P: Keywords created since upgrading to 11.2 are not coming up as auto complete suggestions

12 Votes
Community Beginner ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Issue: Keywords created since upgrading to 11.2 are not coming up as auto complete suggestions in the add keywords field when keywording an image.

 

Lightroom Classic Version Number: 11.2

OS Version Number: Windows 10 v21H1 & v21H2

 

Steps to reproduce:

Step 1: Create a new keyword in the catalogue.

Step 2: Select an image and start to type the keyword into the add keyword field in Keywords section.

 

Expected result:

The new keyword should automatically appear as an auto complete suggestion when adding keywords to an image.

For example, keywords ‘car’ & ‘caravan’ exist in my my catalogue prior to updating to v11.2. Now after upgrading to 11.2 I now add a new keyword ‘carousel’ I would expect all 3 of these keywords to appear after typing ‘ca’ into the add keyword field. However, only ‘car’ & ‘caravan’ show and ‘carousel’ is missing.

Keywords added prior to v11.2 are working but new ones added in 11.2 are not.

This happens on both my workstation and laptop (separate catalogues). I checked and this was working in v11.1.

Bug Fixed Locked
TOPICS
Windows

Views

2.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 4 Correct answers

Explorer , Apr 21, 2022 Apr 21, 2022
@johnrellis After an update, the version is 11.3, fortunately the bug we are talking about is eliminated  This topic is not relevant anymore for those who update from 11.2 to 11.3.

Votes

Translate

Translate
Adobe Employee , Apr 11, 2022 Apr 11, 2022
Updates to the Adobe Photography Products were released today and contain a fix for this issue. Please install the update via your Creative Cloud Desktop App or your respective App Store.    Note:  You may need to refresh the Creative Cloud App for desktop software to show an update available.  ([Ctrl/Cmd]+[Alt/Opt]+ [ R ]) For Mobile downloads, it may take several days for the update to appear in your respective App Stores.   Thank you for your patience. 
Status Fixed

Votes

Translate

Translate
Adobe Community Professional , Mar 06, 2022 Mar 06, 2022
Confirmed bug - see link. Moved to bugs and closed by Mod.

Votes

Translate

Translate
Adobe Employee , Feb 10, 2022 Feb 10, 2022
I can reproduce this issue and have logged a bug with the team. Thanks for your report!
Status Acknowledged

Votes

Translate

Translate
53 Comments
Adobe Employee ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

I can reproduce this issue and have logged a bug with the team. Thanks for your report!

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Acknowledged

Votes

Translate

Translate

Report

Report
New Here ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

I updated to the latest Lightroom Classic (2-9-2022) from Mac Big Sur 11.6.3 and I have been doing face reconition and I use to be able to start typing the first letter of the name and it would show all names I have already put in, the more I typed the name, the more accurate the results. Since update, I start to type the letter of the name, it doesn't show all the names that start with that letter and as I type more of the name nothing changes, even if I type the whole name. Is there a setting now I need to change to get correct results of names? Thanks for any help,

Tim 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Is this only failing on new names being entered or failing on names entered prior to 11.2?

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Both new names and old names.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Only new names for me, previously entered ones auto-complete fine

Votes

Translate

Translate

Report

Report
New Here ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

I've lost auto completion of text in the keyword tags field. What to do?
"Auto completion of text in the keyword tags field" in preferences is checked.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

In the past, you could clear up problems with auto-complete of keywords by deleting the file "<catalog> Helper.lrdata".  But now, deleting that file and restarting LR lets you auto-complete existing keywords but not newly added ones.  

 

That observation leads to this workaround, which I don't recommend:

 

1. Exit LR.

 

2. Do these commands:

cd path-to-catalog-folder
rm -rf catalog\ Helper.lrdata
touch catalog\ Helper.lrdata
chmod 555 catalog\ Helper.lrdata

(These are Mac OS commands. I haven't tested the equivalent on Windows.)

 

3. Restart LR.

 

This creates a dummy Helper.lrdata file that LR isn't able to read or write.  Now, auto-complete of keywords works correctly.

 

However I don't recommend this, since the performance of LR could suffer, not just with keywords, but with displaying folder counts on startup. There may be other bad side effects as well.

Votes

Translate

Translate

Report

Report
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

I've been archiving and keywording my lightroom catalogging, and after I updated to 11.2 release, the keywording doesn't autofill after I put in a new keyword. 

 

I've already checked the preferences the auto keyword is on, as well as in the catalog settings. 

 

The only fix that I've been able to find is to delte my helper file, and the new keywords I put in previously will show up. However new words won't work, so I'd have to quit lightroom, and then delte the helper file, and then the new word I entered will automatically show up in keywords.

 

Anyone have any idea how to fix this? or is it a bug in the new release?

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 16, 2022 Feb 16, 2022

Copy link to clipboard

Copied

As you can see by the correct answer at the top of the thread your post was merged into, Adobe has acknowledged this bug with 11.2. There is currently no known safe workaround.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Having the same problems. Causing significant pain with my customer list.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

I worked with Adobe online for several hours yesterday. They gave up, and I  did also went back to 11.1 works great. Have to wait for the BUG Fix before going back to 11.2. 

Votes

Translate

Translate

Report

Report
New Here ,
Mar 03, 2022 Mar 03, 2022

Copy link to clipboard

Copied

keyword auto suggestion is not functioning for newly created keywords.  The keyword shows in the keyword     list but i cannot type first few letters of keywork and have the work auto fill or suggest?

Votes

Translate

Translate

Report

Report
New Here ,
Mar 03, 2022 Mar 03, 2022

Copy link to clipboard

Copied

Wenn ich ein Gesicht mit dem Rahmen markiere und dann zu tippen beginne, bekomme ich ein Prompt mit Vorschlägen der bereits erfassten Namen. Das funktioniert auch bei alten Namen, die ich früher erfasst habe. Wenn ich allerdings einen neuen Namen erfasse, erscheint der nicht mehr im Prompt und ich muss ihn vollständig neu eingeben.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 03, 2022 Mar 03, 2022

Copy link to clipboard

Copied

Welche Version verwendest Du (Nummer)?

Versuch mal, ob es hilft die preferences zurückzusetzen:

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

 

Votes

Translate

Translate

Report

Report
New Here ,
Mar 03, 2022 Mar 03, 2022

Copy link to clipboard

Copied

Sollte die letzte Version sein: 11.2

Preferences zurücksetzen hat leider keine Auswirkungen gehabt.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 04, 2022 Mar 04, 2022

Copy link to clipboard

Copied

Vielleicht hängt es auch mit der Anzahl der Namen zusammen. Ich habe einen neuen Katalog angelegt und einen neuen Namen angelegt, und da funktioniert der Prompt einwandfrei.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 04, 2022 Mar 04, 2022

Copy link to clipboard

Copied

I see the same issue, but only on keywords created after the update

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 06, 2022 Mar 06, 2022

Copy link to clipboard

Copied

Das Problem wurde in der Zwischenzeit von Adobe bestätigt und wird gefixt. Wann? Das weiss nur Adobe.

https://community.adobe.com/t5/lightroom-classic-bugs/p-keywords-created-since-upgrading-to-11-2-are...

 

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 06, 2022 Mar 06, 2022

Copy link to clipboard

Copied

Confirmed bug - see link.

Moved to bugs and closed by Mod.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 06, 2022 Mar 06, 2022

Copy link to clipboard

Copied

Danke für die Info. Dann warten wir auf hoffentlich baldigen Fix. 😉

Votes

Translate

Translate

Report

Report
New Here ,
Mar 06, 2022 Mar 06, 2022

Copy link to clipboard

Copied

Hi Folks, this is as annoying one 🙂 

I have a bit of a work around, not a great one but i think it's safe enough. I have been exporting the keyword list, then adding new keywords to the text file, then importing the edited text file back into LR, the new words then work with the Auto complete. A bit long winded I know, but sometimes quicker than having to re-type keywords. Hopefully helps some-one, while we wait for a fix.

Cheers

Doug

Votes

Translate

Translate

Report

Report
New Here ,
Mar 06, 2022 Mar 06, 2022

Copy link to clipboard

Copied

Recently, I find that after I create a new people keyword for a new face, that name is not suggested when I start typing it for that same person on a different photo. Many existing names continue to be offered. It appears that the missing names are the most recent. BTW, the new entries are being entered and visible under Keyword List/People, they are just not being suggested. Any guidance would be gratefully accepted?

 

Lightroom Classic 11.2

Mac OS X 11.6.1

Votes

Translate

Translate

Report

Report
Explorer ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

I too seem to have this issue with windows 10 set also. I also dont see new names but older ones appear

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

Confirmed bug - will be fixed - before you ask ... only Adobe knows when.

[moved/merged by mod.]

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 07, 2022 Mar 07, 2022

Copy link to clipboard

Copied

@douglasa45458059 wrote, "I have been exporting the keyword list, then adding new keywords to the text file, then importing the edited text file back into LR, the new words then work with the Auto complete."

 

Note that it isn't necessary to export the keywords. You can just make a new  text file, with one new keyword per line. When you import the file, those keywords will be added, leaving your existing keywords untouched.

Votes

Translate

Translate

Report

Report