• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
23

P: Noise reduction effect not displayed in Develop mode

Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

Noise reduction effect not displayed in Develop mode when image is smaller than 1:1. Enlarged is ok, but when I set FIT or FILL, image displayed without noise reduction settings applied (I think so).

Bug Won't fix
TOPICS
macOS , Windows

Views

219

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 108 Replies 108
108 Comments
LEGEND ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Don't try and justify this change by saying we should be zooming in on every picture. We want the effect (approximation or not) that was enabled in the previous version, what possible reason do they have to remove it?
 

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

None of the 3 options make any difference at all to me.  It still wont render noise reduction or sharpening on fit or fill.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

It's the same for me too: None of the 3 options made any difference to me.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

I've got the same issue, but I'm on a MacBook Pro 15" Late 2016 with macOS Sierra 10.12.6

I can't see how it's a driver issue if it's across macOS and Windows?

Turning off the "Use Graphics Processor" option resolves the issue.

Votes

Translate

Translate

Report

Report
Participant ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

No problem for me, tried several Sony A7(R2) raws with Lightroom Classic CC on macOS Sierra 10.12.6, pulled the Luminance slider back and forth between 0 and 100 % and clearly saw the effect in the "Fit" view. I applied this fix (marked as official for a different issue).

Votes

Translate

Translate

Report

Report
New Here ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied



When applying noise reduction to an image you can only see the noise reduction tale effect if your zoomed in to 1:1. When you zoom out again the noise reduction is not applied.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Just to update, the latest Nvidia drivers came out today, ive installed them and the same issue so thats 4 sets ive tried now.
Im firmly convinced this isn't a driver issue - its a lightroom issue.  Especially as it effects both windows and apple (which is rare).
Its also not just noise reduction - its sharpening not updated as well (but thats harder to see on fit and fill than NR is).

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Instructions did not work for me. Setting GPU preferred system = "OpenGL" changed "Metal" to "OpenGL" in Performance tab but noise reduction effect not displayed anyway. macOS 10.13 (completely updated), GT650m.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

UPDATE: So I've trying different things and here is what I see,

1:1 vs 1:2 vs 1:3 vs 1:4
NR results shown in 1:1 1:2 and 1:3 but not in 1:4.

Camera Calibration
There are 4 process version under camera calibration. The current version is 4 and I am guessing the previous version(before updating to LRCCC) was 3. NR results shown in only version 2. Not even version 3 😐

Moving sliders very fast 🙂
When I move any slider(even HSL sliders) real fast, when the slider is moving, the NR results show. Then it almost instantly goes away. Its almost as if it is being rendered to look crappy.

Camera
Raw
I tried RAW files from my 5Dm4(30mp), X-E1(16mp) and 70D(20mp)....guess what...the 70D files work just fine!!!! This is really frustrating cos I only upgraded to the 5dm4 about a month ago.
 
As for the Fuji, I usually don't shoot raw with my xe1, so dont know if this issue was present with the Fuji RAW before LRCCC...maybe its an xtrans thing. Then again, the 5dm4 RAWs may be weird because of the Dual Pixel Raw option(although i am not using DPR)

Anyone else seeing the above?

Please please tell me that people with this issue are not 5dm4 users. That would almost be funny...unfortunate, but funny.

All my drivers are up to date. I'm using windows 10 and GTX driver 388

Tomorrow m gonna hook up the PC to the TV(4K) via hdmi(no DVI) and see what happens.

On a side note, my monitor is 1920x1200 and I changed resolution to 1920x1080 + restart. Lightroom wont even open. It just kept crashing.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Tried different images. Cropped file to 2606 x 1737 - NR displayed correct in FIT. Cropped file to 4386 x 2467 - NR not displayed in FIT.

Votes

Translate

Translate

Report

Report
Mentor ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

You can't see noise reduction if your images are only displaying at 25%. Noise is a per pixel change in an image and there's no way to see how reduction works unless you're at 100%.  

Votes

Translate

Translate

Report

Report
Mentor ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Your 5D files are 6700px wide and your display is 1920... that's why you can't see the noise reduction. Noise is 1px wide and when you fit, you're only seeing 25% of your image. There's no way to see NR at that scale... that's why there's a viewer in the Details panel.

Votes

Translate

Translate

Report

Report
Mentor ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Try this with your 5D images... use the slider in Develop to zoom 1:3, then 1:2. Can you see the NR? The point at which you can see the effect is the minimum zoom at which NR is visible.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

@eartho, I am understood Your explanation, but I see a big difference between old LR6 (CC) and new LR Classic. By the way, I clearly see noise reduction effect on my Mac book retina display even at 25%.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

I see your point but you are missing a key point everyone is saying - before LRCCC this was not an issue.

I certainly didnt have this issue LR6. This is a post LRCCC issue visible to some users.

Also, your arguments is true to all settings...not just NR. Highlights, shadows, blacks whites, tone curves etc.....they are all done at 1px wide and everything is an approximation at "fit" view because, technically lightroom can not show true highlights, shadows, blacks, whites, tone curves etc at "fit". 

 

Votes

Translate

Translate

Report

Report
Mentor ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Noise reduction and sharpening are completely different than those other adjustments. That little ! in the details panel has been there since v1 or 2 so that people would understand why their images don't look right at Fit view.

Everyone's been complaining about speed for years now and the main contributor to sluggishness in Develop has always been the NR. I imagine to speed things up they've modified the render so that it's not wasting cycles to display an incorrect view. 

Again, there's no point in looking at NR when zoomed to fit. You HAVE to be viewing at 1:1 or looking at the Detail panel preview.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

I disagree. Light, shadows, whites and blacks directly show dynamic range, and if it can not be approximated correctly at "fit", there would be obvious banding across all images. Everything at "fit" is an approximation and maybe adobe decided to drop NR approximation for what ever reason in the new version.

I have never had performance issue with noise reduction. If anything, the performance issues were more prominent in filters, masks and spot removal.

Also on the "!" it says "for more accurate....." which means there is an less accurate, but still visible NR at "fit"....which it doesnt have anymore.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

Except you can see NR in fit and fill modes, you've been able to see the estimate of it for the last few years in lightroom and you can still see it if you turn off GPU acceleration in the menu.  Its a bug.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

Same problems here on macOS High Sierra and LR Classic (macbook pro and iMac). A lot of images show high color noise in Develop module. When switching to Library module the are OK. The whole detail panel (sharpness and noise reduction) doesn't work then.

I tried to find our what's the reason (and please don't tell me I have to view on a certain percentage to not have the color noise). Some images I have set high WB values. When I reduce WB noise goes away and noise sliders work as usual. The break point was 20.401. Might be just by accident. But then I also have images where WB doesn't play a role with color noise. When I reset the tone controls noise also goes away.

Other than this buggy behavior I don't see any improvement of the new develop process (OK, the numbering). I'm a bit angry as I now spent several hours of beta testing instead of being productive. Any quality control for LR classic at Adobe?

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied



After I upgraded from Lightroom CC to Lightroom Classic CC all my images look grainy. Even when shot at ISO 100. It is really disturbing and I'm not sure what to do. I never had that issue with older LR versions. I updated older catalogs and the issue is the same with those photos. Images that looked great are all grainy now. 

Also, LR Classic crashes at least 4-5 times while editing a wedding. So annoying. Anyone having similar issues? Or know how to correct them? 

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied



Along with other problems in the new LR Classic, my images are grainy in Develop but not in Library or during export. The develop module overall has been extremely slow to respond to sliders. 

I run MacOS El Capitan with 32GB RAM. 

Anyone know how to fix this issue? Thank you in advance!

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Spoke to the tech support guy today. They said my GPU doesnt support LRCCC. I think its ludicrous that a GTX Titan doesnt support LRCCC. Weighing up option elsewhere, Capture ONE, DXO and ON1. Hopefully Adobe will have a solution or a better answer by the end of the year. At this point Rawtherapee is better than LRCCC. It doesnt support GPUs....but its free and I know what I'm getting.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

I dont think they decided to drop it because it works without GPU acceleration so clearly the feature is still there, just doesn't work any more.  Also nothing in the changelog or notes about it so im going for bug.
Im gathering eartho doesnt use the features which is fair enough, everyone has a different workflow.  However for me the approximation is "near enough" to get me started and culling and serves as a quick way to make adjustments before going in to 1:1.  Its a big part of my overall workflow (and id argue you cant see how an image looks overall scrolling across it in 1:1 looking at snapshots in a zoomed window)
Quite simply, the feature worked perfectly on the previous version and still works now without GPU acceleration.  Unfortunately, turning GPU acceleration off makes the already fairly poor performance even worse so its not a satisfactory work around.

As a side question, is anyone experiencing this bug with an accelerated GPU that ISNT nvidia? (AMD etc)? 

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

It has been confirmed as a bug

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Its garbage, reading this thread alone people are using many different GPUs ranging from 1-2 years old to released a few months ago and have the same issue.
The odds on all these cards (which dont forget ALL previously worked on lightroom) suddenly not supporting it are remote.  Its most likely that LRCC doesnt support THEM.  Which given it used to means its a bug.

If that is the official support response im very disappointed as they clearly haven't read this thread or collated any information at all and seem to be content to ignore the problem.  What we have here is a repeatable with 100% accuracy issue affecting a large variety of video hardware on many different drivers and rarely for bugs, exhibits on both PC and Apple.  All of those hint to a code issue.

Capture 1 is looking more and more tempting albeit its more expensive.  The main thing holding me back is the nightmare of converting, changing over and learning a new work flow.  That and i still need PS for some tasks so its an additional cost per month rather than a replacement.

Votes

Translate

Translate

Report

Report