P: Preference Treat dot/slash As A Keyword Separator doesn't work on import

2 Votes
LEGEND ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

The Preference options File Handling > Treat dot/slash As A Keyword Separator doesn't work on import, though it does work with the menu command Metadata > Read Metadata From File.  To reproduce:

 

1. In Preferences > File Handling, set the options Treat dot/slash As A Keyword Separator.

 

2. Import the two attached files slash.jpg and dot.jpg. They contain the following metadata fields:

 

$ exiftool -a -G -xmp:subject -iptc:keywords -xmp:hierarchicalsubject dot.jpg slash.jpg 
======== dot.jpg
[XMP]  Subject  : A.B.C
[IPTC] Keywords : A.B.C
======== slash.jpg
[XMP]  Subject  : A/B/C
[IPTC] Keywords : A/B/C

 

 

3. Observe the following incorrect keywords that were created and added to the imported photos:

johnrellis_0-1650818583369.png

 

4. Select the two photos and do Metadata > Read Metadata From File.

 

5. Observe the photos now have the correct hierarchical keyword A > B > C applied:

johnrellis_1-1650818678880.png

 

Tested on LR 11.3.1 / Mac OS 11.6.2.

Bug Unresolved
TOPICS
macOS , Windows

Views

90

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
3 Comments
New Here ,
Apr 23, 2022 Apr 23, 2022

Copy link to clipboard

Copied

When importing a keyword containing a slash character, there is normaly an option which tells Lightroom to handle it as a hierarchy, in the same way as it does it for ">" or "|" separators.

This option can be activated through : Edit>Preferences>File Handling  - Reading Metadata : Treat "/" as keyword separator.

This worked perfectly up to Lightroom CC 2015, and does not work anymore for later versions, although the possibility is still displayed.

I need to migrate to Lightroom about 30 000 with all the metadata, but I need to preserve the hierarchy of keywords.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

I hadn't used that option since LR 3 when I migrated to LR, but I too see that it is broken.  I filed a bug report here:

https://community.adobe.com/t5/lightroom-classic-bugs/preference-treat-dot-slash-as-a-keyword-separa...

 

Please add details about how this affects you to the bug report and click Upvote in the upper-right corner.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

LATEST

A workaround:

 

1. Set the option Preferences > File Handling > Treat slash As A Keyword Separator.

 

2. Import the files into LR.

 

3. Select all the newly imported files and do the menu command Metadata > Read Metadata From Files.

 

4. Do the command Metadata > Purge Unused Keywords, which will remove all the keywords that aren't assigned to any photos.  Be careful here: If you already have a "controlled vocabulary" in the catalog with a carefully curated hierarchy, and some of the keywords in that hierarchy are currently unused, then don't give this command!  Instead, you'll have to manually remove the top-level keywords containing "/" that were added incorrectly by Import.

Votes

Translate

Translate

Report

Report