P: SFTP with 64-bit Windows broken

4 Votes
Explorer ,
Sep 02, 2011 Sep 02, 2011

Copy link to clipboard

Copied

I've posted ad nauseum about the sftp bug that affects 99% of us that try to use sftp to upload web galleries from our 64-bit Windows version of LR 3.x. I tested 3.5RC and it too has the bug (crash at 50% progress, like clock work). I saw a comment from DT in another forum thread that said the proposed fix was basically too invasive to introduce into 3.x. Can someone from Adobe please confirm or deny that statement? If true, I'll stop testing all subsequent 3.x releases and wait for 4.x. Thanks!

Bug Fixed
TOPICS
Windows

Views

25

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Apr 23, 2012 Apr 23, 2012
Contrary to BStock's post from a month ago, sftp works for me now. LR4 and LR4.1RC. Thanks to Adobe!

Votes

Translate

Translate
7 Comments
Mentor ,
Sep 02, 2011 Sep 02, 2011

Copy link to clipboard

Copied

Is DT Dan Tull? He is from Adobe.

Votes

Translate

Translate

Report

Report
Contributor ,
Sep 06, 2011 Sep 06, 2011

Copy link to clipboard

Copied

Yeah, unfortunately it looks like this fix won't be applied to the 3.x dot releases, though I believe it is confirmed fixed in internal 4.0 builds even now.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

Whenever I try to connect via SFTP protocol getting an error "Cannot browse the FTP server, because an unknown error occurred.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

LR4 - I'd hoped that SFTP exports would finally work, but it does not as with LR3.

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 23, 2012 Apr 23, 2012

Copy link to clipboard

Copied

What's the status of sFTP in Lr4.1RC?

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 23, 2012 Apr 23, 2012

Copy link to clipboard

Copied

Contrary to BStock's post from a month ago, sftp works for me now. LR4 and LR4.1RC. Thanks to Adobe!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 01, 2013 Feb 01, 2013

Copy link to clipboard

Copied

LATEST
In December I switched ISPs to GoDaddy. At that point my LR 4.3 sFTP gallery uploads began failing at about 65% complete. With the help of GoDaddy's senior tech support and security teams, it was determined that Lightroom's login behavior on the backend is rapidly opening and closing sessions which is triggering security routines designed to stop a denial of service attack. This results in my IP address being blocked for 10 minutes and LR reporting that the upload failed. While there is a chance my ISP could be involved in this behavior, it is likely an application behavior trait.

GoDaddy has provided a snippet from the security log showing sessions being opened and closed within seconds while uploading an HTML gallery of about 35 pictures. Additionally, running netstat on my Win 8 64 bit system shows Lightroom generating 26 connections to GoDaddy with 1 connection ESTABLISHED and all others in TIME_WAIT status.

Is this normal behavior for LR? GoDaddy says the behavior they see is not congruent with their security and they cannot address my inability to upload from LR. If this does appear to be an issue with LR, the GoDaddy CEO team is willing to get on a conference call with Adobe development to provide further details as to what they see.

Is this the best forum to be addressing this issue?

Votes

Translate

Translate

Report

Report