P: Watermark: Italic & Bold Transposed

10 Votes
Community Beginner ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

In the latest version of Lightroom Classic in the watermark panel. Click Italic and you get bold and visa versa. Noticed this after the update to the new version. My water mark had gone from Italic to bold.

(Windows)

Bug Investigating
TOPICS
macOS , Windows

Views

232

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
42 Comments
New Here ,
Jan 30, 2021 Jan 30, 2021

Copy link to clipboard

Copied

Same here.  Using Book Antiqua font (which I had as a preset) but now just defaults to a generic standard font.  Just tried a number of different ones but with no success.  See this is pretty much 3 months since this was highlighted but appears nothing has been done yet to resolve this issue.  Disappointing!

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 30, 2021 Jan 30, 2021

Copy link to clipboard

Copied

Totally disgusted!    It cannot be rocket science to get italics back up & running.   

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Hello Rikk.

How is it going with fixing the bug? 

I am doing species name in Latin, and they have to be itallic

Br Jørn Ari

Votes

Translate

Translate

Report

Report
New Here ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

I'm now on version 10.2 in April 2021 and italics are still not working!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Same issue. I reported this issue > 6 months and nothing happens. I'm quite surprised.

Votes

Translate

Translate

Report

Report
Guru ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Just a side comment here: it is a good idea to check which typefaces even have any "designed" italic (or bold, or bold italic) variant installed as a font file. Especially with more unusual looking ones - including script faces - no "italicised" form may have been intended by their designer. A handwriting style font is already in some senses "italic".

 

Similarly the basic form of each typeface design is considered such-and such Regular (even if it does not say so), and will group with a corresponding Bold, Italic and Bold Italic typically. But such-and such Light, or Book, or Script is separately grouped and will not necessarily 'know' what best to use when the user asks for a Bold option.

 

In most software - MS Word or whatever - you can assign any typeface you like an italic override, bold or both. When a proper font file is not present, a "faux" sloped / thickened version is fudged instead and usually that looks awful. Some more typographically scrupulous software will simply not show any "faux" version.

 

It's strange though. While some faces mentioned (such as Papyrus or Segoe Script) can IMO be expected problematic to override to italic (since there is no 'Papyrus Italic' font file; while Segoe Script has only got 'Regular' and 'Bold')...

 

...some typefaces mentioned, such as Book Antiqua, should have all needed variants present as standard. I guess the sizing of a particular text string can change considerably with a "designed" font variant - which raises a separate complication for LrC watermarking. 

 

Consider e.g. the very differing widths of the letter shapes in this illustration:

Screenshot 2021-04-29 083618.jpg

If that is a properly defined font file then really LrC should cope with this IMO, but maybe it would be more accurate to offer all of the genuine font files available in a single list, rather then offering a list of faces plus style overrides. 

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

What is most upsetting is that talics on all fonts did work in all prior versions of LR. So fixing the issue could be as simple as rolling back that section of code to the last working version.



Sent from my Android device with K-9 Mail. Please excuse my brevity.

Votes

Translate

Translate

Report

Report
New Here ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Well you are likely very correct in that not every font is designed to be used as Italic.

However, as many have mentioned above, this is something that has worked fine in earlier versions, so why it stops functioning in a later version remains a mystery.

Also, there is no logical reason whatsoever to change the font totally to Arial when you have selected another font and Italic.

Moreover why Adobe fails to fix such a simple matter is a mystery as well. We are paying dues for regular updates..

In my case I used to use Lucida Handwriting Italic as my signature. Hundreds of pictures went out published with plain and very unpersonal Arial instead of the font selected by me.

A watermark is a photographers signature and where he publishes his name! How it appears is not unimportant!

I really expect Adobe to fix this as we are now approaching a full year with this obvious ugly bug!

 

Best Regards

 

Wolfram Meyer not Wolfram Meyer

Sol 2021-05-22 Solbacka-8.JPGBro 2020-08-19 Hazze-Tobias-2.JPG

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 15, 2021 Aug 15, 2021

Copy link to clipboard

Copied

On watermarking, I'm using Centery Schoolbook, Bold Italic.  When I check the Control Panel, the Font and Style are available.  Why isn't it working?  It worked before this problem first appeared before the Pandemic started and then started converting to Arial near the end of 2019 or earlier.  Its been almost two years, please fix this or at least let us know which properties are allowed.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

2 years has passed, still no fix. not sure if there is anyway to escalate this to Adobe?

 

I did create a ticket once but got the response that it's pending in the queue and the team will be checking based on priority. I assume this is a very low priority one.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

I gave up on waiting for a fix!

I can create a signature 'Graphic' PNG in Photoshop that can use any text font capability in Photoshop without limitations, even including efex like stroke and drop-shadow, etc. Do it once, and you have the Watermark you want in Lr-Classic.

 

 

Regards. My System: Lr-Classic 11.1, Photoshop 23.1, Lightroom 5.1, Lr-iOS 7.0.2, Bridge 12.0, Windows-10.

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

Yes,  I gave up back in November.  Created graphic and have been using that since.

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

Specifying italic or bold italic text watermark has been broken since v10.

That is getting on for two years, .... and still broken in v11.

 

Disappointing is an understatement.

Paul.

 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

I'm running into the same problem with Italic Watermark. It's worse than just dropping the Italic style: it also changes the font. Can we get an update on when this will be fixed?

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

There's quite a few people on this thread saying "Me too" but only 3 votes at the top, so if you're affected, please go hit that button as it affects the priority given to fixing it.

-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

LATEST

I think i found a bug on text water mark in Lightroom 11.1 (Windows 10, spanish).
When selecting any font and setting the style to italics the text is shown in regular Adobe Clean font, but Dropdown menus still show my selected font and italics. Screenshot is attached. It happends with any font.

 

When editing Lightroom's identity plate I can use the italic version, or in Photoshop and any other software on my computer. So is not a limitation in my PC.

Votes

Translate

Translate

Report

Report