P: Wrong GPS coordinates on videos

2 Votes
LEGEND ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

I recently came across an issue with the GPS coordinates of my videos in Lightroom Classic 10.3.

 

I have my camera paired with my smartphone so that all my photos and videos have GPS coordinates.

 

For my photos, Lightroom Classic works exactly as expected. The coordinates are correctly read from the EXIF data and I can see on the map more or less exactly where each shot was taken.

 

It's a different story with videos, however. I just recently imported a batch of 9 videos. When I opened the map module, all 9 videos were in exactly the same location. (This location was not on my route but it wasn't too far away either - about 50 KM from where I was walking. But it's somewhere I've never been before.)

 

Investigating further, I opened some of the video files in EXIF tool to check the GPS coordinates. Each of the nine videos in fact had unique coordinates and, after double-checking in Google Earth, I found that these coordinates were accurate. This leads me to believe that this is an issue with Lightroom Classic reading the GPS coordinates from the EXIF data. Furthermore, I also noticed that the seemingly random location Lightroom assigned to my videos was in a different format to the one normally used by the camera.

 

I have not experienced any such issues with photos. Lightroom seems to correctly read the coordinates for the photos. Even when importing a batch of both photos and videos, the photos have the correct GPS coordinates while the videos are grouped together somewhere random. This is all using the same camera (Fuji XT4).

 

I've already posted about this issue in this thread, where another forum member was able to corroborate my findings. This indeed seems to be a Lightroom bug.

 

You can find a sample video here to help you re-create the bug.

 

Please let me know if I can provide any further information.

Bug Investigating
TOPICS
macOS , Windows

Views

168

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
13 Comments
New Here ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Hello,

 

I recently came across an issue with the GPS coordinates of my videos in Lightroom Classic.

 

I have my camera paired with my smartphone so that all my photos and videos have GPS coordinates.

 

For my photos, Lightroom Classic works exactly as expected. The coordinates are correctly read from the EXIF data and I can see on the map more or less exactly where each shot was taken.

 

It's a different story with videos, however. I just recently imported a batch of 9 videos. When I opened the map module, all 9 videos were in exactly the same location. (This location was not on my route but it wasn't too far away either - about 50 KM from where I was walking. But it's somewhere I've never been before.)

 

Investigating further, I opened some of the video files in EXIF tool to check the GPS coordinates. Each video in fact had unique coordinates and, after double-checking in Google Earth, I found that these coordinates were accurate. This leads me to believe it's an issue with Lightroom Classic reading the GPS coordinates from the EXIF data. Furthermore, I also noticed that the seemingly random location Lightroom assigned to my videos was in a different format to the one normally used by the camera.

 

I have not experienced any such issues with photos. Lightroom seems to correctly read the coordinates for the photos. Even when importing a batch of both photos and videos, the photos have the correct GPS coordinates while the videos are grouped together somewhere random. This is all using the same camera (Fuji XT4).

 

Has anyone else noticed this or had similar issues with video GPS coordinates? Any ideas what the issue might be or what I can do to fix it?

 

Thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Please upload a sample video to Dropbox or similar and post the sharing link here (don't use Youtube, since it will discard the metadata).  I can then see if this is an instance of a known bug or some other problem and perhaps suggest a workaround.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Thanks for getting back to me John.

 

I've uploaded one of my videos to OneDrive here.

 

Please let me know if this helps or if you need anything else.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Sorry, please use this link instead.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

The forum software won't let me reply to you with details. I'll try send you a private message instead.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

It's clearly a Lightroom bug. Notice how Lightroom 10.3 incorrectly displays the coordinates of the imported video:

johnrellis_0-1624386233771.png

 

60" (60 seconds) isn't valid in degrees/minutes/seconds format -- you can't have 60".

 

I've poked inside the file, and it appears the coordinates are recorded in an industry-standard format but different than how most apps record coordinates.  For Quicktime video, popular cameras and apps use the Quicktime metadata field GPSCoordinates, whereas this video is using the EXIF GPS metadata fields.  That's probably why this bug hasn't been discovered until now.

 

Please post a bug report in the official Adobe feedback forum, where Adobe wants all bug reports and feature suggestions:

https://www.lightroomqueen.com/send-bug-report-feature-request-adobe/

 

Be sure to include the first ten lines of the menu command Help > System Info. Provide all the details, including the link to the sample video, rather than linking back to this thread -- experience shows that Adobe developers tend not to follow the links. Product developers read everything posted there, but rarely participate here, which is primarily a user-to-user forum.

 

To workaround the bug, remove the video from the catalog and use Exiftool to rewrite the GPS coordinates in a different internal representation:

 

exiftool "-gpslongitude<gpslongitude" "-gpslatitude<gpslatitude" DSCF3287.MOV 

 

Then reimport the video.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

My reply made it finally, after many tries and three browsers over 12 hours.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Thanks for looking into this issue.

 

I had suspected the issue lies with lightroom but it's good to have that corroborated. As I mentioned, the GPS coordinates for photos work just fine using the same camera.

 

I will follow your instructions and post this issue to the forum you indicated.

Votes

Translate

Translate

Report

Report
Participant ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

Why are you using a photo editing app for videos? You should be using Premiere or...

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 23, 2021 Jun 23, 2021

Copy link to clipboard

Copied

For the sample video, Exiftool displays the coordinates as:

46 deg 4' 25.18" N, 23 deg 34' 25.97" E

while LR displays them incorrectly as:

46°0'60"  23°0'60" 

The 60" clearly indicates a bug in LR.

johnrellis_01624386233771-cfb8b1bb-1b3b-4602-b9e9-f5ec536cb9cd-366460523.png

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

Hey, 

Thanks for reporting this issue. We shall look into it further.

Regards,

Sumeet

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied

The bug is still there for mp4s from a Pixel phone in Lightroom 11.1…

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied

LATEST

Votes

Translate

Translate

Report

Report