Abnormal Behavior With LR and PS

Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

I just started having a few issues with LR and PS two days ago that I can't figure out how to correct. 

 

1) When I choose Masking in the LR develop module, the "Add New Mask" tools such as "Subject", "Brush", "Gradient", etc do not always display.  I have to go under the "Tools" menu to select what I need to work with.   The options including add to or erase from were always displayed as well but not now.

2) When I send a RAW file to PS by way of COMMAND E, the file goes but it doesn't ask me which of the three choices to use such as "Open A Copy With LR Adjustments".  

3) When I finish my edit in PS, I save and then close the file.  When I go back to LR, the file is there as a TIFF but it often will not open in the Develop module.  I have to go back to the Library module, click on the folder that the image is in and then select the file and go back to the Develop module.  Also, I often color code the file and add it to a collection folder as a select.  This is my workflow and have been doing it for years but now I can't do this until I go to the folder in the Library module where I have to find the TIFF and then I can color code it and add it to a collection.

4) In LR, when I use COMMAND + to zoom in on an image, I am pretty sure I used to be able to use COMMAND 0 to zoom the image back to fit on screen.  This no longer works.  It works in PS but not LR.

 

Did I do something to create these issues?  Is anyone experiencing anything similar?  I have rebooted the programs and my computer several times to no avail.

 

I am using a Mac running Monterey 12.1/ LR Classic 11.2/ PS 23.2.2

I am using collections to organize my photos.  Any ideas would be greatly appreciated.  Thank you.

TOPICS
Cross-app workflows , macOS

Views

69

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

  • For brush, press K. For Linear gradient, press M.
  • The dialog with three choices only appears for rendered files, like jpg or tff. Raw files open silently in the Camera Raw plugin where adjustments from Lightroom are applied to a new file, which opens in Photoshop.
  • If you press Cmd + E in Develop, the file from Photoshop should open in Develop.
  • Cmd + 0 and 1 do different things in Lightroom, they show/hide the Histogram and the Basic panel. Click in the image to toggle between Fit and 100%.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Thank you for the reply Per Bernstsen.  Yes, if I press K or M, I do get those options.  However, it has always been that when I select Masking, all the options would appear in the window under the tool.  I use Select Subject very often and now I have to go the Tools menu to activate it.  I am finding that I have to go to the Tools menu to add a second or more masking tool to an image or to Add To or Subtract From a mask.  These options were displayed as a Plus and Minus sign but now for those I also have to go under the Tools menu. 

 

Thank you for clarifying the dialog with the three chices when going from LR to PS.

 

I'm still having issues after saving a TIFF from PS.  It automatically appears in the Develop module in LR but I can't color code it or add it to a collection until I click on another folder and then come back to the folder that the image is in.  Also, if I make edits, the edits don't stick so I have to do the same as before which is go to the Library module, find the image and then go back to the Develop Module. 

 

It's very strange that all these issues appeared at the same time.  Perhaps I did something without realizing it and changed the way LR handles images from PS?  I am so confused.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2022 Mar 26, 2022

Copy link to clipboard

Copied

LATEST

Press Shift + W to open the Masks panel with the menu. There is no direct shortcut for Select subject.

If the masks panel is misbehaving, try resetting the Lightroom preferences, which might also fix the problems you're having with tiffs coming from PS.

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines