• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Auto Write changes to XMP not working properly'

Explorer ,
Jun 19, 2024 Jun 19, 2024

Copy link to clipboard

Copied

Hi All,

 

I am running LR Classic 13.3 and I have the option selected to Automatically Write Meta Changes to XMP files.  I still get the prompt that it's writing changes to XMP files when I exit even if I have had LR sitting idle for hours.  LR used to just instantly update the XMP files so when I exited I didn't have to wait.  It's as if LR is now cycling through the XMP info stored in it's system to see if anything has changed, even if I just open LR and immediately close it without making any edit whatsoever.  This is very inefficient. 

 

Why isn't the Auto Write Met changes to XMP option not working as expected? 


Thanks,

Randy

Randy Brogen, M.Photog.M.Artists.Cr., CPP
TOPICS
Windows

Views

106

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2024 Jun 20, 2024

Copy link to clipboard

Copied

Others have reported similar to yourself. Please, try switching off 'Automatically Write Meta Changes to XMP files', and let us know if it helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 23, 2024 Jun 23, 2024

Copy link to clipboard

Copied

LATEST

It occurs to me that you might be tripping over this bug:

https://community.adobe.com/t5/lightroom-classic-bugs/p-save-metadata-to-file-doesn-t-always-set-met...

 

where LR thinks metadata has changed immediately after it saves metadata to the file. If you have set the option Catalog Settings > Metadata > Automatically Write Changes To XMP, then LR will loop infinitely resaving metadata to XMP for all your files.  Part of that process involves read the XMP files as well.

 

To see if you're tripping over the bug,

 

1. Disable Catalog Settings > Metadata > Automatically Write Changes To XMP. 

 

2. In the Library Filter bar's Metadata browser, add the column Metadata Status and select all files that have status Has Been Changed.

 

3. Select all the displayed files and do Metadata > Save Metadata To File.

 

4. When it completes, do many of the files switch back to status Has Been Changed? If so, then you're tripping over the bug.


Let us know.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines