Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Bringing together in a catalog folders mistakenly shown in different disk locations

Community Beginner ,
Apr 17, 2021 Apr 17, 2021

Copy link to clipboard

Copied

My external hard drive has a parent folder called "JEK's Lightroom Photos," which contains many subfolders with my photos.  At some point, I screwed up:  In the Lightroom catalog, I see external hard drive (E:) with a "JEK's Lightroom Photos" parent folder containing four subfolders and another parent folder called "Pictures" contaning all the other subfolders. (See the attachment.)  This does not mirror the placement on my external hard drive, where all subfolders are inside "JEK's Lightroom Photos."  How do I get all subfolders inside the same parent folder while retaining the existing LR edits?

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
How to, Problem or error

Views

386

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 18, 2021 Apr 18, 2021
If you [Right-Click] on one of the photo thumbnails that Lightroom is showing in a sub-folder of {Pictures}- and choose [Show in Finder/Explorer]- Where does the File Browser window show you the photo file? It can happen that files have been imported using the [Copy] option and Lightroom has  made reference to the 'copied' files, and not the originals. So LrC 'sees' those 'copies'  in your {Pictures} folder, and you have the 'originals' in your {JEK's Lightroom Photos}  folders. If you do in fac...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

If you [Right-Click] on one of the photo thumbnails that Lightroom is showing in a sub-folder of {Pictures}- and choose [Show in Finder/Explorer]-

Where does the File Browser window show you the photo file?

It can happen that files have been imported using the [Copy] option and Lightroom has  made reference to the 'copied' files, and not the originals. So LrC 'sees' those 'copies'  in your {Pictures} folder, and you have the 'originals' in your {JEK's Lightroom Photos}  folders.

If you do in fact have the two copies, then you could use the [Update Folder location] command to re-direct the LrC catalog links to the {JEK's Lightroom Photos} parent folder.

So let us know if you have the folders & photos in two locations on your hard-drive.

 

Regards. My System: Lr-Classic 10.4, Photoshop 22.5, Lightroom 4.4, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 09, 2021 May 09, 2021

Copy link to clipboard

Copied

Apologies for the delay in replying, due to not getting (or not seeing) the email notification of your comment.  You were exactly right about the problem:  I had versions of the photos both in the "JEK's Lightroom Photos" folders and the "Pictures" folder.  I used the [Update Folder Location] command this afternoon to link each subfolder to its location in the "JEK's Lightroom Photos" folder.  One more question:  When I open some of the subfolders, I can see the photo names in Library, but there is a gray box instead of the preview pic.  If I open a photo in Develop, the preview pic for that particular photo is displayed when I go back to Library.  How do I fix this en masse?  Thanks so much for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2021 May 09, 2021

Copy link to clipboard

Copied

Grey Previews! Well there are several things you can try-

1) 

In the LrC Preferences >Performance tab:  Set the 'Use Graphics Processor' to [OFF]

GPU.jpg

2)

Try setting your default monitor profile to sRGB sRGB IEC61966-2.1 as per these instructions:

https://www.lightroomqueen.com/how-do-i-change-my-monitor-profile-to-check-whether-its-corrupted/

If this works - Ideally then you should calibrate your monitor with a Calibration device (Spyder, colormunki, etc) and create a profile specific for your monitor.

3)

There is the possibility of a corrupt preview files. (The Preview Thumbnails are not showing until updated).

 Lightroom error on preview cache or displays gray thumbnails

Be aware that Deleting the Previews.LRDATA cache will mean that Previews will need to re-build for all files which can take some time.  MENU: Library > Previews > Build Standard Size Previews.

4)

And you need to know for sure that all the photos and folders are correctly linked to the files on the hard-drive folder. If you still see [!] on preview borders, or [?] on Folders then LrC still thinks these are "Missing" and the 'Grey' preview cannot be re-built, as LrC does not know where the 'Original' is located.

 

 

Regards. My System: Lr-Classic 10.4, Photoshop 22.5, Lightroom 4.4, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

LATEST

Thanks so much for your response.  The email notification function for this post must be on the fritz, as I didn't get a notification of this response either, despite checking the "Email me when someone replies" box.  (Yes, I checked my junk mail as well as my inbox.)  Before I saw your response, I had another go at loading the previews by opening each subfolder in the "JEK's Lightroom Folders" folder.  Unlike yesterday, this time it worked.  Who know what was happening yesterday (maybe my woefully slow laptop having a hissy fit), but the important thing is that the catalog is now sorted.  Thanks so much for setting me in the right direction.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines