• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

can't remove a folder

New Here ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

I am trying to remove a folder from my catalog and when I select that folder and clich remove nothing happens.  I even tried to delete the original folder on my physical drive and that did not work.  I subsequently created an new folder on my hard drive and selected find missing folder and nothing happend.

How do I delete this folder.   It is called 2022 and I am using windows.image.jpg

TOPICS
Windows

Views

292

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Notice the ? mark. That indicates that LrC no longer has correct info on the folder location. Perhaps it got moved/renamed/deleted outside of LrC.

 

for that, see: https://www.computer-darkroom.com/lr2_find_folder/find-folder.htm

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

As I mentioned I tried that and the folder was found but I still couldn't delete it

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Is the folder on your hard drive empty? 


.....Suzanne Mathia

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

It initially had one file in it which I didn't care about. And I couldn't delete the folder so in order to troubleshoot the issue I actually deleted the physical folder and the file on my hard disk hence the ? Symbol.

I tried recreating The same folder which got rid of the ? But I was still unable to remove the folder.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Right click on that folder and select to show parent folder. You might need to repeat that, to see the top level folder.

I suspect some folder duplication is occurring, and a capitalization issue might be occurring.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

You would normally see a warning message for this, but- Have you tried 'Removing' the one photo from the library first. ie. the file shown in the {Joel....} sub-folder, then remove the folders?

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Try removing the subfolder first. If that does not work either, then remove the image in that subfolder and try again.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Thanks for all the replies.

I have physically deleted the folder and sub folder, including the files from my hard disk hence  the ? next to the folder name.

I also tied to remove the subfolder.  Nothing happens.   I tried to go to the parent folder and still nothing happens.

I also tried optimize catalog and that also did not work.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Just to make sure that you tried this the correct way. Did you select the image in the Lightroom library grid, right clicked it and chose to remove it? Then did you right click on the subfolder in the Lightroom folder panel and chose to remove it? Same for the parent folder?

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

I tried to do that and r click the folder and files and select remove it but nothing happend and the files and folders remained in the lightroom catalog.  So in the end I physically deleted the folder and files from my hard disk.  However they still remain in the lightroom catalog and I cant get rid of them.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2023 Sep 12, 2023

Copy link to clipboard

Copied

Sounds like catalog corruption. Try this. Create a new catalog, and then choose 'Import from Another Catalog'. Import your old catalog (select all images, but do not move them). This will create a new copy of your catalog. Now try if you can delete those folders in this new copy. If you can, then use the new copy from now on.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2023 Nov 12, 2023

Copy link to clipboard

Copied

LATEST

Thanks!  Solved.  Created a new catalog and imported the old one.  Deletion on missing folders is now working again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines