Cannot update gps data using setRawMetadata

Explorer ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

I ma trying to update raw metadata on export. there are few metatada I am updating on this plugin. All the metadatas are updated but gps. I used

setRawMetadata('gps', {longtitude =1.39392320320, latitude=1.2343232});
Even though this call finished without any errors, it does not update the metadata to the given value. After I checked, now the gps data is nil.

 

Can you please tell me what the problem here. Or are there any restrictions.

TOPICS
SDK

Views

502

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Feb 18, 2020 Feb 18, 2020
I have figured out the issue. there are some other settings in export window which says not to export location data. once uncheked that, it works perfect. Thanks everyone.

Likes

Translate

Translate
LEGEND ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

You've got incorrect syntax; it should be:

setRawMetadata('gps', {longtitude = 1.39392320320, latitude = 1.2343232})

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

LATEST

You might as well written that in chinese, I understand the programming, but I don't know where to apply it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

My guess it is failing because longitude is misspelled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

This is corrected in the quesion. Any other suggestion other than spelling mistakes? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

Correction to the correction:

setRawMetadata('gps', {longitude = 1.39392320320, latitude = 1.2343232})

 

[Use the reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2020 Feb 17, 2020

Copy link to clipboard

Copied

sorry, updated the issue. I am actually using = and correct name.  Still it is not updated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

[This post contains embedded images that don't appear in email. View the post in your Web browser to see the images.]

 

Without seeing the complete code, it's hard to know what might be going wrong. I just verified that this code works correctly in LR 9.2:

 

Untitled.png

If you're not using a debugger, I highly recommend either my Debugging Toolkit or the Zerobrane IDE. Trying to debug LR plugins using print statements is an exercise in frustration.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

I have figured out the issue. there are some other settings in export window which says not to export location data. once uncheked that, it works perfect.

 

Thanks everyone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 18, 2020 Feb 18, 2020

Copy link to clipboard

Copied

Glad you got it resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines