Copy and paste IPTC metadata NOT working

Explorer ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

All I need to do is copy and paste the Headline and Description for about 100 images. And maybe one or two will paste but the rest will not. Very frustrating. On M1Mac, Latest version of everything

TOPICS
macOS

Views

136

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

Many have reported issues with Copy/Sync of develop settings in LR 11.3 and 11.3.1, and there have been other bugs reported with copying metadata, but I haven't seen these symptoms reported before. I just tried Copy/Paste of Headline and Description to over 1100 photos in LR 11.3.1 and didn't experience the problem. Without a recipe that reproduces the problem on any LR installation, Adobe is unlikely to look at the problem, unless many people report it.

 

You could try these workarounds:

 

1. Set the option Catalog Settings > Metadata > Automatically Write Changes Into XMP.

 

2. Do the menu command Help > System Info. If you're on 11.3 or 11.3.1, roll back to 11.2.

 

(If you're not on 11.3.1, please do Help > System Info and report the precise version number.  People often report "latest" when they're not.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

Thanks, John
I've always had Automatically Write Changes Into XMP checked. 

I've also experienced problems with copying/pasting develop settings as well.

I appreciate your input and I'll try the rollback. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

Unfortunately, the rollback to 11.2 did not work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

"I've also experienced problems with copying/pasting develop settings as well."

 

With pasting develop settings, are the sliders getting changed on the target photos but the Library previews not updating?  That's another known bug in 11.3 / 11.3.1:

https://community.adobe.com/t5/lightroom-classic-bugs/p-library-previews-not-updating/idi-p/12897363

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

Oh, are you in Loupe view when you do this (one photo showing above the filmstrip)?  In Loupe view, Paste will only modify the most-selected (current) photo -- switch to Grid view before doing the Paste.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

Yup. Understood. Getting back to the metadata, I remember in the past when I pasted into a field, a message would appear that would say something like "Metadata being updated for 100 images." I'm not seeing that now. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

And it might take 10 seconds or so. I'm wondering if I'm checking too soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

So you're in Grid view when you're pasting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

Yes, to be clear I'm talking about captions, headlines, etc

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

Please post a full-resolution screenshot of your entire LR window immediately after pasting -- that might give important clues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2022 Jun 09, 2022

Copy link to clipboard

Copied

Unfortunately I face the same issue since 11.2 (now on 11.3.1 [ 202204181225-f90ebff5 ]). Not only doesn't copy&paste work, managing IPTC data has become a nightmare to work with. For example entering IPTC Description in Grid View, changing to next photo and going back, the previously entered text is not showing up. But: exporting to a JPEG shows the IPTS data!! And it doesn't make a huge difference whether files are stored on NAS or locallly, maybe it's a tad faster the LR UI gets updated with the IPTC data stored to the file. Using XMP has no influence either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 09, 2022 Jun 09, 2022

Copy link to clipboard

Copied

"entering IPTC Description in Grid View, changing to next photo and going back, the previously entered text is not showing up. But: exporting to a JPEG shows the IPTS data!!"

 

Your symptoms may not be identical to the original poster's.  But they are similar to a whole bucket of symptoms where metadata changes are made in the catalog and appear in exported photos but don't always appear in the Metadata panel.

 

Do the fields you're pasting contain double-quotes by any cha

nce?

 

For most everyone (but not all) who have reported similar symptoms, the two workarounds have been successful:

 

- Setting the option Catalog Settings > Metadata > Automatically Write Changes Into XMP.

 

- Rolling back to LR 11.2.

 

Adobe has acknowledged the various bug reports, so they'll likely be fixed in the future. LR releases about every eight weeks, so we might expect to see LR 11.4 in the next week or so.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2022 Jun 10, 2022

Copy link to clipboard

Copied

LATEST

Hi John,

 

No, no quotes whatsoever, just alphanumeric characters, some periods, colons and a copyright symbol. And as I stated earlier, it doens't make any difference whether I use XMP or not. 

 

I'd like to avoid rolling back to 11.2 cause I'm sure the issues were the same back then. I'll rather wait for this issu(s) to be fixed, better sooner than later.

 

Cheers,

Stefan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines