Develop Module Blacks out entire screen

New Here ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Hey,

 

I've seen a few of these posts, but solution to the problem which is "Disable GPU acceleration" seems a bit counter intuitive as it reduces performance/responsivness of the application considerably.

 

Using a freesync monitor with Gsync enabled in both studio and game ready drivers from nvidia causes GPU to black out the entire screen not just lightroom develop module.

This can be bypassed by simply setting a shortcut on monitor to enable/disable freesync option as a temporary workaround, but it would be great if it just worked.

 

System:

3080 10g, connected via display port 1.4 to a 4k 144hz Dell 3223q

Tested with:Game ready driver 516.50 & Studio ready driver 512.96

I should mention, this only happens in lightroom, as an example Blender that I'd expect to utilize 3d settings is working flawlessly. It might be something about a 2d application trying to utilize what is essentially a 3d only option?

 

I've tried disabling gsync for LRC only, no change.

Forcing fixed refresh rate for LRC to both 60 and 144, no change. 

Disabling everything in Nvidia control panel for LRC, no change.

 

Disabling LRC gpu acceleration completely, problem goes away.

Leaving gpu acceleration on, but disabling freesync on the monitor (gsync goes away from control panel automatically), problem goes away.

Placing any full screen application over lightroom while photo is zoomed seems to stop the problem as well (until LRC is brought back to focus).

 

Using develop module zoomed out, problem goes away.

Zooming in, screen blacks out.

Panning while zoomed in, screen blacks out.

Moving another application window over zoomed in develop module, screen blacks out.

Leaving the photo zoomed in and not touching anything, causes a blackout randomly at a very slow rate.

 

 

Well, thats about it, am glad to keep testing if needed or run some diagnostic exports.

 

Cheers,

Milos

TOPICS
Windows

Views

60

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Not counter-intuitive if you have a bug in your GPU and you end up with a black preview in Develop and disabling GPU fixes this issue. 

 

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if this is the latest OS version, you may need to roll back a release.
Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Maybe I wasn't clear enough, gpu works flawlessly, I've tested it and retested using multiple benchmarks and burns, there are no artifacts or any other signs of GPU failing, all results are within silicon range for the make and model. 

The only program showing problems is LRC, everything else on my system is fine.

GPU Acceleration works flawlessly.

Bug appears once the gsync option is enabled with a freesync monitor.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Yes, that's a different problem outlined here:

https://community.adobe.com/t5/photoshop-ecosystem-bugs/p-cursor-stuttering-amp-screen-flickering-in...


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Apparently an issue for Adobe around  NVIDIA G-Sync. In this community you will find various problems, both PS and LrC vs G-Sync. Solution is to turn G-Sync off. Sounds like a long term bug.

 

https://community.adobe.com/t5/lightroom-classic-discussions/photo-in-develop-module-flashes-black-i...

 

https://community.adobe.com/t5/photoshop-ecosystem-bugs/p-cursor-stuttering-amp-screen-flickering-in...

 

hmm, looking at those links reminds me, what version of LrC are you running?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

LRC 11.4, I keep things updated.

 

Yeah I saw those, thought i add this one to the fray, it's not just dev module flickering or flashing black, rather entire screen.

 

Like I mentioned, killing g/freesync does resolve it, it's just a nuisance that could probably be resolved somehow on the program / driver side (I assume Adobe has contacts with Nvidia that would take this bug seriously). Did my best to add all scenarios where it happens to help them resolve.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Interesting development:

 

Disabling Gsync while application is off, then turning application on and enabling Gsync while app is up, then restarting the application reduces the issue to "Development Module Flickers black on zoom", it's not throwing off the entire screen anymore.

 

I'm trully interested in what interactions are causing this 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

LATEST

If someone comes here looking for a solution, in my case the issue seems to have been caused by either dp1.4 port throughput or by dp1.4 cable. Switching to HDMI 2.1 seems to have resolved it completely.

 

It's still strange that even when limited to 60hz  4k (which is well within DP1.4 throughput capabilities) problem remains.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines