Locked

Does Lightroom Classic work with Big Sur?

Adobe Employee ,
Nov 11, 2020 Nov 11, 2020

Copy link to clipboard

Copied

macOS Big Sur (version 11)macOS Big Sur (version 11)

With the release of macOS big Sur (version 11), you may wonder if Lightroom Classic is compatible, or if you should wait to install the new OS update.

 

For upgrade recommendations and a list of known issues that we're aware of thus far, see Lightroom Classic and Big Sur | macOS 11.

 

If you run into any issues while using Lightroom Classic in Big Sur that are not listed in the above article, please let us know here in the Lightroom Classic community.

Views

4.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2020 Nov 21, 2020

Copy link to clipboard

Copied

I am running Lightroom Classic 10.0 on Big Sur and having so.many.problems!!! My entire computer has crashed 4 times and Lightroom has crashed 7....and counting! I am unable to make more than 3-4 adjustments in a photo before it crashes. I am unable to sync edits. This is beyond frustrating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

having the same !!!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 31, 2020 Dec 31, 2020

Copy link to clipboard

Copied

same and looking closer for subscription cancel button after each crash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2021 Feb 12, 2021

Copy link to clipboard

Copied

I've been having problems in the same way since November. I took my iMac 2015 in and had the hard drive replaced, software looked at, etc. and it's STILL not working. It's clearly an adobe issue now that I've installed Big Sur. I basically can't do any editing now. So angry 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2021 Feb 14, 2021

Copy link to clipboard

Copied

I have bought a external SDD and installed Mojave and Lightroom 6 on it. Now, when I know that I am going to mainly edit photos, I boot from the external SDD and then it's just like before. I know it is a bit of a hassle, but at least I can do whatever I did before in LR 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Me  too, it is impossible to work, did you solve the problem or have any tips regarding this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

If you have this problem go to system preferences and lower resolution of monitor I found this myself with no help from Adobe works fine without the 5k screen resolution

Get Outlook for iOS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

That would be great if only it would really solve the problem ! but in the first place, where exactly do you have access to resolution of the monitor in system preferences ? THanks !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2020 Nov 23, 2020

Copy link to clipboard

Copied

Here's my list so far.

LRC

1.  Adjust ment brush paints sometimes and others it does nothing.

2.  Constant lag and in some cases I resort to the Force Quit which seems to be my best friend as of late.

I just don't understand why companies like Adobe that are provided the beta/pre-release OS but still can't seem to figure out to eliminate bugs prior to the consumer lighting up the community boards as is the case currently. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2020 Nov 23, 2020

Copy link to clipboard

Copied

Hi,

I received a new iMac 4 days ago, so many computer crashes and after, a long talk with Apple support I cancel my test subscription and I have to return the iMac tomorrow. Prior to install Ligthroom CC I check comparability with Adobe. My iMac is I7 with 32gb ram, no escuse. It is really amazing and frustrating as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

Hi,

just to share that the adobe page about Big Sur compability has changed, now they don't claim anymore that ligthroom cc is compatible with Big Sur. In my case serious problems could have been

avoid. 😞 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

Problem in the Print Module of LR Classic 10.0 running on a 27inch iMac 5K 2019 with macOS Big Sur 11.0.1...

A number of basic edits do not show up in the preview image inside the Print Module when in the "Image Settings" section the option "Zoom to Fill" is checked. When I uncheck that option, the photo looks exactly like in the Develop Module, IOW all edits are visible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Big problems with the Develop module.  Brushes etc very slow, cropping can also not work.  Attached photo happened when cropping.  Looks OK in Library module.  Screwed up in Develop.   This is the version/Mac infoScreenshot 2020-12-10 at 15.44.43.pngScreenshot 2020-12-10 at 15.43.01.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

I am having the same problem.  I thought it was a memory issue after the Big Sur update, so I upgraded my memory from 8 to 32GB.  Still doing the same thing, particularly with the adjustment brushes.  Then the whole things crashes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Mine worked ok until today opens then crashes totally unresponsive 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

My problem seems to be the cursor driver.  It locks constantly, especially when using a tool such as crop, or sliders on the side panels.  The cursor stops moving on the screen even thought the trackpad or mouse keep moving.  It stays froze for several seconds, then jumps to a new position, then locks again.  The condition is so bad it's unusable.  If a fix isn't found quickly I'll drop back to Catalina.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

LR 10.0 worked fine after uograding to Big Sur. Then after pgrding to LR 10.1 I started experiencing same problems reported on this forum - slow resonse in Develop module especially but not onlywhen using the graduated filter and brush tools. Program stopped completely a number of times. Had to turn off Mac and restart several times.

Then I turned the Graphics processor to off as suggested somewhere in these forums and that seems to have solved the problem  - so far. What if anything am I loosing by turning off the graphics processor? 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

Unusable since latest update turned off gpu as suggested works of a fashion slow slider don't work properly UNUSABLE not happy and looking for other options 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Updated to Big Sur 

Instal update for Lightroom Classic 

Everything Crash after moving just one slider in develop module. 

Computer freeze and need to restart LR, already run test if something is wrong with iMac 27 5k late 2015, 32 gb ram, ssd drive, external drive with library on Lacie thunderbolt connection and nothing is wrong. 

This is happening only when run LR, other programs like DaVinci Resolve works nice and smooth. 

It happens that while whole computer is blocked by LR running , time, adjustments for wifi, volume adjustments dissapear. 

Already searching solutions for it like 4 days straight and no idea what should i do. 

Any ideas Adobe ? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

I have just cancelled my cloud subscription due to having this problem for 2-3 weeks without solution,very hard also to get Adobe to act!.
They did however do a backwards install to a previous time but this also had faults where as b4 the update it was fine??.
I had a job to edit which was impossible to complete,I have also now lost some of my hard gained credibility by putting back the final edits 🤬
Before the latest update it was working fine on big sur 🤷‍:male_sign:

Get Outlook for iOS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 31, 2020 Dec 31, 2020

Copy link to clipboard

Copied

I just wonder if anyone actually read that comments ? Or it is just for us silly users to cry out and Adobe hope for best that we forget ? 

Because looking back in history of this post not so much happened, 

Adobe please step up your game in customer service and dont release updates that make us users frustrated before you test them correctly on new system. 

Right now im looking much closer on canceling subscription button and and i thing not alone in this area. 

If actually someone reads that i already wrote down what is going on so have a nice lecture. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

Tools work with Big Sur until LR crashes the computer. Hope an update is coming soon. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

I am on IOS Big Sur 11.1, and Lightroom Classic works until I try to edit an image, what happens next is I get the "spinning wheel of death" for a few minutes, then the cursor goes away then black screen, then the computer restarts, and I get the error screen to send info to apple, and adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

YES I get this exact same problem. I spoke to apple for over an hour trying to work on the computer itself to see if that was the problem, but they said it was an Adobe problem. I have been a LR and Adobe user for over a decade and am thinking of switching to a different software because its effecting my workflow so severely. PLEASE let me know if you find a way to fix this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I changed even my external hard drive from LaCie to LaCie but new model and still the same. 

And then Adobe released some small update, I downsize resolution from 5k to neutral on my IMac 5k. Turn off Gpu acceleration. 
Took my LR to smaller size window and it works but shutter on every adjustment while editing. 
not ideal I can say but works for now. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines