• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Downgrade catalogue from v12 to v11?

New Here ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

Hi folks

I've been using v12 since October '22 on Windows 11, and immediately ran into sync problems using Jeffrey Friedl's smart catalogue sync plugin. After I had Adobe on the phone for a couple of hours, we de-installed LRC, re-installed, imported the photos into a new catalogue and it went well until I tried the plugin again. Crash. Now I repeated the process and can't even sync LRC standalone, so, for the moment, I wanted to rollback to v11, where everything worked. For that, of course, I need to roll-back the catalogue from v12 to v11, but can't find how to....

Anyone got some help, please?

Thanks!

TOPICS
Windows

Views

398

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

The catalog cannot be rolled back to LrC 11. The only way for you to go back to LrC 11.x whilst retaining edits, keywords, metadata, etc is to save metadata to XMP sidecar, then import all the files into a new LrC 11.x catalog. Unfortunately, you'll loose all your history, collections, flags, etc in the process.

 

Would it not be easier to contact Jeffrey and ask him if he's aware of the issue you're experiencing. He's normally very responsive and I believe he would be very keen to fix any bugs that may exist in his plugin.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

Dear Ian,

Many thanks for your proposal. In fact, yes, not having his email address, I did post on Jeffrey's site for the smart-collection plug-in (in November), with the following text:

Hi Jeffrey, I have been using several of your plug-ins in LRC , and mostly rely on the Smart-Collection Sync Plugin (Version 20220125.19), which is simply excellent. Having upgraded LRC to v12.0.1, I made my usual $ donation to reactivate the plugin, and the problems started. Syncing seemed to be addressing way too many images. What I noticed was that LR seemed to freeze - couldn't click on anything, before ultimately just closing. Analysing memory usage showed that consumption increased once the freeze was in place. See particulalry slide 11 of this slide deck, where I've annotated it. Slide 16 details my hardare and OS information:

https://1drv.ms/p/XXXXXXXXXXX (if you make this comment public, please remove the link - since I don't know your email address, it's open) - I amended the url for this post to be ineffective

I contacted Adobe and after two two hour sessions, and in the first, updated GPU driver cleaned catalogue etc. In the second, since the problem continued, they duplicated my catalogue, I deleteed all cloud based collections, stopped syncing collections from LRC, stopped syncing top right of the screen and then started with a new collection and if I remember what she did, she imported the duplicate catalogue into a clean one. All was well for a couple of days. I selected a couple of existing collections to sync and they appeared, not using the plug-in. However, after I re-activated the plug-in, the problem returned.

I would really appreciate your thoughts on this one!

Thanks in advance

Kind regards, David Ellis, Munich, Germany

Slide 11 of the PPTX showed the consumption of memory from Task Manager, leading to the crash.

Sadly I didn't get an answer, so I left the problem, with LRc not syncing, and working locally.

However, my attempts in the past couple of days make me question whether the problem is in the plug-in or a conflict between LRc and Windows on my laptop. I followed the process which the Adobe agent had executed to address the problem last autumn, as listed above. The crash occurred when I started to sync an existing (from the old catalogue) collection. Note: this was not a Jeffrey generated collection, but a manually created one. So, before I got to activating the plug-in. Ultimately, I am wondering if a re-install of Windows is necessary, but clearly, want to exhaust all possibilities before then. So, yes, I would like to know if there are other steps that I could take...

Kind regards, David

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

So what would you do after rolling back? Never upgrade Lightroom anymore? Use version 11 for the rest of your life? Rolling back is only a temporary solution if your problem is a known bug that will be fixed in due time. In a situation like this it is no option. You'll have to find what the problem is and fix it. Start by resetting the preferences: https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

LATEST

Thanks for your comments, Johan,

I agree with you, rolling back is a temporary measure. Bearing in mind that I've been living with this problem for 6 months already, and not got to a resolution, my thinking was that (hopefully) with v13, the problem would cease. After all, I've been using LRc and smart-collection since at least 2018 with each version of LRc (or whatever it was called!) and it only crashed on upgrade to v12. And I mean immediately on upgrade. Though it took me about a week to recognise the connection...

As I mentioned in my answer to Ian, the problem with syncing now seems to affect LRc stability even without using Jeffrey's plugin.

Having said all that, I would be happy to try resetting the preferences, as a first step, to see if that improves things!

Cheers, David

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines