• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

DXO plugin screwed up my Lightroom Catalog!

Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Trying the DXO PureRaw3 plugin trial app I chose to export the DXO processed image to my main external drive where my catalog is. The results was that DXO moved my Lightroom folders around and screwed up all my catalog hierachy!

 Attached image:

Folders.png

 

All my image folders : 2021, 2022, 2023 are inside the Lightroom Catalog 2022 folder, But DXO moved things around now the Lightroom Catalog 2022 folder appears empty (even though the number of image listed is correct) Only the DXO generated images are visible in the External Drive 4 folder. Nothing else. If I try to move the 2021 folder back into the Lightroom catalog folder I get the message that a folder already exists there (with no option to replace it).

 

How do I fix this mess with the minimum amount of difficulty?

 

Thanks for any help!

TOPICS
macOS

Views

722

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Clicking the image folders everything appears empty.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

It's unlikely that the plugin moved all those folders around. It looks more like the plugin created the 'capitalization error'. Here's the explanation and how to fix it, but do check first in the MacOS Finder what the folder hierarchy really looks like.

https://www.lightroomqueen.com/capitalization-catalog-error/

 

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Thanks Johan for your reply.

 

There is no duplicate named folder that I can see. Not sure what process lead to the result I got but I'm hoping for a simple fix like creating a new External Drive 4 folder in the right position and deleting the current empty Drive 4 Folder. The fix in the link you sent got me really confused.

 

I'm also hoping not to have to resort to using a catalog backup to restore as my latest backup is not very recent.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

If I select "Show Parent Folder" with control- click, the folder position changes but all the image folders still show empty when clicked:

 

Folders 2.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

What if I delete the Lightroom Catalog 2022 with the greyed out arrow (no images appear in there) and move the Original Lightroom Catalog 2022 into the External Drive 4 Folder where it should be, could that be the fix? I don't want to try anything unless I'm pretty sure it wont cause another disaster..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Actually, there is no "External Drive 4" folder on the External drive, just the Lightroom catalog 2022 folder. Should the "External Drive" folder even be there? I'm not even sure if it was there before the problem...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

You can keep talking to yourself, but the fix has been given. If the extra folder is not really present on the disk when viewed in the Fnder, then this is the capitalization error.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

I have proceeded to make a Fix folder (on my computer drive, not my external drive where the catalog is) and did the Update Folder Location for the Ligthroom catalog 2022 with the grey arrow. That catalog disappeared but the Fix folder did not appear. I'm stuck here.

 

after fix folder.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

The path to the two folders looks identical with no capitalization error.

 

Screen Shot 2023-03-23 at 3.40.50 PM.pngScreen Shot 2023-03-23 at 3.21.52 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

H'm, the odd thing here is that the path shown for the first folder is actually not correct. The correct path would have to show 'External Drive 4' twice. The first time as the drive name, and the second time as the folder with the same name. That makes this one more complicated than usual. Does that 'External Drive 4' folder exist on the hard drive? Try restarting Lightroom to see if that makes the CapsFix folder show up. Also have a look at this variant of the capitalization error as well. That may explain this path difference: 

https://helpx.adobe.com/lightroom-classic/kb/lightroom-displays-same-hard-drive-twice.html

 

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

Thanks for your message. I did restart Lightroom after doing the Update Folder and the result was the same. There is no "External Drive 4" folder on the drive so I'm not sure why it shows like that in the catalog. I do notice on another drive with a different Lightroom catalog that the drive name shows as a folder in the catalog also, and on yet another drive with another Lightroom catalog it does not. Never paid attention to that before and have no idea why that is.

 

I wish there was a simple "folder relink" option to perform but that seems to be only available when there's a question mark over an image or folder (?)

 

I'm on Mac OS, if that makes a difference.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard

Copied

All my photos actually appear in a smart collection. I never created this collection. This collection was made when I used the DXO plugin and it created a collection for the DXO image. WTF?...

Screen Shot 2023-03-24 at 5.06.49 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard

Copied

The state of my Catalog:

Screen Shot 2023-03-24 at 5.13.36 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard

Copied

It appears Lightroom puts everything into a smart collection automatically.  I never noticed that before. It wasn't related to the DXO plugin.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard

Copied

I use MacOS too. If an external drive shows as a folder, then do the following. Right-click on that folder and choose 'Hide This Parent', then restart Lightroom. Now the drive should show as a disk. In your case, that would obviously mean that you now have the same disk showing twice, but that is a known problem with a known solution (I already gave you the link). Smart collections have nothing to do with this. If DXO created a smart collection, then that is irrelevant. Keep it if you like it, delete it if you don't.

 

BTW, you previously said that you didn't see the CapsFix folder, but isn't that a matter of simply scrolling? Your screenshot does not show all folders and so it also may not show all disks.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard

Copied

Hide this Parent is not available for this folder. (it's available for Catalog 2022 folder). The screen shots show the whole catalog. there's only 3 subfolders. Still I checked around to see if the Fix folder wasn't somewhere else, didn't find it.

Will read the linked info page another five time until it hopefully sinks in. Sorry I'm very slow with this sort of things. Thanks for your help!

 

(What if I applied Update Folder Location to Lightroom Catalog 2022 back to itself?... (Don't want to try stuff I don't understand to avoid digging myself into a deeper hole..))

 

Screen Shot 2023-03-24 at 6.15.43 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

What if I delete the "External Drive 4" folder with the grey arrow? There's nothing in it except for the 2 images generated by DXO... The "two hard drives" link is too confusing for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 26, 2023 Mar 26, 2023

Copy link to clipboard

Copied

You can try it, but do make sure you have a catalog backup before you do that.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 26, 2023 Mar 26, 2023

Copy link to clipboard

Copied

Deleting the "External Drive 4" folder solved the problem! Relieved that the solution was as simple as possible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 27, 2023 Mar 27, 2023

Copy link to clipboard

Copied

Good! I assume that this means that the two DXO generated images are no longer in Lightroom. Move them out of their current folder into a newly created temporary folder, and then import them from there. Don't import them directly from their current folder, because that could recreate the problem again.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 27, 2023 Mar 27, 2023

Copy link to clipboard

Copied

LATEST

Thanks for your assistance. I've uninstalled the DXO software and I'm not likely to use any third party Lightroom plugins ever again..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines