Error message when opeing LR Classic.....

Explorer ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

I have just migrated LR to my desktop at my summer home.

When I open LR Classic, I get the following message--

"LR cannot write to the following directory.  Until this problem is resolved, syncing from LR CC may not function correctly.

L:     "

L is my SSD drive on which I keep LR.

I have no idea what this means.  I do use CC to sync iPhone pics...and use Mobile.

Any help will be appreciated.

thanks

Views

5.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 30, 2018 Jun 30, 2018

Change the destination of the folder that is currently syncing to your mobile photos. Try going into Lightroom Preferences > Lightroom Sync > uncheck the box that Specifies the location for Lightroom CC ecosystem's images or change the location to your SSD temporarily. You can change it back anytime or not use it at all.

Likes

Translate

Translate
LEGEND ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

It might mean that you do not have WRITE permission to the folder where the catalog file is located. If that's the case, you need to make sure you have both read and WRITE permission to that folder.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

that certainly looked like the right answer!  The folder that holds the catalog was "read only"....I undid that....but, unfortunately, I got the same message when I closed and reopened LR Classic.....

....any other ideas...??

thanks a bunch..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

Not the "read only" flag, I am talking about folder permissions in your operating system. Right click on the folder, select Properties, click on Security, and set the permissions so that you have WRITE permission.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

I did that....still doesn't work....and I noticed that under the General tab the read-only box is marked (after unmarking it and clicking apply)

...based on you comment not sure if that matters..

but in any case still have the same message.....

a second message says that a "file is not located at the specific path   L:

It shows L (for my ssd) but no other path indicator......

really appreciate your help...thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

I have just migrated LR to my desktop at my summer home.

What is the EXACT folder path where the catalog file is located?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2018 Jun 29, 2018

Copy link to clipboard

Copied

This PC>2 TB SSD Samsung (F:)>LR active cat 10 13 2016> exported LR after Brian 10 13 2016>D->LR CAT and Photos imported fall 2015>export all LR  10 22 2015>D->All LR Photos

((((note--I switched the drive and it went from L to F...works fine))))

Since I use Classic but do sync with Moblie  and iPhone  ( I am not sure I understand how this works)  Am I also using CC?  And, if so should I open it and connect it to the new location for the CAT?   

When/if we get this problem solved......I am wondering how to clean up that long path.  Can I go to the folders section on the left of LR and pull the All LR Photos folder up to the Samsung folder and get rid of the intermediate links???

Well.....thanks for sticking with me on this

Chuck

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 29, 2018 Jun 29, 2018

Copy link to clipboard

Copied

We are talking about moving the catalog and not the photos, is that correct? You can move the catalog file to somewhere else using your operating system. Then, double-click on it to open it.

I can't answer your question about sync with mobile, I never use it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2018 Jun 29, 2018

Copy link to clipboard

Copied

we started by trying to fix the error message....I think that is still the main issue

I havent' moved either from my ssd drive......I just pointed the version of LR I have on this desktop after moving north for the summer.....and now get that error message...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 29, 2018 Jun 29, 2018

Copy link to clipboard

Copied

((((note--I switched the drive and it went from L to F...works fine))))

So based on the above, are things working or not? I'm confused.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2018 Jun 29, 2018

Copy link to clipboard

Copied

I am sorry for the confusion.

In case you noticed that the Samsung changed from L to F I just wanted you to know that LR still opened and worked fine.

But, I still get the same error message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 30, 2018 Jun 30, 2018

Copy link to clipboard

Copied

Then I am totally lost. On the one hand, it works totally fine but you still get an error message?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2018 Jun 30, 2018

Copy link to clipboard

Copied

Change the destination of the folder that is currently syncing to your mobile photos. Try going into Lightroom Preferences > Lightroom Sync > uncheck the box that Specifies the location for Lightroom CC ecosystem's images or change the location to your SSD temporarily. You can change it back anytime or not use it at all.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 30, 2018 Jun 30, 2018

Copy link to clipboard

Copied

that did it...don't get the error message anymore.....thanks a bunch

can you point me to an explanation of how Classic and CC work together for folks like me.......I use Classic because i want to store my pics on desktop.....but also use Mobile to edit a specified Collection like when on an airplane....and want my iphone photos to show up in LR.....

mostly this seems to work....but, frankly, I have no idea why!!!  and many explanations of Classi  in CC say that Mobile only works with CC!!!

thanks for your help.....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2018 Jul 01, 2018

Copy link to clipboard

Copied

Glad that worked!

Classic's companion App, Lightroom Mobile offers a reliable workflow that is reasonable to manage. Here is an example workflow...

In this instance the photographer needs

- to access images from any given shoot on multiple devices for culling, sorting, editing and

- an easy way to share images with a client

With Lightroom mobile installed on your phone and tablet and Classic on your computer, you can create and access synced collections from any device or browser. You'll have to turn syncing on under the name of your catalog - look for the white arrow to open the activity center and turn on syncing.

Create a collection (there a multiple ways to do that) tick the box to the left of the name of the collection and notice that it is syncing and when it is complete. Then notice in the center grid view in the library module there is a Make Public button. If you now open a browser window and go to lightroom.adobe.com and log in with your credentials you will see your shared collection.

You can make the collection shareable to anyone with a link by clicking on the Make Public button in Classic or you can click on the gear icon to access settings in the browser.

If you've downloaded Lr Mobile on your other devices you can open that same collection there as well.

So in this instance the photographer has the ability to continue to work on this collection (or album) of images from anywhere and can copy-paste-send the link to a client for their review with a few short clicks.

Give it a try with just a small collection and let us know how you do.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 01, 2018 Jul 01, 2018

Copy link to clipboard

Copied

Thanks very much.

We have a bunch of company for the next two weeks...but, when I have a chance I am eager to follow your outline....

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 03, 2018 Jul 03, 2018

Copy link to clipboard

Copied

OK...now I have a different problem....hope you can help

when I import photos....I get a message that my SSD drive is not available and pics will go to Picutres folder

      My SSd, under properties, is read only.  When I unclick that and "apply"...the system churns for quite a while...but drive is still read only....

....also, I think i started building previews for entire catalog of 90k pics.....so it  has been churning .....for a day!!  How can I turn that off....and what would normal setting for Previews be?

thanks a bunch

Chuck

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 03, 2018 Jul 03, 2018

Copy link to clipboard

Copied

Hi Chuck

Probably should start a new thread for the External drive permissions problem... you're on a Windows machine?

When you copied your Lightroom catalog to the external drive did you not copy the Previews / Smart Previews file with it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 03, 2018 Jul 03, 2018

Copy link to clipboard

Copied

Windows 10

I brought my full catalog etc with me to summer home on SSD....which I was using for LR in FL.  In the past when switching locations I have just plugged in the SSD drive, updated LR if needed, and pointed LR to that catalog.....and all worked immediately.

somewhere in all of this I must have made a mistake....or two

Not sure what I did re Previews but I do think I clicked something like "build previews for catalog"......which I think I shouldn't have done....it is just churning....and when I select one pic, it doesn't snap into clear focus.....just keeps churning

that's the first problem.....then dealing with the SSD ........thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2019 Oct 13, 2019

Copy link to clipboard

Copied

thank you for this suggestion!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

LATEST

Worked for me too!!!!!  That was driving me crazy.  Thanks so much.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

Thank you - great answer and it fixed the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Change the destination of the folder that is currently syncing to your mobile photos. Try going into Lightroom Preferences > Lightroom Sync > uncheck the box that Specifies the location for Lightroom CC ecosystem's images or change the location to your SSD temporarily. You can change it back anytime or not use it at all.

 

Thank you very much! The recommandation was really very usefull!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines