Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Experimenting some lags in Lightroom since the last Update

New Here ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Hi everyone,

Since I did the last update of Lightroom Classic, each time I use it there's some lags constantly.

I've try to uninstall + install the application but the lags keep showing up.

Have you something in mind that I can try? 

 

Thank you.

TOPICS
Bug, Performance

Views

184

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Lags when you perform what tasks in Lightroom Classic? Be specific.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Mostly every sort of task in the develop mode.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

How big is your monitor? (in pixels, not inches)

 

How big are the photos when they come out of the camera? (in pixels or megapixels, not megabytes)

 

Are you doing a lot of spot healing? Are you doing a lot of brushing?

 

Please provide the following basic information:

Adobe Forum.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

LATEST

In addition to answering the good questions dj_paige has asked, verify you are indeed on LR 10.2 by doing the menu command Help > System Info.  LR 10.0 and 10.1 had significant performance problems that affected many (but not most) people, and the Creative Cloud app sometimes fools people into thinking they are on the "latest".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines