Export Plugin creates 1px images

Community Beginner ,
Jun 24, 2022 Jun 24, 2022

Copy link to clipboard

Copied

Hey all, 

With my plugin (evlaa), I run some export to create online galeries. 
Unfortunately, There is a bug since the 11.4 version of Lightroom Classic and the expoorted images are only a 1px large gray square. 

Do you have any idea on what's going on?

 

Here is the code I'm using. 

 

 

local export_session = LrExportSession{
    photosToExport = { photo },
    exportSettings = {
      -- temp folder
      LR_export_destinationType ="tempFolder",
      LR_export_destinationPathPrefix = Utils.getTmpDir(),

      -- full size jpeg
      LR_format = "JPEG",  
      LR_export_colorSpace = "sRGB",  
      LR_jpeg_quality = 1,  
      LR_size_doConstrain = LR_size_doConstrain,
      LR_jpeg_useLimitSize = false,
      LR_size_doNotEnlarge = LR_size_doNotEnlarge,
      LR_size_maxWidth = LR_size_maxWidth,
      LR_size_maxHeight = LR_size_maxHeight,
      LR_size_resizeType = LR_size_resizeType,
      LR_size_units = LR_size_units,


      -- no watermark for delivery
      LR_useWatermark = LR_useWatermark,
      LR_watermarking_id = LR_watermarking_id
    }
  }


export_session:doExportOnCurrentTask()
  for i, rendition in export_session:renditions() do
    local success, pathOrMessage = rendition:waitForRender()
  ...

 

 

 

Thank yoou so much for yoour help 

Martin

 

TOPICS
macOS , SDK , Windows

Views

101

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 26, 2022 Jun 26, 2022

Copy link to clipboard

Copied

Can you check your resizing paramters ? This case could happen when "LR_size_maxWidth" and "LR_size_maxHeight" are invalid.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Hello MaithreyaS, 

Thank you for your reply. Just for the context, this plugin is working well in the 11.3 version of Lightroom. 
That's why I'm pretty sure it's link to the last version (11.4). 
But I didn't find anything in the release that could introduce this issue. 

The maxWidth and maxHeight is a number chosed by the user to resize the images. (ex: 1500px). 

Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Use a debugger or print statements to post here the actual value of "exportSettings" passed to LrExportSession during execution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Hey John, 

Here are the exportSettings values : 

{"LR_export_colorSpace":"sRGB","LR_export_destinationPathPrefix":"/var/folders/s_/_5wzn09n489bwjb8ytnzc_4m0000gn/T/679906698.41693-3519","LR_export_destinationType":"tempFolder","LR_format":"JPEG","LR_jpeg_quality":1,"LR_jpeg_useLimitSize":false,"LR_size_doConstrain":true,"LR_size_doNotEnlarge":true,"LR_size_maxHeight":"1500","LR_size_maxWidth":"1500","LR_size_resizeType":"longEdge","LR_size_units":"pixels","LR_useWatermark":false,"LR_watermarking_id":"<simpleCopyrightWatermark>"}

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 20, 2022 Jul 20, 2022

Copy link to clipboard

Copied

Those settings omit a lot of options that I use in my plugins.  It's all mostly undocumented, and I don't know which ones are required, so my approach has been to create an Export preset in the Export window, right-click it, do Show In Finder / Explorer, and change the settings as necessary, keeping all the others.  My plugins using LrExportSession continue to work in LR 11.4.1.

 

Example settings from one of my plugins (which the plugin modifies based on user input):

local ExportSettings = {
    LR_collisionHandling = "rename",
    LR_embeddedMetadataOption = "all",
    LR_exportServiceProvider = "com.adobe.ag.export.file",
    LR_exportServiceProviderTitle = "Hard Drive",
    LR_export_bitDepth = 16,
    LR_export_colorSpace = "/Library/ColorSync/Profiles/REC709.icc",
    LR_export_destinationPathPrefix = "",
    LR_export_destinationPathSuffix = "",
    LR_export_destinationType = "sourceFolder",
    LR_export_useSubfolder = false,
    LR_export_videoFileHandling = "include",
    LR_export_videoFormat = "4e49434b-4832-3634-fbfb-fbfbfbfbfbfb",
    LR_export_videoPreset = "original",
    LR_extensionCase = "lowercase",
    LR_format = "TIFF",
    LR_includeFaceTagsAsKeywords = true,
    LR_includeVideoFiles = true,
    LR_initialSequenceNumber = 1,
    LR_jpeg_limitSize = 100,
    LR_jpeg_useLimitSize = false,
    LR_metadata_keywordOptions = "flat",
    LR_outputSharpeningLevel = 2,
    LR_outputSharpeningMedia = "screen",
    LR_outputSharpeningOn = false,
    LR_reimportExportedPhoto = false,
    LR_reimport_stackWithOriginal = false,
    LR_reimport_stackWithOriginal_position = "above",
    LR_removeFaceMetadata = true,
    LR_removeLocationMetadata = false,
    LR_renamingTokensOn = false,
    LR_selectedTextFontFamily = "Myriad Web Pro",
    LR_selectedTextFontSize = 12,
    LR_size_doConstrain = false,
    LR_size_resolution = 240,
    LR_size_resolutionUnits = "inch",
    LR_tiff_compressionMethod = "compressionMethod_None",
    LR_tiff_preserveTransparency = false,
    LR_tokenCustomString = "",
    LR_tokens = "{{image_name}}",
    LR_tokensArchivedToString2 = "{{image_name}}",
    LR_useWatermark = false,
    LR_watermarking_id = "<simpleCopyrightWatermark>"}

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

Thank you for your feedback, 
I'll try to understand. But the thing is that it was working with the previous version of Lightroom. 
Do you know if there is a changelog somewhere to understand if a parameter is now mandatory? 

Thank you 
Martin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

I found the issue. 

It's linked to max_width and max_height. They are currently string attributes and when I try with number, it's working. 


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

LATEST

Glad you got it resolved.

 

"Do you know if there is a changelog somewhere to understand if a parameter is now mandatory?"

 

Unfortunately, Adobe rarely provides much information about changes to the SDK.  Part of the issue is that SDK methods are typically thin layers on top of internal methods, and when Adobe changes something internally, the behavior of the SDK will change too.  Adobe hasn't invested much in the SDK for years and no longer has an engineer dedicated to it, so such changes go undetected and unreported.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines