• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

I lost all my edits in one folder after updating from Catalina to Big Sur (Mac). How to recover?

Community Beginner ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

I updated my OS from Catalina to Big Sur last night and lost all my edits in one folder -- the last batch I was working on before doing the OS update. Prior to the OS update, to create room on my hard drive, I deleted the Preview and Smart Preview files, knowing that LR would recreate them. But for these images it's NOT recreating them, I don't know why. I really don't want to redo all that work. What happened here? I have not moved the images.

 

What I did do before deleting the preview files was to copy them (and the whole catalog) over to my Backup external hard drive... just in case. Is there any way I could link the current images that are missing the edits with the backed-up Previews file? If so, how?

 

Another issue to consider is that because of the OS update, Lightroom renamed my catalog from v2 to v3 (it's done this renaming before, when I did my last OS upgrade). But now this means that my current catalog and the backed-up previews for it have different names. How to deal with this?

 

I hope there's an easy solution to these missing edits. Would appreciate advice and solutions. Your help is most appreciated. Thank you.

 

TOPICS
macOS

Views

42

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

Upgrading the OS will not cause LrC edits to disappear.

 

Missing edits in this folder ... are there exclamation point icons on the photos or question mark icons on the folders?

 

Did you click on All Photographs in LrC, and then search for one of the photos in LrC by file name?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

The short answer: the missing edited images show an exclamation point in All Photographs.

 

And now I remember something I totally forgot about. After the OS updating, when I opened LR by clicking on this folder, I got a message: these images already exist in LR. Do you want to merge? Stupidly, I chose yes. Big mistake! 

 

It's this merge that's causing this issue. Now all the images (edited and unedited) in the folder are showing as missing, with an exclamation point. Whereas  the duplicates that got merged-- (all of them unedited) -- show as visible. 

 

When I go to Finder to find the missing image-- which it does find-- it says this image is associated with another image in LR, and LR only allows one image to be associated with a missing image (I'm paraphrasing). 

In short, this is a big mess. I never should have allowed the merge. 

 

Just to test a theory I had: I removed (from within LR) one of the unedited images, then tried again to "find" that same "missing" image and it worked! It found the edited image, so I got back my original image plus my edits. 

 

My question: How can I undo the merge, without manually deleting and relinking 250 images?  I can't bear the thought of having to do this maually for 250 images. I hope there's a solution or workaround somehow. 

 

I may repost this question under new heading, as this is a different problem from what I first thought it was.

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 30, 2022 Oct 30, 2022

Copy link to clipboard

Copied

"After the OS updating, when I opened LR by clicking on this folder, I got a message: these images already exist in LR. Do you want to merge? Stupidly, I chose yes. Big mistake! "

How can you open Lightroom by clicking on a folder? The merge question only comes up if you try to relocate a folder or reconnect a missing folder, and select a folder that is already in Lightroom.

 

Lightroom can filter for 'no edits', so if you select that folder and filter on no edits, you should be able to remove them in batch. If you then reconnect one of the missing images, click 'Find nearby photos' at the bottom of the dialog. That should reconnect all missing photos in the same folder.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 30, 2022 Oct 30, 2022

Copy link to clipboard

Copied

LATEST
Another issue to consider is that because of the OS update, Lightroom renamed my catalog from v2 to v3

What version of LrC do you now have?

Current is v12.0.1, any upgrade (not update) of a catalog should have been to v12 , not v3

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines