Incorrect Image Count

Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

One of my image folders is showing an incorrect number of images.  The folder itself contains 2000+ images, they are all visible in the grid view and all editible in the Develop Module.  I have a screen capture that shows part of the grid view which contains all 2000+ images. 

 

I have screen captures of the grid view but I can't post them because I'm being asked for labels for each image but I don't know what labels it is referring to.

 

There is nothing wrong in the grid view or in the folder itself, but the catalog on the left column says that there are only 14 images.  Clearly that is wrong.  Both Windows explorer and the count summery at the bottom the Grid View agree on the 2000+ number.  But the left column says there are only 14

 

A second screen capture shows the image count of 14 but again, I don't know how to post it.  

 

I see no other errors.  I have no idea why this particular folder vs all the others, is wrong.  I did try synchronizing this folder but the result is that all images in the folder are already in Lr.  

TOPICS
Windows

Views

118

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

You haven't included the screenshots!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

I'll try again.  It would let me post them the first time

 

The Grid View

KauaiCatalog.jpg

 

The image count

index.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

I gave up trying to figure it out and backed up a week and now the numbers in the folder column and the numbers in the grid view and the numbers in the folder itself are all the same.  I didn't have too many pictures to redo so all is  well. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

The solid triangle to the left of "Kauai" indicates there are subfolders:

 

johnrellis_0-1647044761977.png

 

Click the triangle to show the subfolders and the "missing" counts will be there.  Somehow, you unchecked the menu item Library > Show Photos In Subfolders, and when that is unchecked, then the counts show just the number of photos in each folder proper.  When you check it again, you'll see the full count for "Kauai - 2022" and all its subfolders, and Grid view will show the photos in "Kauai - 2022" and all its subfolders.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

@johnrellis 

The "image count" screenshot shows there are at least 511 photos being shown. If the "Show Photos In Subfolders" was unchecked wouldn't there only be 14 photos showing?  This would be the case unless there is another folder selected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

"The "image count" screenshot shows there are at least 511 photos being shown. If the "Show Photos In Subfolders" was unchecked wouldn't there only be 14 photos showing?  This would be the case unless there is another folder selected."

 

Good point. But since Wernerg expediently restored a backup, it will be hard to investigate further.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

The subfolder showed only 1 photo but there were actually 20.  All 20 were visible in Lr.  When I had Show Photos in Subfolders checked, the Kauai - 2020 folder showed 15 and the Grid View had all the 2000+ of the top level folder and the 20 from the subfolder. 

 

If this is really of interest I could restore the offending catalog and get some more data.  There is at least one backup that has the problem catalog.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 13, 2022 Mar 13, 2022

Copy link to clipboard

Copied

LATEST

I don't think it's worth investigating more at this point. Adobe only pays attention to problems that can be easily reproduced or that affect larger numbers of people.  

 

If it does strike you again, try deleting the file "<catalog> Helper.lrdata", which among other things caches folder information. It contains just cached information that LR will rebuild, so it's safe to delete.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines