Installer CD of LM 6, not working on this iMac

New Here ,
Aug 19, 2022 Aug 19, 2022

Copy link to clipboard

Copied

I got a message "need contact to the developer" when I install my owned Lightroom 6 CD bought in 2016! Please advise how to sovle this problem.

TOPICS
macOS

Views

1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation