Issues with Lighroom and ASUS Rog Strix

New Here ,
Sep 18, 2022 Sep 18, 2022

Copy link to clipboard

Copied

Has anyone been having issues with the new lightroom classic and importing photos? I'm trying to import images, and I click through about 15-20 at a time before it freezes on me for a few seconds. I have to wait, then keep going. Sometimes it crashes, and then keeps crashing repeatedly and I have to turn everything off then back on. I also can't import anything if I use an SD card plugged into an SD card reader, it keeps making lightroom crash. The only way I can import anything is if i plug my camera directly into my laptop. Its a brand new laptop, so I wonder if there are compatability issues possibly.

TOPICS
Windows

Views

36

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 18, 2022 Sep 18, 2022

Copy link to clipboard

Copied

A few possibility's

 

  • USB cable connecting SD card reader to computer is poor quality, not a data cable (power only), damaged
  • USB cable connecting camera to computer is poor quality, not a data cable (power only), damaged
  • USB cable connected to a hub instead of a computer port (should fail earlier, and device dependant)
  • SD card reader is damaged
  • SD card damaged, have you tried another one?

(could be something else)

 

Inquiry, in the import, are you selecting Add, or Copy?

 

Inquiry, if using Copy, have you tried, outside of LrC, copying the images on the SD card, onto your desired hard drive/folder, then in LrC, import via Add?

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

LATEST

Thank you so much, those are all great tips! Unfortunately, I think it's a Lightroom issue and not an equipment issue.

My SD card reader is new, and works fine on a different computer.

The camera cord is also new and works fine on another computer, and is meant for charging and data transfer.

I'm a photographer, so over the last ~3 weeks I've tried this with at least 4 different SD cards and have had issues with every single one. 

On the import, I'm selecting copy, not add. I even tried saving the images to my computer first, then importing into Lightroom that way, and it still was pausing and freezing on me.

Lightroom has also been not responding occasionally when I'm opening it up to import images. I have no idea why, I'm using a brand new laptop and have never had issues with Lightroom on anything else before so it makes me wonder if it's a comparability bug that Lightroom needs to update for my specific laptop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines