• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Keywords/Tagging inconsistencies

Community Beginner ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

 

Hello,

 

I started a collection with a nice list of keywords so far. For the particular set I am working on if I look at the Windows Explorer where they are located I can see that some photos have keywords, while others have none. For those that do, they have the proper ones while also having some keywords which are not selected in LR.

 

Are keywords saved automatically into the file once it is selected or applied?

 

Perhaps there is a logic here that escapes me, I'm still greenish...

TOPICS
Windows

Views

51

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Nov 04, 2022 Nov 04, 2022

Keywords are saved automatically to the Lightroom Classic catalog (database) file. You can't turn this off.

 

Keywords are optionally saved to photo files (or sidecar .xmp files). To turn on the option, go to Catalog Settings->Metadata and check the box "Automatically write changes to xmp"

Likes

Translate

Translate
LEGEND ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Keywords are saved automatically to the Lightroom Classic catalog (database) file. You can't turn this off.

 

Keywords are optionally saved to photo files (or sidecar .xmp files). To turn on the option, go to Catalog Settings->Metadata and check the box "Automatically write changes to xmp"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

 

 

I look at the Windows Explorer where they are located

 

 

Sounds like OP is looking at properties of the original files, this via Windows File Explorer, not via LrC, and finding missing keywords applied in LrC via post editing.

 

And asking, how to fix.

____________________________

Oh, and an inquiry to the more informed, if you turn on "Automatically Write Changes Into XMP" will that write the keyword data into the original files, or just the sidecar xmp file?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

If it's a Raw, to a sidecar. To rendered files it adds to the original file. Checked by adding the keywords, saving to metadata, Open as Original and check File Info in Ps to confirm. 

 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2022 Nov 05, 2022

Copy link to clipboard

Copied

LATEST

Checking "Automatically write changes to xmp" applied the proper keywords to all files automatically. Also, the only files that had keywords were the copies created by LR when sending them to PS, none of the original files had keywords, but all do now.

 

Thanks for the help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines