• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Lighroom Classic database disconnected and inconsistent.

New Here ,
Mar 24, 2023 Mar 24, 2023

Copy link to clipboard


I’ve used Adobe Photoshop and Lightroom Classic for many of years and love the programs. The problem that I am experiencing though interesting is frustrating. Time has made me a dinosaur but in a past life I was a systems analyst with relational database experience.

I acquired a new computer Windows 11 and downloaded fresh installs of Photoshop 2023 (PH) and Lightroom Classic 2023 (LRC).

  • First problem was a disconnect between LRC and PS.  In LR I would right-click an image to edit in PS. This command was greyed out.  I uninstalled both programs using the facility of Windows control panel. Reinstalled both PS & LRC installing PS first.  This action corrected the problem.


  • I had copied the folders containing images and the catalogue files to the new hard drive. Same arrangement as previous. The commands <File – Open> and <File - Recent > work as expected. For <File – Open> I would drill down the directory hierarchy to the command.  For example clicking on Catalogue2011-v12




This works fine for all the catalogues. 




Creating a new catalogue <Catalogue2023> The following files are created.



Now the problem.  There are several aspects. Creating a new catalogue appears to be OK. Shown above.

It gets interesting. I have repeatedly received  the following dialogue when I try to execute an import into the newly created Catalogue2023. LRC wants to go to a folder that was previously deleted. In this case “Panama”  which LRC  states it is not available as shown below. The import should be referrencing Catalogue2023. There is a disconnect between creating “Catalogue2023” and doing an immediate import. I deleted the folder Catalogue2023 and recreated it a few times with the same result.




More interesting.  Not only does LRC offer to import the images into the the Windows 11 “Picture folder”  it wants to use the name of the deleated catalogue “Panama” If I click OK the command will be successful and catalogue and images will appear in the Windows picture folder.  Note:  to exit the above dialogue box the only option I have is to click “OK”. If I wish to not do so I must exit out of the LRC progran. I have tried to create other catalogues having different names and have had the same experience. The same Panama option is provided.

Even more interesting. I’ve made various attempts to create the catalogue which includes cold booting the computer with the same above mentioned result. Then several times in succession executing <File – New Catalogue> did not repeat the expected  process to create a new catalogue. Rather it was as if I had executed the command <File – Open Catalogue> which actually opened any catalogue I selected. Note since Catalogue2023 was not created it was not available to choose.

Cold booting the computer I was again able to create Catalogue2023 with the same aforementioned problem of LRC not finding the catalogue it created.





I now pursued the problem further and executed the command to repair the catalogue “Catalogue2023”

Executing the command <alt – Lightroom> and selected “Catalogue2023” and tested for integrity. This time the catalogue was populated with images from a variety of catalogues but not all catalogues. I chose an image and was able to <right click and select to open in PS>.  PS opens with the selected image performing as normal.

I then opened a different catalogue and was able to edit an image in PS with no issues.

Next I returned to Catalogue2023 executing the command <file – open recent>  selected “Catalogue2023” The images previously imported into this catalogue using the repair utility vanished. The following 2 screen dumps are the contents of the folder “Catalogue2023” at this stage of the trouble shooting. Different from the previous folder files.










I surrender.  I’ve spent 2 days on this problem and have more than a few times repeated the experience. 

I look forward to a solution.



Joe van Wissen










Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 27, 2023 Mar 27, 2023

Copy link to clipboard



Hi @Joe_wfvw, welcome to the Lightroom Classic community. I'll help you figure this out. You've gone through a lot of effort.


I understand that you manage a lot of catalogs, which can be confusing. First, let us begin by resetting Lightroom Classic's preferences to make it forget any locations or recent actions you've completed to avoid getting linked to incorrect folders.

Please follow the manual method to reset Lightroom Classic: https://helpx.adobe.com/lightroom-classic/help/setting-preferences-lightroom.html

As a test, keep your primary catalogs on the internal drive. Check this to learn more about the catalog: https://helpx.adobe.com/lightroom-classic/kb/catalog-faq-lightroom.html

Sameer K





Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines