• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Lightroom 2

Community Beginner ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

I have a copy of the Lightroom 2 I purchased many years ago before Adobe changed everything to subscription. I used it on my old computer which is no longer working for some time. I now from time to time need to make some adjustments to the photos. I installed the Lightroom 2 yesterday but it cannot register and cannot get updates which seems to be required to recognize the CR2 file. How can I get it to work? I would think I paid for it, I should be able to use it even it is no longer supported? Appreciate your help an advance!
John

TOPICS
Windows

Views

104

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

That's ancient, and no, there is no more support or updates, and I'm not sure you can even install and 'activate' the serial number any longer. 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

what make/model of camera?

and see:

https://helpx.adobe.com/camera-raw/kb/camera-raw-plug-supported-cameras.html

Answer probably near 100%, No

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

Thanks for replying. My camera is Canon 7D. the link says matching profile is available and the plug in version is 5.6. Minimum Lightroom version is 1, and minimum Lightroom classic/perpetual version is 2.6.  Since my Lightroom is 2, does it mean it should work? Do I install Adobe Camera Raw plug in so my Lightroom will be able to work with CR2?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

One big huge note about current Adobe product names

That Adobe Lightroom 1 is not the older version of your v2. The product you have is now moved on to v12 and called Lightroom Classic.

 

So that Lr 1 referred to in that link is not what you have access to

 

Shortly after Adobe went to the subscription model of marketing, they decided that it would be just fantastic to roll out the mobile part of Lr into a separate product marketed at the smartphone owners. And at one point the marketing genius (not) decided to call that Lightroom, and renamed the product you have, currently called Lightroom Classic.

 

Pissed off near 99% of existing customers.

 

That Lightroom product is also referred to by Adobe as Lightroom Ecosystem (Cloud Based), occasonally mus named Lightroom Desktop, has customer nickname Lightroom Cloudy. It stores Albums on the cloud, and the photos on the cloud, while running off your PC

 

Lightroom Classic, keeps a catalog on a hard drive, and photos preferably on hard drive.  Classic is more capable than cloudy.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

So, for your camera, you would need to upgrade your Lightroom (perpetual) v2, to Lightroom (perpetual) v5.6  /edit/  2.6 (I see I made a mistake)

 

One big problem, that would require a license, and Adobe no longer sells those.

/edit/ My bad, conflated ACR with Lr (perp)

 

Another big problem, Adobe no longer directly provides a source to acquire that version (some site may exist, but no license)

 

A work around is to convert your RAW images to DNG, either via Canon Software, or Adobe DNG converter, or other third party software.

 

About Lightroom and Adobe Camera RAW, Camera RAW code is built into Lightroom, Lightroom does not use the Adobe Camera RAW plug-in. The Adobe Camera RAW Plug-in is for use by Photoshop. Downloading and installing the latest Adobe Camera RAW will do nothing for your Lr2. That link provided, while titled Adobe Camera RAW, is inclusive for several products supported cameras.

 

Note that it has become common to refer to the old Lightroom v6.14 and older , non subscription, as perpetual or stand alone. 

 

Also note that at one point the moniker CC showed up in Adobe product names post subscription. That term is no longer used, and usual refers to first subscription product, or in error, perpetual, to be avoided.

 

Now a note about the available subscriptions at Adobe. The plans. as mentioned the current product that you are used to is called Lightroom Classic, not just Lightroom. While their is a plan for just Lightroom, their is no plan for just Lightroom Classic. The first Plan that provides Lightroom Classic is one of the two Photography Plans, ( includes Photoshop, Lightroom, Lightroom Classic, Bridge, and some odds and ends). So, should you go subscription, be aware. Also be aware that if you decide to go with a monthly payment, you are on the hook for 12 months, and a steep penalty if you bow out.If you go for an annual subscription, used to be a pitifully small discount, not sure if they still do that, and bowing out may be more painful.

 

And a caution, as the operating systems capability improves, more specifically as cyber security in the operating systems improve, more and more old applications fail. Eventually that old v2 will not work. Also, some features in the older Adobe software may depend on third party licenses and/or agreements. Paid for by Adobe. Adobe may decide to no longer pay that bill. Things like mapping, face detection. Had already occurred.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

Thank you very much for the history lesson. I felt like a cave man being teleported into 21 century. Other than Adobe, do you have any tool recommendation that work with CR2. I primarily need to adjust color temperatures every few months.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

You Canon 7D came with a software disk that includes "Digital Photo Professional" which is suitable for editing RAW images. If you've lost the disk you can download it from Canon:

https://en.canon-cna.com/support/consumer_products/software/digital-photo-professional.html?os=windo...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

There seems to be a fair bit of misinformation posted in this thread. 

 

So, for the record, the perpetual license version of Lightroom 2 will install and run on Windows 10 (I know, because I currently have version 2.7 installed on my Win10 system). Secondly, the Canon 7D was first supported by the perpetual license version of Lightroom 2.6. That means that if you can upgrade your current version (which I assume you installed from disk, meaning it's likely the base version 2.0) to the final release version 2.7 then you should have no issues processing raw files from your 7D. Try this link for the 2.7 download: https://prodesigntools.com/products/adobe-lightroom-2.html

 

No need for the DNG converter or other software, you should be able to achieve what you want using your 2.x version of Lightroom.

 

What I don't know is what, if any, of the Lightroom functions may have stopped working as the operating systems changed over the years (Windows XP was still supported long after support for Lightroom 2 ceased). But if you're not an extensive user of Lightroom you may be fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

Thanks Jim! My Lightroom version is 2.0. It is installed on my Windows 10 but failed to check for update from the drop down menu. It is . I did click on the link in the pro design tool website, and it leads me to $9.99/month subscription. When I tried to register with my serial number, and it is rightly saying it is already registered. But in the mean time, there is no activated device on my account. Adobe has cut the tie with the stand alone owners like me. It is frustrating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

LATEST

The download is at the Link John provided but you have to search for it.  I just downloaded it for Windows.  

 

https://prodesigntools.com/direct-download-links-for-lightroom-3-and-photoshop-elements-8.html/comme...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

quote

So, for your camera, you would need to upgrade your Lightroom (perpetual) v2, to Lightroom (perpetual) v5.6

 

For the Canon 7D, updating the old Lightroom 2.0 to at least version 2.6 (not Cloud) will work.

 

5.6 is the minimum version of Camera Raw required which does not affect Lightroom.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

In summary-

You will need to convert your files to the DNG raw format. DNG LEGACY SUPPORT 

If you computer system is not 'current' you may not be able to use the DNG Converter.

So will it work for you ? Yes or No! It depends....

 

Upgrade to Version 12 you may be pleasantly surprised with the improvements.

$9.99 PHOTOGRAPHY PLAN (USA)

Regards. My System: Lr-Classic 12.0.1 Photoshop 24.0.1, ACR 15.0, Lightroom 6.0, Lr-iOS 8.0.8, Bridge 13.0, Windows-11.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines