Lightroom 9.4: before/after view in Develop slow

Explorer ,
Oct 02, 2020 Oct 02, 2020

Copy link to clipboard

Copied

Since a while, when I'm in Develop and switch to before view (with \ key), this will take several seconds. Same when switching back. I recall this being much faster before.

I have an Apple iMac 2017 5K, with a 3.8 GHz Quad-Core Intel Core i5 and 40GB RAM.

I am running Lightroom on my internal SSD (catalog and photo's)

I have set the camera RAW cache to 60GB or something

GPU is enabled (custom setting)

I have optimized my catalog

 

Regular edit are running fine as far as I can tell, it is the before/after view that slowed down.

Am I overlooking something?

 

Views

206

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Oct 10, 2020 Oct 10, 2020
Well, I ended up re-importing the photos as this was the only thing that solved the problem.

Likes

Translate

Translate
Adobe Community Professional ,
Oct 02, 2020 Oct 02, 2020

Copy link to clipboard

Copied

Please try switch off the GPU support from the Lightroom preferences and check if that helps to fix the issue

Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor" > Restart Lightroom.

Adobe Lightroom GPU Troubleshooting and FAQ 

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 02, 2020 Oct 02, 2020

Copy link to clipboard

Copied

Switching off GPU support does not make  much difference.

The strange thing is, I can do some edits (for example reducing highlight value and adding clarity) and switching between before/after is fast. If I do one extra edit (for example crop), switching between before/after becomes slow. And it remains slow, even if I undo the crop.

I am very sure, that switching between before after was always fast some time ago.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2020 Oct 03, 2020

Copy link to clipboard

Copied

It is getting stranger. I noticed that before/after switching was still quick on photos I edited a few months ago.

 

I also noticed that my default RAW settings (or develop settings) were different. For example, the default value for sharpening was higher (40) than before (25). So I made a new set for RAW defaults and imported an already imported photo again with a different filename. I applied the same changes and to my surprise switching between before/after is quick again. When I go the the other (duplicate) photo before/after is still slow (with beachball).

 

So how do I go from here? Do I have to re-import my last set of photos to solve the problem? (I am not enthousiatsic about that as I already edited photos). Or is there a better solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 03, 2020 Oct 03, 2020

Copy link to clipboard

Copied

Look at the History oif edits for the image/images that are slow. Is there any Adjustment Brushing going on?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2020 Oct 03, 2020

Copy link to clipboard

Copied

No, no adjustment brush. Just some straightforward edits like clarity, brightness, saturation, shadows and occassional cropping.

All my edited images from the last import are slow when switching between before/after. I checked images I edited last year, and all of these are fast (even those with adjustment brush).

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 10, 2020 Oct 10, 2020

Copy link to clipboard

Copied

Well, I ended up re-importing the photos as this was the only thing that solved the problem.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

I have the same problem Lightroom / no GPU acceleration in the before-view 

 

I noticed that it is related to GPU support, because in the before view GPU acceleration does not work.This affects not only my old files, but also newly imported files, so a reimport can't really help here? Are you sure that the reimport fixed the problem for you?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Yes, the reimport fixed it for me. Note that I also changed my develop/RAW settings as these were changed (because of a LR update?), see my post of Oct 3, 2020.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the quick reply.

So for me, unfortunately, a reimport does not fix the problem. But I see that in the before view the GPU is not working, so everything is done by the CPU and that makes the computer slow. When I crop an image it gets better, switching to the before view is then faster because the image has less pixels and the CPU has less to calculate. But it only affects raw files. Other formats like .psd and .tif do not cause problems, probably because Camera Raw is not used.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines