Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom Classic 10.3 not responding while launching on macOS

New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

Hi all,

Been on the sturggle bus with LRC for about a month now. It'll take an hour and 10+ tries to open LRC. It freezes at multiple points when loading a catalog, leaving helper, -wal and -lock files that I have to remove each time it stops responding. IF it actually loads correctly and the catalog is ready to be used, there are zero issues and it runs smoothly. 

 

I've updated, have plenty of storage, emptied the cache, restarted the computer, unchecked "enable graphics processor," nothing changes it aside from it loading from random luck. Any suggestions what this could be? Thanks!

TOPICS
Crash or freeze, Mac, Performance, Problem or error

Views

97

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

LATEST

Hi,

 

We're sorry about the experience with Lightroom Classic due to the application freezing on launch. Would you mind telling us which macOS version are you working on? Since when are you facing this issue? 

 

If you are using macOS Big Sur, please ensure Lightroom Classic as the necessary permissions by following the steps mentioned below:

1. Go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy tab.

2. Then select Accessibility from the list to the left & check if Lightroom Classic is added to the list with a check mark in front of it.

3. If Lightroom Classic is not a part of the list, please add it by unlocking the window first using the lock at the bottom left, then clicking the + icon & navigating to the Applications folder.

4. Also, grant permissions to Lightroom Classic under Full disk access located in the same list as Accessibility.

5. Once done, restart the Mac & check if it helps.

 

If the issue persists, you can try to reset the preferences of Lightroom using the steps mentioned here: https://adobe.ly/2JSym5e

Please backup your presets prior to resetting the preferences.

 

Let us know how it goes!

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines