Lightroom Classic 11.1 doesn't launch past splash screen on 40GB RAM i9 iMac running macOS 12.1

Community Beginner ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Upon launch, my Mac LrC 11.1 doesn't get past the splash screen on  my 2019 5K 27-inch i9 iMac with 40GB RAM running macOS 12.1.

 

LrC hangs on the splash screen "forever" ... and I need to use Force Quit to stop LrC.

 

For the past several years, LrC would launch almost instantaneously on this machine.

 

This is not limited to Monterey (macOS 12.x) -- it also happened on Big Sur, so I updated to Monterey to see if that would fix the problem -- it didn't.

 

If I reboot this Mac, I can get LrC to launch normally and quickly. However, after some period of normal Mac usage, I can then no longer launch LrC.

 

This seems different from the "corrupted Preferences" issue since LrC starts normally some of the time.

TOPICS
macOS

Views

141

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Lightroom Classic. Would you mind telling us what's the latest thing you see Lightroom Classic loading on the start-up screen (splash screen)? Please ensure that Lightroom Classic has the necessary paermissions on the Mac by following the steps suggested below:

1. Go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy tab.

2. Then select Accessibility from the list to the left & check if Lightroom Classic is added to the list with a check mark in front of it.

3. If Lightroom Classic is not a part of the list, please add it by unlocking the window first using the lock at the bottom left, then clicking the + icon & navigating to the Applications folder.

4. Also, grant permissions to Lightroom Classic under Full disk access located in the same list as Accessibility.

5. Once done, restart the Mac & check if it helps.

 

You can try to reset the preferences of Lightroom using the steps mentioned here: https://adobe.ly/2JSym5e

Please backup your presets prior to resetting the preferences.

 

Let us know if it helps!

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

I made the changes under Accessibility and Full Disk Access as requested. LrC was absent from both settings previously.

 

I see if the poor launch behavior returns and report back here ... either way. Though it may take several days for me to post.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

I followed the advice of nikunj.m and now my LrC launches normally, and has contined to launch normally for several days.

I can't be sure that there is actual cause and effect involved here, but regardless, my LrC now works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Bummer. This "hang at splash screen" behavior has returned for my Mac LrC.

Very strange. I haven't done anything out of the ordinary on this iMac.

On launch, it gets stuck on the splash screen and after ~five minutes of waiting I need to resort to Force Quit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

I should add that deleting the Preferences PLIST (~/Library/Preferences/com.adobe.LightroomClassicCC7.plist) makes no difference -- still hangs on launch.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

I have had to roll back to LrC 11.0.1 to get a working system. That version launches normally and fast.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

AirPlay the culprit?

 

I have indeed been experimentling with AirPlay-ing audio from this iMac (the iMac that is trying to run 11.1 LrC)

 

Maybe there is a link?

 

See issue here:

https://community.adobe.com/t5/lightroom-classic-bugs/p-conflict-between-airplay-and-lrc/idc-p/12619...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

LATEST

I installed LrC 11.2 on February 9, 2022, and I have not seen any LrC launching problems. I have used AirPlay almost daily since Feb 9 as well.

 

Link to (related?) AirPlay issue:

https://community.adobe.com/t5/lightroom-classic-bugs/p-conflict-between-airplay-and-lrc/idc-p/12619...

 

macOS 12.2 on a 2019 5K iMac 27-inch

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines