• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Lightroom Classic 11.4 on M1 Macbook: GPU Acceleration Affecting Colours & Select Sky

New Here ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Hello,

I'm having an issue with Lightroom that is very complex in nature. When I run Lightroom in Native ARM (without Rosetta), my Select Subject is flawless almost every time, but my previews appear desaturated. I found a workaround to this by turning off GPU Acceleration, which restored my colours to accuracy but destroyed my performance; Lightroom became very laggy and was almost unusable.

 

I decided to open Lightroom with Rosetta, which solved all my problems (fixed colours with GPU Acceleration ON) except the Select Subject feature was horrible, it would select almost anything but the subject, and in a very weird way, almost as if a Color or Luminance Range was applied to it, but it's a dead end. I've repeatedly checked and there is absolutely nothing there.

 

I used the Select Subject feature on the same photo in both situations. In Native ARM mode, I even tried deleting my previews and rebuilding them as standard-sized, but the problem with the colours did not go away.

 

Here are some details:

M1 MacBook Pro running the latest version of Ventura 13.0

16 GB RAM

Ample Storage

Lightroom Classic CC 11.4

Please let me know if anyone can help!

TOPICS
macOS

Views

174

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 25, 2022 Dec 25, 2022

But disabling GPU stops the issue?  On Mac, that's a function of the OS, maybe  upgrade to the lastest version of Ventura and see if it clears up. 

Also see:
https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html
https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html

Disable third-party graphics accelerators. Third-party GPU overclocking utilities and haxies aren't supported.

Likes

Translate

Translate
Community Expert ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Try a differing display profile, any difference? 

Are you calibrating and creating your own using an instrument and software? If so, do not use a LUT or Version 4 spec profile (use Matrix and V2), that may be the issue. 

 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Thank you for your reply.

 

I am used the native Macbook display with its native Color Calibration; no changes. I doubt anything's happened to it because it's almost over a year old, Truetone and Night Shift are off.

 

I am using the Version 5 (Current) profile. 

 

I have found another sign that it is purely a Lightroom issue. I turned on soft-proofing, and voila. Please have a look at the attached photo. The current is what I SHOULD be seeing in Loupe view, but unfortunately I see the Proof Preview version instead, even when I turn soft-proofing OFF. ( As seen in Photo 4 in the original post)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Screenshot 2022-12-26 at 1.42.42 AM.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Odd that soft proofing to sRGB on your wide gamut display would help. Try Display P3. 

Still seems like a display profile issue. Maybe run Profile First Aid from the Colorsync Utility.

You are only running the one, Macbook display?

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

Thanks again for the help.

 

So changing to Display P3, does nothing to the colours. Tried Adobe RGB for the fun of it and that did nothing either. 

 

I ran Profile First Aid, and it came up with about 30 errors. Fixed permissions and now I'm down to 4 errors, all saying: Tag ‘pseq’: Required tag is not present. I did a bit more research and it seems like you can't really do anything about these 4.

 

I am running just the one Macbook native internal display, no external monitors connected.

 

The only confusing thing is when I enable the soft-proofing, I can see what the image in supposed to look like in the Current view, but as soon as I turn it off it goes back to the desaturated colours.Screenshot 2022-12-26 at 2.36.30 AM.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

LATEST

But disabling GPU stops the issue?  On Mac, that's a function of the OS, maybe  upgrade to the lastest version of Ventura and see if it clears up. 

Also see:
https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html
https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html

Disable third-party graphics accelerators. Third-party GPU overclocking utilities and haxies aren't supported.

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines