Lightroom Classic 11.4 very slow to export.

Community Beginner ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

Just Updated to the newet version on Mac OS Monterey on my M1 Pro and Export speeds have decreased exponentially! Its Soooo slow. Exporting 500 RAW to JPG photos would take a couple of minutes, now its gone to at least 3 times slower....

 

TOPICS
macOS

Views

768

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jun 21, 2022 Jun 21, 2022

So I did some testing on 11.3.1 and 11.4 with 250 images. Exportednin 11.3.1 then Uninstalled LR and installed directly to 11.4 and that did the trick. Both export times where very similar, with 11.4 bein a couple of seconds behind, and exporting 250 images under 5 minutes.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

Provide info on your system resources including Disk drives involved in the process, including full disk size and free space available. I would hazard a guess 1 to 2 seconds per image, render the raw image apply all edits and write to disk.

500 images 8 to 15 minutes.

You say prior experience was much faster, then I suspect your free disk space has been reduced over time and is affecting the process. If the disk involved has less than 20-25% free it will begin to affect performance.

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.8,; LrC 11.4.1, Lr 5.4.1, Ps 23.3.2-ACR 14.4,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

MacBook Pro M1 Pro

10 core CPU

16 core GPU
Mac OS Monterey 12.5

16Gb RAM

1TB internal SSD 5,550 mb/s

Disk working on is a Crucial 2TB SSD 1,050 mb/s (always worked on this drive)

Sony a7iv ARW files

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 16, 2022 Jun 16, 2022

Copy link to clipboard

Copied

"Exporting 500 RAW to JPG photos would take a couple of minutes"

 

To build on DdeGannes' reply, that seems unusually fast. 

 

Do a simple performance measurement: Select 50 raws. Using the stopwatch on your phone, time an export of those 50 raws, with Preferences > Performance > Use Graphics Processor = Custom,

 

a) In LR 11.4 with Use GPU for Export turned off 

b) In LR 11.4 with Use GPU for Export turned on

c) In LR 11.3.1.

 

Do three runs for each of a, b, and c, and take the middle time of the three runs.

 

With my Macbook Pro (2019, 8-core Intel i9, AMD Radeon Pro Vega 20 - 4 GB),

 

a) 1.8 secs/photo

b) 1.5 secs/photo

c) 1.8 secs/photo

 

My GPU has only 4 GB, half of the minimum 8 GB LR wants to see before it defaults Use GPU for Export to on, which probably explains why the speed I'm seeing from the use of the GPU is modest compared to what others report. 

 

And I don't observe any difference in speed between LR 11.3.1 and 11.4.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

Thanks, I just downlaoded 11.3.1 to try, did feel it a bit faster but I will do the trials, and Ill get back to you with results.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

I think you can see from the comments, other users are struggling with the same problme on 11.4 and it's not an isolated thing present in my system.

 

hope to see a solution soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

"I think you can see from the comments, other users are struggling with the same problme on 11.4 and it's not an isolated thing present in my system."

 

Right, the goal is not to dismiss the complaints but to try to identify what it is about these installations that is causing the problem.  Most users aren't experiencing the problem (otherwise, we'd see many, many more complaints by now).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

not saying your are dismissing and we appreciate the time and support, maybe other users havent seen any issues for some reason, but here we have Windows Users experiencing the same issue as my Mac M1 Pro system, or aUser with even more RAM than mine is also seeing something wierd happening.

 

Will send report today.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

I upgraded to 11.4 and the exporting was at least 2-3x slower.  Sporadic starting/stopping with the progress bar.  On Windows 10, fast machine with SSD with plenty of disk space.  This was with the GPU setting set to Auto or Off, no difference. 

 

I downgraded to 11.3.1 and it's back to normal without this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Hi Chris, 

My download totally slowed down last week, couldn't work out what was happening. Total panic and nearly missed a deadline. I'll revert to the 11.3.1 version. Thank you so much for your comments here. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2022 Jun 18, 2022

Copy link to clipboard

Copied

Yup, mine is also exponentially slow. Taking like 30 mins to export 60 files when it used to take like two to five minutes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2022 Jun 18, 2022

Copy link to clipboard

Copied

Revered back to 11.3.1 and is now exporting as normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

Sadly its the only option 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

Hi,

Could you share your export settings with us? It the export slow on CPU or GPU in LrC 11.4? If you have a lot of edits on the image, could you share a sample image with edits saved?

 

 

Venkatesh Penjuri
Adobe Lightroom Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

Mine are simple exports of TIFs to JPEGs without any edits, without GPU.

 

s = {
id = "B3556DA7-B9BE-4516-BAA5-109B61F48927",
internalName = "0 Print",
title = "0 Print",
type = "Export",
value = {
collisionHandling = "ask",
embeddedMetadataOption = "copyrightAndContactOnly",
exportServiceProvider = "com.adobe.ag.export.file",
exportServiceProviderTitle = "Hard Drive",
export_colorSpace = "AdobeRGB",
export_destinationPathSuffix = "Print (high-res)",
export_destinationType = "sourceFolder",
export_useSubfolder = true,
export_videoFileHandling = "include",
export_videoFormat = "4e49434b-4832-3634-fbfb-fbfbfbfbfbfb",
export_videoPreset = "original",
extensionCase = "lowercase",
format = "JPEG",
includeFaceTagsAsKeywords = true,
includeFaceTagsInIptc = true,
includeVideoFiles = true,
initialSequenceNumber = 1,
jpeg_limitSize = 100,
jpeg_quality = 0.8,
jpeg_useLimitSize = false,
metadata_keywordOptions = "flat",
outputSharpeningLevel = 2,
outputSharpeningMedia = "screen",
outputSharpeningOn = false,
reimportExportedPhoto = false,
reimport_stackWithOriginal = false,
reimport_stackWithOriginal_position = "below",
removeFaceMetadata = true,
removeLocationMetadata = true,
renamingTokensOn = true,
selectedTextFontFamily = "Myriad Web Pro",
selectedTextFontSize = 12,
size_doConstrain = false,
size_percentage = 100,
size_resolution = 300,
size_resolutionUnits = "inch",
tokenCustomString = "",
tokens = "{{com.adobe.title}} - {{naming_sequenceNumber_2Digits}}",
tokensArchivedToString2 = "{{image_name}}",
useWatermark = false,
watermarking_id = "<simpleCopyrightWatermark>",
},
version = 0,
}

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

I find export nearly 1/3 as fast as before--initially. I'm on a MacPro with Mojave and 64GB RAM and 1TB Samsung NVME drive. The only consolation is it seems to speed up as time goes by. With a 288 RAW NEF export to jpeg, it takes nearly 5 minutes to export 5 files, with only like 120% CPU usage, but then it starts using more cores and it is exporting more the way before with previous update. I tried with GPU for export on and off, and no real difference. It seems like when it starts it tries to figure out the strategy for using more cores and takes a long time to decide, then suddenly after 5 minutes, it figures out there are 6 or more cores and goes much faster, using up to 650% CPU on i9900KF (8-core).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

On my Windows computer, I found that 11.4 would create more than 15 blank files during export, which I assume means that it's working on 15+ images at the same time in parallel. With 11.3 and older, it would only have 3 or 4 blank files at the same time during export. Perhaps this extra parallelism is reducing efficiency. However, I haven't recorded the exact time for completing exports in the past, so I have no reference to check whether or not it's any different now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

Actually, I checked this again on my Windows computer, and I was wrong about the number of parallel images being worked on. There was actually only 2 blank files at the same time during an export job of 480 RAW to TIFF. I don't know why yesterday Windows Explorer was showing me 15+ blank thumbnails at the same time, I guess the thumbnail generation wasn't able to catch up to the file generation, but today I looked at the details view to check the file size to see whether or not they were empty.

 

A problem with 11.4 that might cause you to think it's slower than previous versions, is that the progress bar is showing a much smaller percentage of completion than the actual amount. It shows me 3% when 30% of the images are in the export folder, 7% when 60% is completed, and 22% when 90% is completed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

I used a stopwatch and for me it definately is extremely slower.    It was holding up our workflow considerably so had to downgrade.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2022 Jun 21, 2022

Copy link to clipboard

Copied

So I did some testing on 11.3.1 and 11.4 with 250 images. Exportednin 11.3.1 then Uninstalled LR and installed directly to 11.4 and that did the trick. Both export times where very similar, with 11.4 bein a couple of seconds behind, and exporting 250 images under 5 minutes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

I am also finding a massive decrease in export times since "up-grading" to 11.4

Macbook Pro 16 M1 Pro (2021) - Montery 12.3.1 - 16gb - 1Tb (over 300Gb available)

atleast 2 to 3x slower and the CPU usage in Activity Moniter hardley even ramps up 30-40%

Where before the CPU usage was running close to 100% for the duration of the export.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

I think I may have found a solution - Preferences / Performance / Camera Raw - Make sure 'Use Graphics Processor' is set to 'Custom' and select 'Use GPU for Display' and NOT "Use GPU for Export'

Restart Lightroom and exports are super-speedy again using nearly 100% of CPU power available.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

This didn't work for me. Only solution was reverting back to 11.3.1. I can't wait an hour to export images that usually only take a minute or two, SMH. Hopefully Adobe addresses this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

There's definitely an issue with 11.4. I have a fully-spec'd M1 Pro and it took almost 30 minutes to export 96 images, set to 800 pixels on the long edge and absolutely no editing on the files (aside from adding a watermark). Uninstalled 11.4 and reverted back to 11.3.1, took under 2 minutes to export all 170 images. Adobe screwed something up, per usual.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

LATEST

I has been so slow during the past month I am almost proficient at Capture one while I wait

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines