• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Lightroom Classic 12.1 slowness all around - is cache not working?

Participant ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

I'm a long time Lightroom user with 30 years of desktop support experience and 20 years of pro lab software and proofing experience.  I've gone through every recommendation around on improving performance and the only thing that helped was replacing my video card (AMD to GeForce. both were $350 on sale,)  It bought 100% view waiting from 10 seconds to 5, but not all the time.  Even navigating between 24mp images and JPG's is crawling.  The 100% resolution rarely loads and as you're going through a library the images are blury (as all get out.)  My graphics resources/cpu/drive aren't being maxed out either, nowhere close. 32GB i7 full SSD's.

 

I'm married to Lightroom and can't divorce it. I use an am familiar with other software, but I NEED LIGHTROOM TO WORK.  I have vision issues and Lightroom has the largest fonts and tools of most programs.  The others may enlarge better, but they become unusable.

I watch Hudson Henry go through a library on his MAC M1/M2 and he has he same issues!  It is painful and unacceptable. The Cache is supposed to let you view the folder you're in, and pre-load the images around it.  Even going back and forth between images that loaded is delayed.

 

PS  I don't let anyone access my computer remotely and don't have the time to jump through hoops with technical support.

TOPICS
Windows

Views

475

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

This issue is occurring in the Library Module?

Camera RAW CACHE is not used in the Library Module. Probably something else going wrong.

 

Have you considered that your library previews might be fouled up?

 

And have you changed the preferences setting (performance) to not use Graphics Acceleration, just as a test?

 

Oh, and where do you keep your catalog? Local HD? As opposed to Network, NAS, Dropbox, cloud.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Thank you for the reply.  It is everywhere, even with new catalogs and reset preferences.  I run 5 SSD's, one for my OS, two for storage, and one for cache.  Dedicated PSI-E bus reduces all with 3D NAND.  I run all sorts of rendering, business software, and sim games without any trouble.  (They are currently not installed on this machine.)  I have several devices I've recreated the problem on.  I tested a basic catalog the last time I redid my system with everything based on the local drive as well.

As I mentioned, I witnessed it in Hudson Henry's last workshop video.  It's not me.  🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Just in case, can you post your system information, as LrC reports it?

/Help/System Info/

 

Mostly interested in OS version/build, CPU, RAM, library path, and GPU info. Not at all intetested in all that gobblygook that shows up after plug-ins. Delete anything you are not comfortable with.

 

I have a Windows and a MAC without your issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

This is from my older machine.  I noticed below that "memory cache size" is empty, but all of the caches are functioning/updating in the target folders.

 

20230131-lrcv12.1-systeminfo2.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

The memory CACHE size would just be a value at the time you inspected the sys info, it may vary. I just looked at a sample of my Sys Info, I keep on hand for sharing, at it was also 0, That on a PC with no such issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Your GPU driver version shown as 30.0.15.2698 (Windows Store info) would be NVIDIA v526.98.

Now if you visit :

https://www.nvidia.com/download/driverResults.aspx/198796/en-us/

You can see that a slightly newer driver has been released

Game Ready v528.24, and Studio v528.24

 

Adobe support pages often talk to keeping those GPU drivers up to date. Mind you, typically, more of a Develop module issue.

 

If I remember correctly, you were coming from AMD GPU.

 

For the NVIDIA GPU's, management/control of that GPU is largely thru the NVIDIA  GeForce Experience app. use that app to check for and install GPU driver updates. When you do so, select custom for install type, that forces a clean install.

 

If you are not a gamer, it is recommended that you select a Studio driver as opposed to a Game Ready driver, even if the same version. Studio better tested, better for graphics programming.

 

One additional note about that GeForce Experience, make sure it is up to date. And double check that it is treating Lightroom Classic as a program receiving extra love from the Driver (acceleration). On newer GeForce Experience versions, that should occur automatically by default.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

I assume this is a desktop, not a laptop, so you probably have a nice PSU, and do not have a throttled down CPU, hence you can go for more power. I would assume that you have already done the following, but sometimes OS updates can foul this up. Speaking of tip 8 in:

 

https://www.pcmag.com/how-to/12-tips-to-speed-up-windows-10-windows-11

 

Would have zip/nada with MACOS. And falls under the concept of just in case.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

LATEST

I think you might have missed that I've been doing this for 30 years.  My "checkup list" is 100 items long.  Sure I'm a little older now, but I'm not aged out by any means, I can run circles (physically and mentally) around new techs, and I remember taking computer classes with programmers that coudl code, but couldn't find the power switch in a lab.  LOL  This was worse with 45mp images from y Z7II, but now it is with 24mp images from A7C and even JPG's from my Z30.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines