Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom classic 8.2.1 - Photos have read-only access

New Here ,
Apr 27, 2019 Apr 27, 2019

Copy link to clipboard

Copied

Photos have read-only access

I upgraded from Photoshop Lightroom 5.7 to CC subscription Lightroom Classic 8.2.1.

My images are stored on internal hard drive.

With Lightroom 5.7 I have no problem to write metadata into photos. However, when I try the same with Lightroom classic 8.2.1, I'm getting error - photos have read-only access.

But when I check photos, the check mark for "read-only" is unchecked.

Permissions - I'm the only user (administrator), and all of principals (windows 10) have full access to image files.

After trying a lot of things (changing permissions, installing/un-installing lightroom, creating new catalogs, ..) I finally figured out what is the problem:

My image files are on virtual drive. I created virtual drive using DOS command "subst" (historical reasons; subst 😧 G:\...\....\....\Photos ).

Lightroom 5.7 doesn't have any problem with such created virtual drive, can write metadata into jpg files, but Lightroom Classic (newest version) can't. Always getting message "Photos have read-only access".

If I dismount the virtual drive and point the Lightroom Classic 8.2.1 catalog folder to the real location of photos, then the metadata writing works.

So my questions are:

  • is this a bug in Lightroom Classic 8.2.1 that it sees jpg files on virtual drive as "read-only" or is this intentional? Lightroom 5.7 has no problem with it.
  • Is there some way around this issue so I can continue using my virtual drive? (a lot of my applications are dependent on it).

Views

764

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

I have the same problem, no idea how to fix this

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

me too

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

I also have trouble with this. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 05, 2021 Oct 05, 2021

Copy link to clipboard

Copied

Two year old posting with no solution, Original poster may have fixed or moved on, who knows.

 

No idea what the Operating System is for any of the people posting.

 

Please post your own problem. When you do include the following:

 

  • Complete Adobe program name and vetsion
  • Complete Operating System name and version
  • CPU info
  • RAM info
  • Any error message you get
  • Any screenshots that might help

 

This community site does not work all that well to Me To postings, largely a member issue.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

LATEST

I have had problems with this for years.  when attempting to save metadata lightroom . first it gives me a message that an unknown error was encounter while trying to save metadata then it

gives me an error saying I have read only access.

Using windows 10

custom built machine from Puget systems

plenty of ram

not on external drive

Lightroom 11.0

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines