• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
6

Lightroom Classic - currently on v13 - can't import jpg when there is a mov with the same name

Community Beginner ,
Nov 27, 2023 Nov 27, 2023

Copy link to clipboard

Copied

Dear sir/madam,

 

I am trying to import photos and videos that are in the same folder but they are from different cameras. Coincidently, there were 3 jpg files with the same name as 3 mov files. When I imported, the jpg didn't show in the library. After trying different things for a while I verified that if I changed the file name (either the jpg or mov), Lightroom was able to import both files.

 

I hope it helps. Best regards,

 

Marcos

TOPICS
Windows

Views

114

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 27, 2023 Nov 27, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

If a video file is paired with a JPEG with the same file name, by default when you import the video, LR will treat the JPEG as a "sidecar" and not import it. Instead it shows up with "+JPEG" after the file name and is listed as a sidecar:

johnrellis_0-1701141967949.png

 

This behavior handles some cameras which generated JPEGs as sidecars for videos to hold video metadata (rather than write the metadata into the video itself).  I don't know if there are any modern cameras that do this.

 

You can disable this behavior by unchecking checking the poorly named option Preferences > General > Treat JPEG Files Next To Raw Files As Separate Photos.  Then when you import a video, any similarly named JPEG will imported as a separate photo.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

Hi John,

 

Thank you for your answer. I didn't know about this functionality. I went to Preferences and my check box is already unchecked.

Also my issue is a bit different. I imported the files from two different cameras and coincidetally in one there was a video and on the other an image with the same name. That's when happened the issue I described.

I solved the issue by changing the file name but the problem is that you have to always check the number of files in your folder with the number imported as Lightroom doesn't inform about the issue. Isn't it something that might be better handled by the program?

 

Best regards,

 

Marcos

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

Hi Marcos, 

That check box needs to be on for JPEGS to been seen separately. It's off by default. 

While it does work for Video as John mentiones, it's primary purpose was for those shooting RAW+JPEG pairs, long before Lightroom imported video. It allowed them to bring in both images, but only referencing the JPEG as a sidecar to prevent clutter in the UI. The phrasing is terrible, I agree, but again it needs to be on and only works for imports made when it's on. It doesn't retroactivaly seprate previous imports. 

Sean McCormack. Author of 'Essential Development 3'. Magazine Writer. Former Official Fuji X-Photographer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

Thank you Sean (and John).

I'll try next time with the checkbox on and report back if I see any discrepancies.

Best regards

Marcos

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

LATEST

Oops, I corrected the typo in my previous reply:

 

"You can disable this behavior by unchecking checking the poorly named option Preferences > General > Treat JPEG Files Next To Raw Files As Separate Photos.  Then when you import a video, any similarly named JPEG will imported as a separate photo."

 

Sorry for the confusion. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines