• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
3

Lightroom classic is running so slow it is almost unusable

Community Beginner ,
Mar 12, 2020 Mar 12, 2020

Copy link to clipboard

Copied

I have been using Lightroom since version 1.0. I am up to date with my updates on the current classic CC. It has been running so slow for the last several months it is bordering on totally unusable. When I open it takes minutes to load. Every click on the import process, from import, to selecting the drive, to selecting the folder (both for cards and already-uploaded on RAID on USB-C connection), takes 3-6 minutes. I often get the whited out scren and Lightroom is not responding message before it comes back again. 

I am running it on a I7-3770k processor, Nvidia GXO1060,, 32GB RAM, with the catalog on its own SSD. I start the new year with new catalogs for my commercial and news photography, so the catalog have hardly any photos in them. The photos are from a D4 and D810. I regularly optimize the catalog. I do not have an enormous number of presents.. I've done nearly every step on the optimization web page. Help????

TOPICS
Windows

Views

31.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 26, 2022 Nov 26, 2022

Copy link to clipboard

Copied

I would love to know what solution you found. I'm stumped. Three adobe techs and a Microsoft tech and still no change. Very frustrating. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

I actually had this issue when after installing Windows 11, Lightroom Classic would not use the GPU even if acceleration was enabeled and all nvidia and chipset drivers where up to date. The program was unusable! If on asus mobo, this actually worked for me. Armory Crate ---> Settings ---> Update center ---> Install Model identifier and Asus framework service. I'm so happy, almost did roll back.

 

Specs: Strix x570-F, Ryzen 3900x, RTX3070

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

I saw this Armory Crate thing but it's completely new to me. Not installed on my ASUS system. Can you say more about how this works, and how to install it? Is it a BIOS thing or a program one must install? VERY curious to know if this would solve the issue in my Win10 updated to Win 11 system. LRC is absolutely unuseable in that environment. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

It is basically a fancy and a bit crappy software to update chipset drivers, control rgb lightning and so on. Just search your mobo and download armory crate https://www.asus.com/motherboards-components/motherboards/all-series/.

 

I was losing hope, and I really don't even know what GPU Model identifier and Asus framework service does, LOL.

 

In Windows 10 I did not need to install those, LRC worked fine out of the box.

 

 

Below I marked the things I installed. Don't know which one did the trick because I installed them at the same time.

Untitled.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

I am experiencing the same problem. Very, very slow! It's almost impossible to get jobs done on time now. This version of Lightroom Classic is a dog. Major productivity issue. I hope it gets addressed pronto or I'll have to go back to an old version. Seems ridiculous when we're paying for this software on a monthly basis!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Same problem here, this is incredible, from clicking on Preferences to get into Preferences it needs more than 10 seconds, painful slow on an extremly fast PC with all drivers up to date?!? Switching from photo to photo in developer mode is even worse 😕

 

Snimka zaslona 2023-11-06 203950.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Lightroom Classic version: 13
Operating system: Windows 11
Application architecture: x64
Logical processor count: 24
Processor speed: 3,7GHz
SqLite Version: 3.36.0
CPU Utilisation: 0,0%
Built-in memory: 32690,8 MB
Dedicated GPU memory used by Lightroom: 644,5MB / 8031,0MB (8%)
Real memory available to Lightroom: 32690,8 MB
Real memory used by Lightroom: 1581,1 MB (4,8%)
Virtual memory used by Lightroom: 2444,4 MB
GDI objects count: 1184
USER objects count: 2836
Process handles count: 9062
Memory cache size: 0,0MB
Internal Camera Raw version: 16.0 [ 1677 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 89MB / 16345MB (0%)
Camera Raw real memory: -70755MB / 32690MB (-216%)
System DPI setting: 120 DPI
Desktop composition enabled: Yes
Standard Preview Size: 1440 pixels
Displays: 1) 3840x2160
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No
 
Graphics Processor Info: 
DirectX: NVIDIA GeForce RTX 3070 (31.0.15.3203)
Init State: GPU for Export supported by default
User Preference: GPU for Export enabled
 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Please will you check your working drive for space?
Lightroom gets all fussy if your disk is more than 60% full
I gained a lot of speed by dumping all the images I was never going to use/edit

In LRC, in whatever folder, select all your junk images, click Delete, then select "From Disk." This will remove them from both your LRC catalogue and your disk at the same time. Don't forget to empty your digital trash. 

Once my working drive was below 60% used, things sped up quite a bit. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

I'm running everything on probably one of the fastest SSD on the marker which is by the way mostly free as you can see on below screenshot...

 

Snimka zaslona 2023-11-06 221357.png

 

btw, I recently dumped literally thousands of photos.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Snimka zaslona 2023-11-06 222626.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

LATEST

You’ve posted to an ancient thread. It is highly unlikely that the issue described in this thread, though not impossible, is the same one you are currently experiencing. Rather than resurrect an old thread that is seemingly similar, you are better off posting to a new thread with fresh, complete information, including system information, a complete description of the problem, and step-by-step instructions for reproduction. 

 

If the issue is the same, we will merge you back into the appropriate location. 

 

Thank you!

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines