• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Lightroom crashes in Masking tool (AMD 780M Graphics)

Community Beginner ,
Aug 10, 2023 Aug 10, 2023

Copy link to clipboard

Copied

Hi,

I have found a very unusual bug. Lightroom Classic crashes on me every time I go into the masking tool.
As soon as I click on the icon, my entire PC hangs, before after about 30 seconds a message appears that my graphics driver has crashed.

Lightroom itself is then of course completely stuck.

I have already tried to disable the graphics card acceleration, but this has made no difference.

Interestingly, the masking tool in photoshop Camera RAW works without problems.

I have tried older versions of Lightroom Classic, but the problem persists.

The PC I am using is the Minisforum UM790 with the AMD Ryzen 9 7940HS and the AMD Radeon 780M Graphics. I have installed driver 23.7.2.

Does anyone here perhaps have an idea? The AMD Ryzen 9 7940HS with the 780M is fairly new and this is the first graphics driver version that works with this graphics card, but aside from Lightroom I have not encountered any problems and Photoshop (2023 Beta) runs flawlessly.

TOPICS
Windows

Views

2.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 10, 2023 Aug 10, 2023

Copy link to clipboard

Copied

AMD Radeon 780M Graphics

Is that an integrated video control as opposed to a dedicated graphics control card? And as such, without VRAM?

 

https://www.notebookcheck.net/AMD-Radeon-780M-GPU-Benchmarks-and-Specs.680539.0.html

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 10, 2023 Aug 10, 2023

Copy link to clipboard

Copied

Verify that LR is seeing that graphics driver by doing Help > System Info and verifying the displayed driver version is 31.0.21023.2010 (that's the Windows driver version number for 23.7.2).

 

You could try installing an older driver (say 3 - 6 months) older. In the past, some AMD driver-related bugs have been avoided by doing that.  But I can't find any older drivers at amd.com for the AMD Ryzen 9 7940HS.

 

Adobe refuses to let you disable the use of the GPU for AI commands via Preferences, so changing the setting Use Graphics Processor won't have any impact on your issue.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

Hi,

@GoldingD yes it is an intigrierte GPU, with 6 GB of the RAM allocated.

johnrellis Yes Lightroom recognizes driver version 31.0.21023.2010. It's just strange that under Photoshop everything works without problems...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

"It's just strange that under Photoshop everything works without problems..."

 

Do you mean that when you edit a file causing problems for LR in Photoshop's Adobe Camera Raw and invoke the exact same masking commands, it works correctly in Camera Raw?

 

Or do you mean that general editing in Photoshop works fine?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 12, 2023 Aug 12, 2023

Copy link to clipboard

Copied

Hi, the masking tool works in Photoshop but not in Lightroom. So yes 1 to 1 the same module works in Photoshop but not in Lightroom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

Hi, i have the same problem with Lightroom Lr/LrC.
When i use the new AI mask funktion the Lightroom App crash and the hole Computer freeze.

There is no improvement when I deactivate the graphics processor.

my brandnew System: Lenovo Ideapad 5 Pro 14 / 32GB / AMP Radeon 7840HS / 780M with the actual AMD Driver 23.7.2 / with intigraded graphic AMD 780M (31.0.21023.2010)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2023 Aug 13, 2023

Copy link to clipboard

Copied

Same problem with Beelink 7940HS radeon 780M. I'm going crazy from the last 5 weeks, can't deliver jobs to my client.
AMD need to create a specific driver for these APUs (780M), the latest driver doesn't work neither.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 19, 2023 Sep 19, 2023

Copy link to clipboard

Copied

I'm having the same exact issue and have the same computer as the OP. So far I haven't found any fixes, which is frustrating because I can't even use the basic masking tools. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2023 Sep 19, 2023

Copy link to clipboard

Copied

It's most unfortunate that Adobe inexplicably refuses to provide an option that disables the use of the graphics processor the AI masking commands, needlessly leaving users like you high and dry:

https://community.adobe.com/t5/lightroom-classic-ideas/p-allow-users-to-disable-the-gpu-for-ai-maski...

 

It would be trivial to implement.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2023 Sep 19, 2023

Copy link to clipboard

Copied

to make it work better Make sure you have AMD adrenalin edition version 23.9.1

an alternatively go on lightroom preferences and unfortunately have to disable GPU.

pc stills freeze to me too on masks , unfortunately AMD hasnt totally solved this issue 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2023 Sep 27, 2023

Copy link to clipboard

Copied

Same Mini PC, same issues. To partially "solve" and continue using at least old masking tool you should try opening a photo (for me worked trying with an old photo with small pixel count) and closing as fast as you can the tab contaning the "people masking" tool. That part is open by default when you access the masking menu and it's that people recognition that is killing lightroom

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2023 Sep 27, 2023

Copy link to clipboard

Copied

HI,

I decided to try and update the drivers. So I dowloaded from 

https://www.amd.com/en/support/apu/amd-ryzen-pro-processors/amd-ryzen-9-pro-processors-radeon-graphi...

the "Auto-Detect and Install" version of Adrenalin software and went through setup process. First time crashed the system but after a reboot I completed installation and now I have a new Adrenalin Software installed (it removed the one previously installed by Minis Forum I suppose) and last drivers available (ver 23.9.23). 

Now Lightroom seem to work fine, I just tested the features that crashed Ligthroom yesterday, like just opening the Denoise AI window and trying a "Sky" mask.

I suggest trying the same solution.

Regards

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

Hi,

the problem disappeared for me after a graphics card driver update to 23.8.1. There are newer drivers which might work, but 23.8.1 runs without problems on my UM790.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

Same issue. Adobes annoying "new features" pop up is what was causing my Beelink GTX to crash, but if I so much as hovered over an old preset that included a mask my entire system would crash. What is the point of LR if people with fast processors can't even use the features that set LR apart? I tried uninstalling the latest version to an older one and well guess what, the new version updated my catalog and gave me an error that my catalog was to new to use. There was no option to modify the catalog for the older version. So I went back and reinstalled the new LR. Went through all the preferences, making sure everything is correct and updated. Without fail, every single time it even thinks that I'm going to select mask it crashes. Now I'm looking at ditching LR altogether and using Capture One instead. Like what's the point of even having LR with all of its bugs and Adobes refusal to work out the kinks. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

LATEST

@kodyv49772963, please do the LR menu command Help > System Info and copy/paste the entire contents here so we can see exactly which versions of hardware and software LR thinks you're running and important LR options that are set.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines