Lightroom Locking Up When Returning from Editing in Photoshop

Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

Windows Specifications
Edition Windows 10 Home
Version 21H2
Installed on 2/5/2022
OS build 19044.1645
Experience Windows Feature Experience Pack 120.2212.4170.0

 

Adobe Photoshop Lightroom Classic
11.3 Release
Camera Raw 14.3

 

Adobe Photoshop
23.3.0 Release
- set to save files as .TIF


1. Edit photo (Canon CR2 raw file) in Lightroom
2. Select Edit (A copy of file) in Photoshop
3. Make edits in Photoshop and save as .TIF
4. When return to Lightroom, Lightroom locks up. When attempting to exit it says Lightroom is still updating XML

5. Exit anyways and when re-opening Lightroom it isn't locking up.

 

Never did this until both Lightroom and Photoshop received updates sometime during the week of April 11th thru 15th

 

I should note this does NOT happen when I go from Lightroom to any Topaz Labs software.  It creates a TIF file and comes back to Lightroom without a problem.

TOPICS
Windows

Views

232

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

In a first step please try resetting the preferences of Lightroom Classic:   https://helpx.adobe.com/lightroom-classic/help/setting-preferences-lightroom.html 

 

It's recommended to backup your preferences before you reset the preferences to the default settings:  

https://helpx.adobe.com/lightroom-classic/kb/preference-file-and-other-file-locations.html 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

That did not seem to work.  It still loaks up when I get back from Photoshop. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

Just a thought out of the box. You have stated.

3. Make edits in Photoshop and save as .TIF ".

Are you using the file "Save" option or are you using file "Save As" option?

Have you made any adjustment to the file name or destination where it be saves to?

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.5,; LrC 11.3.1, Lr 5.3, Ps 23.3.2-ACR 14.3,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

Save option - the default is set up to save as a .TIF file.

And no modifications to file name or destination.

 

When I get back to Lightroom, the stack is open and it's frozen and I can't close it.  Then when I go to exit I get a warning that Lightroom is still writing to the XMP file but it never seems to finish.  I exit Lightroom and re-open and then the stack can be closed like normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

At Dereck, you stated,

"1. Edit photo (Canon CR2 raw file) in Lightroom
2. Select Edit (A copy of file) in Photoshop
3. Make edits in Photoshop and save as .TIF"

If you are sending a raw image file to Photoshop for editing and the Adobe Camera Raw Plugin, in Photoshop matches what is stated in Lightroom Classic, the image should automatically open in Photoshop. You should not get the option to edit a copy.

Check to see if the Camera Raw plugin in Photoshop indicates 14.3.

See the screen capture.

 

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.5,; LrC 11.3.1, Lr 5.3, Ps 23.3.2-ACR 14.3,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

#2 was a mistake.  I do not get that promt when going from Lightroom to Photoshop.  Only from Lightroom to a Topaz application.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

At the moment I don't have really an idea where the problem can be.  😞

 

What you canb try is to reset the preferences of Photoshop using the steps described here:

Preferences in Photoshop (adobe.com)

Please backup your settings before resetting the preferences. You can check:

Preferences in Photoshop (adobe.com)

 

What happened if you saved the edited picture as an .psd file in Photoshop instead of a tif?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

When I saved as PSD it still locked up (I couldn't collapse the stack) plus I didn't even see the .PSD version until after I exited and restarted Lightroom.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

My only thought at this stage is to return to LrC 11.2.

There are a couple of bugs introduced with LrC 11.3 affecting Windows users.

If you check in the Bug section of the forum there is more info available.

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.5,; LrC 11.3.1, Lr 5.3, Ps 23.3.2-ACR 14.3,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

In the top left of the Lightroom Classic window, there is a small dropdown menu that appears when you hover your mouse over the down-pointing triangle. This allows you to pause/activate Address lookup,  Face detection and Save XMP, provided you have "Automatically write metadata to XMP" selected in the Catalog settings.

Check to see if it is activated or paused? If not then activate and see if that helps.

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.5,; LrC 11.3.1, Lr 5.3, Ps 23.3.2-ACR 14.3,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

It's been activated and I haven't turned it off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

I'm experiencing the same problem.  It is intermittent.  Most times, a round-trip to Photoshop works normally (ctrl-E to edit a file in photoshop, complete edits, ctrl-W (in Photoshop) to return the tif to LR).  But since around the 20th (definitely on the 20th, and again today, but possibly earlier) returning to LR I'll occasionally see this behavior:

  • The tif files completed in Photoshop are not imported into the library.  I sometimes do multiple files in Photoshop.  When coming back into LR today, 2 tif files were back in the library, but 5 were not.
  • The tif/raw group can't be stacked.  Clicking on the '1 of 2' badge does nothing
  • Exiting LR and choosing to optimize hangs.  Exiting LR normally exits.
  • On restarting, everything is functional again EXCEPT the missing tif files need to be imported (they're on disk, just need to be 'added' to the library).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

LATEST

Just to add:  LR 11.3.1, Photoshop 23.3.1, Windows 10 Pro v21H2 19044.1645 (up to date)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines