Lost Lightroom Classic connection to cloud

New Here ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

Recently had to restore my Lightroom Classic catalog with a backup catalog.  All went well except!  I have lost 4500 connections to pictures added from my mobil device by way of the cloud.  All of these images remain in Lightroom (cloud) and remain visible as previews in my Lightroom Classic.  However, all connections are broken.  I am aware that I can download to my PC all 4500 images stored on cloud and then connect them to the resident files.  This will, of course, take forever.  There must be a way that I can resync the preview images shown on my LRC with the images that remain resident in the cloud in LR.  I have been trying for several days to find a way but to no avail.  Help, please.

TOPICS
Windows

Views

96

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

Can you share a screenshot of what you see in your Classic catalog? It sounds like you just need to fix the link to the sync download location of the images from the cloud.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Sure.  Happy to show.  As is true of any preview that is disconnected from the original image, all of the 4500 previews that were"disconnected" when restoring my catalog with a backup catalog show the exclamation point in the box un the upper right of those previews.  These are all images that were shot with my iPhone and migrated into Lightroom Classic by way of Lightroom and the cloud.  The originals are in the cloud and restoring my catalog did not restore the connection between the Lightroom Classic previews and the original images in the cloud.  These are 4500 images of the 12,000 images in my Lightroom Classic on my PC.  While I may be able to reconnect all 4500 images by downloading the oritingals from the cloud and onto my PC, I would have to do this one image at a time.  I am hopeful that there is a way to simply reconnect them all and its remains a mystery why this didn't happen when I opened my backup catalog.  

Please note the folder name given to the disconnected preview.  This is the same folder identification for all of the 4500 disconnected previews.

Thanks very much for your help on this!  IMG_5696.jpgIMG_5694.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Just some thoughts.

LrC can only have one Catalog file synced with the Creative Cloud at any time.

The sync info is stored in the Catalog file.

How current is the Backup Catalog you are trying to restore?

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.5,; LrC 11.3.1, Lr 5.3, Ps 23.3.2-ACR 14.3,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Your screenshots don't show the cloud icon in the upper right corner. Is the sync turned on and not paused? 

Also, all images in a Lightroom Catalog are on a hard drive somewhere. They have to be. That is how Classic works. So even though the images from your Lightroom cloud remain in the cloud, they are also downloaded to your computer. If you did not choose a custom location for this download then the images are in a sync data file in your pictures folder. Looking at your screen this is likely what the "Other Lightroom Device" is that is listed in the folder panel. I don't know why you have so many of them though. 

You can fix the link to the images by reconnecting them to the location of the images in the pictures folder. This article should help https://helpx.adobe.com/lightroom-classic/help/locate-missing-photos.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Thanks for sticking with me, Theresa.

The cloud icon actually shows that my catalog is completly synced.

As for the images in my Lightroom Catalog being on my hard drive.......yes, all images that I loaded directly from camera or card reader are on my hard drive. However, those in my Lightroom Catalog that were taken on my mobile device were loaded into Lightroom on the Cloud and then synced by my Lightroom Classic so are, therefore, in the cloud and not on my hard drive.  Those are the images that have not resynced after opening my backup catalog.

I am familiare with the process of locating missing photos and have used that when I have broken the link between Lightroom Classic and the images resident on my computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

This is the part you aren't understanding correctly. When you sync your Classic catalog with Lightroom everything in the cloud downloads to a hard drive. Classic works like a vacuum and pulls everything down, because Classic can only work with images that reside locally. What makes this confusing is that they also remain in the cloud unless you remove them from the All Synced Photos collection. When you do that they are deleted from the cloud but remain on your hard drive and remain in your Classic catalog.

Your Classic catalog has broken the connection with the downloaded images on your computer. Review the link I shared above. Also, here's a youtube video of mine that explains how to fix broken links. https://www.youtube.com/watch?v=3gUW67J4k1E&list=PLddX4levwRk7Hj948QlExt6zMPpuQmvu0&index=5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Thanks very much, again, Theresa.

 

And thanks for the video regarding missing photos.  I believe I understand this concept and have worked with this over the years.

 

What is certainly news to me, however, is your saying,  “Classic works like a vacuum and pulls everything down, because Classic can only work with images that reside locally.”  I have actually assumed this to be true over the years as well.  Yet, when I opened my very recent catalog backup, all of the files that came into my Lightroom Classic by way of Lightroom and the Cloud have broken links because they cannot find any synced images that you say have to be on my hard drive.   I am hoping this is true yet I cannot locate any of these “downloaded” images nor can Lightroom Classic. 

 

Do you happen to know the file naming convention for these files vacuumed from Lightroom?

 

Again, many thanks.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

By default they go into your Pictures folder unless you change the location in the preferences. Like I said earlier I am pretty sure the Drive L: Other Lightroom Device seen in the folders panel is the location of your downloaded images. Open up one of those folders and see what the path looks like to the images. Also, view the contents of your Pictures folder. Look for a Lightroom sync data folder. Open that and see what is in there. Most likely that is where you will find your photos.

After you fix the connection I recommend that you change the location of the download in your preferences. You will have an option to move everything to the new location. Here's a screen capture of mine. You can see that my downloads go to an external drive. This works much better than the default setup.

2022-01-16_14-31-52.jpg

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

I had another thought. You could try simply rebuilding the sync in Classic by option clicking in the sync activity field shown in my screen capture. This might rebuild it and fix the connection to the images.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

Thanks again, Theresa, for your continued help.  Sorry, I had to be away from my dest the last 24 hours.

Yes, the multiple "Other Lightroom Device" under folders is a mystery.  I deleted a couple that held no files.  I have included the remaining that appear to hold other disconnected images all of which came to my Lightroom Classic from my iPhone and via Lightroom Cloud.  As you can see in the attached images, they all show disconnected folders and the images in those folders are, of course, disconnected as well.  I have search my hard drive for any folders entitled "Imported Photos" and find none.

 

Also, I have never changed any locations under preferences so all of my original images have landed in "Pictures" and within subfiles that are dated.  

 

I have also attached an image of my Cloud Storage that also shows what Lightroom Classic says is the nonsensical folder name where all of my previously synced files are now said to reside. When I click on the little arrow to the right of the file name I am taken, in folders on the left side of my screen, to folders of fall originals residing on my hard drive and which are properly shown as connected in Lightroom Classic.

 

Lastly, I appreciate your thought that occured to simply rebuilding the sync in Classic.  However, I do not know what "option clicking" in the sync activity means.  If in Windows this means "control clicking," I have done that with no result.  I have include an image that shows that my "Sync Activity" shows 0 pending.

 

You're terrific.  Thanks for your help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

LATEST

Your preferences show the location where Lightroom Classic is downloading the images. They should be in a folder called Synced Images, inside of a Lightroom folder, in the Pictures folder. 

Sorry about giving you a Mac shortcut. On Windows it is the Alt key. Here's an article explaining how with screen captures.

https://lightroomkillertips.com/sync-stuck/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines