LR Curve adjustment difficult on MacOS Sierra

New Here ,
Jul 11, 2016 Jul 11, 2016

Copy link to clipboard

Copied

I'm running the latest CC with the MacOS Sierra Beta on a rMBP-13. I've noticed that adjusting curves is incredibly difficult. I can't make a minor adjustment to any point, it's  a massive jump requiring a lot of touchpad movement. Similarly, scrolling to adjust brush size is either very large or small.

Anybody else have this issue? !

Views

17.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Apr 12, 2017 Apr 12, 2017
Works for me now finally with LR 2015.10 and macOS 10.12.4. Thanks for fixing. It's been a long wait.

Likes

Translate

Translate
New Here ,
Nov 26, 2016 Nov 26, 2016

Copy link to clipboard

Copied

Hi! I have also faced this problem

The problem with working in the Curves in Lightroom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

Hi All

This issue should be fixed in the latest release of Lightroom(2015.8/6.8).

Refer Lightroom CC 2015.8 now available

Regards,

Akash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

I wish I could confirm that but it wouldn't be true...

First of all... it's MUCH better - thank you for that. But (unfortunately) the fix is not fully working, at the start it works smooth and as it should, but after the moment of adjusting the curve my mouse hits invisible wall on the right side of curve area.
It seams like Lightroom is still sending some data to macOS (not all, just from time to time) about cursor position changes and when they accumulate enough to hit the right border of the screen the invisible wall on curve area appears - because mouse can't go any further.

In LR5 (even on macOS Sierra) problem does not exist, because when you hit the curve area it looks like macOS somehow ignores mouse moves and not letting it to reach the screen border after a while of constant adjusting.

In general, it looks like there were a conflict between mouse position on curve area and general mouse position (from OS point of view) and now LR is just reading general mouse position which is limited by screen borders.

WORKAROUND (can't believe I still have to look for workarounds ;P):
- making smaller adjustments and not "going crazy" on curve area
OR resize LR window so the curve area is further from the border of the screen

Guys, let me know if you can confirm that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

Richard Hade wrote:

about cursor position changes and when they accumulate enough to hit the right border of the screen the invisible wall on curve area appears - because mouse can't go any further.

I can confirm that the mouse hits a wall at the right side of the tone curve when you are adjusting the upper right point HORIZONTALLY to the left and right.  This seems to be a glitch/bug in the mouse/tool tracking.  The simple workaround is to let go of the mouse button and then reselect the point.  I think it is definitely a bug.  Post a DETAILED bug report here and it might get fixed.  I will me-too it.

Photoshop Family Customer Community

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 12, 2016 Dec 12, 2016

Copy link to clipboard

Copied

Hi Richard Hade​, Xavier F​, and Bob Somrak​,

Unfortunately, you're all right. The tone curve panel is still having issues. The team has acknowledged the continuing of this bug. Here's the latest bug report and thread that the team is following: Tone curve still broken in LR CC2015.8 | Photoshop Family Customer Community

If you could all go to that thread and post your respective System Information and other relevant details or at least, click the "Me Too" button up top, that would help the bug stay at the top of our priority.

Thank you for following up and being persistent with these bugs.

Melissa

Melissa Rios, Product Manager, Community Experience & Platform | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 12, 2016 Dec 12, 2016

Copy link to clipboard

Copied

Melissa

Thanks for staying on this problem.  Good job

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

Melissa

Let me also say thanks for staying on top of this problem.

As the author of the link that you are referring to, let me just point out two things.

1) I have not tried to replicate all of the various bug reports regarding the tone curve, but looking at them, I think that there may be two issues here, and they may not be closely related. I really encourage your staff to look at all the reports and try to understand them before formulating a solution and regression tests.

2) Wojciech Brzozowski in that thread makes a very cogent argument that this bug is a symptom of a larger issue with Lightroom's user interface engine. Again, I encourage Adobe to understand this comment before fixing "the problem."

My own feeling is that the Lightroom team should just steal the user interface that Photoshop uses for manipulating curves (&/or the interface used in Camera Raw) and adopt it for Lightroom, rather than trying to "fix" what you currently have.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

I don't know about the other Curve tool problems as I am running El Capitan but the tracking problem listed in Posts #28 and #30 has NOT been fixed.  Its not a big problems as the workaround is easy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2017 Apr 12, 2017

Copy link to clipboard

Copied

Works for me now finally with LR 2015.10 and macOS 10.12.4. Thanks for fixing. It's been a long wait.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

After update 2015.8 , Tones curves are always erratic and seems glued if picture have a little brush edit (less than before, but not funny to use), try the curve on Capture one Pro, it's smooth and perfect and i want this on lightroom, please Adobe, Optimize your software, update after update it become like a dinosaur,

if switching to Capture one would be more easy, I would change for it today.

and for informations, the "X" shortcut (reject photo) in library mode, don't work anymore,  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

This bug has now been acknowledged. The team is investigating.

Any updates to the issue will be shown here: Lightroom 6: Tone curve is insensitive to MacBook Pro touch pad | Photoshop Family Customer Communit...

It would help if you could add your voice there and your System Info (Help > System Info > Copy or Save As) to provide the team with more info.

Thanks,

Melissa

Melissa Rios, Product Manager, Community Experience & Platform | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2017 Feb 02, 2017

Copy link to clipboard

Copied

same issue!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 14, 2017 Feb 14, 2017

Copy link to clipboard

Copied

FIX THIS ALREADY!!! Seriously!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

Issue reported as being fixed in 2015.9, Still not fixed. Running MacOS Sierra.

Sorry!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

yannickk79586555  wrote

Issue reported as being fixed in 2015.9, Still not fixed. Running MacOS Sierra.

Sorry!

It would help to know what exactly is still not fixed instead of a generalized statement.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

1- You are not using the MacOS version described in the OP (El Capitan = You, Sierra = All of us)

2- The issue is well described up top

3- More on the issue (Lightroom CC 2015.8: Tone curve still broken in | Photoshop Family Customer Community )

Thx for reading the entire thread

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

I did read the entire thread.

They apparently fixed SOMETHING in the Curve tool although they didn't fix the issue I was talking about.  Are you saying that NOTHING has been fixed or just some of the issues have been fixed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 07, 2017 Mar 07, 2017

Copy link to clipboard

Copied

Good Lord!

The issue in question is NOT fixed. Stop it already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2017 Jun 18, 2017

Copy link to clipboard

Copied

LATEST

^

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

So, lightroom had a major update today, and THIS ISSUE IS STILL NOT FIXED!!!!

Adobe, you are becoming so diversified you can't even fix this issue.

I can't adjust curves vertically.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2017 Mar 09, 2017

Copy link to clipboard

Copied

I've just updated to the latest lightroom version and the bug is not fixed for me either.

This is a tragedy, Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2017 Mar 21, 2017

Copy link to clipboard

Copied

The tone curve display is still not working properly after the 2015.9 release - dragging is not responding to minor cursor movement, it only picks up what looks like faster drags resulting in inability to make fine adjustments.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 22, 2017 Mar 22, 2017

Copy link to clipboard

Copied

Again Adobe the Issue is STILL NOT FIXED, even with the latest update.
Come on!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2017 Apr 06, 2017

Copy link to clipboard

Copied

This issue is still not fixed as of April 6th, 2017. Please fix it asap, a lot of people use curve tool on LR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2017 Jun 18, 2017

Copy link to clipboard

Copied

Found a solution, I don't know if I'm the first to mention this or not.

Just make a small adjustment first, release the mouse, then any other adjustment will be much much easier.

I'm guessing this is for the bottom left of the Tone Curve, since that's where I face this problem. I lift the shadows a bit, then I lift them as desired.

You're welcome!

Take care

PS. I use Lightroom 6.0 (1014445) on a mid-2015 MacbookPro running on Sierra.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2