LR doesn't show all of my image —cuts off edges

Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

When using the transform tool, I discovered a rather disturbing trait of LR. Apparently, the edges are being cut off on all sides. I've been using LR since the beta version and never noticed this, so don't know if it's always been this way or if it's new. When using the Transform panel today, I discovered that there was more to my images than was showing and there's no way I can get it all to show. I use Fit for sizing in the image window and tried other sizes, but that doesn't help. What's up with this?

I've included png's to show that there's more when I use Transform. Original is surrounded by gray; the smaller file is a corner of the image when using Transform. Notice how much more you see of the rounded upper part with the dark curve than in the original image.

I'm on an iMac 2017, 64 GB ram, OS Catalina 10.15.7, LR vs 11.3.1 and have been using LR since the beta version.

 

TOPICS
macOS

Views

129

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Jun 11, 2022 Jun 11, 2022

My only remaining guess is LrC is applying an automatic lens correction to the file which might not display all the pixels and when you use Transform LrC turns this off.  Someone with your camera will have to chime in.  A very interesting problem which I look forward to seeing what your solution is.  

Likes

Translate

Translate
LEGEND ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

Do you have an In-Camera aspect ratio set that is different from the default.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

No, I have never used a different aspect ratio in-camera because I shoot in raw.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

On my camera I can set in-camera aspect when I shoot RAW.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

You're right. What I should have said was that I don't bother doing it in camera because it's easy enough to change it in LR. Sorry about that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

What camera are you using.  The Aspect of your posted full size photo is 4:3 so is not the usual 3:2.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

I have an Olympus OM-1, which is a 4/3rds camera.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

My only remaining guess is LrC is applying an automatic lens correction to the file which might not display all the pixels and when you use Transform LrC turns this off.  Someone with your camera will have to chime in.  A very interesting problem which I look forward to seeing what your solution is.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

LATEST

OMG, Bob, you hit it on the head. I've been using Olympus cameras for 11 years and for my older cameras, if I checked Ebnable Profile Corrections, LR would say it was built-in. I got this camera a month ago and it never occurred to me that the new Olympus company would change that, but it's now available & LR did it automatically. Thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

The first thing that you should try is to switch off the GPU support from the Lightroom preferences and check if that helps to fix the issue.

Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor" > Restart Lightroom.

https://helpx.adobe.com/lightroom-classic/kb/lightroom-gpu-faq.html#troubleshooting

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html

 

Another step is to try to reset the Lightroom preferences.

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

It's recommended to backup your preferences before you reset the preferences to the default settings:

https://helpx.adobe.com/lightroom-classic/kb/preference-file-and-other-file-locations.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

Thanks for your answer. First, I went to LR prefs and there is no unchecking of "Use Graphics Processor: It's options are only "Auto, Custom, or Off." I chose "Off," shut down LR, & restarted the computer. Same issue.

Next, I went to Finder> Library> Prefs> com.adobe.LightroomClassicCC7 and moved it to the Desktop, then shut down LR, & restarted the computer. Same issue.

Next, I opened the plist file into TextEdit & searched for the line "useAutoBahn = true" as mentioned in your second link above. There's no such wording in the file. The closest it came was this: AgEditExternally_formatOptions_ExpansionState_TouchWorkspace_autoEnterMode[useAutoBahn_AgMultiMonitor_autoResize_"AgCameraRawNamedSettings_grayMixer_AgDevelop_dustSpotFeather_LoupeVerticalGestureMode_Location_cityFieldEnabled_0AgTemplateBrowserDataModel_copied_ExternalEditor_!

I still have the same issue.

I've included a short video to show the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

Do you have "Constrain Crop" enabled in the transform section?

 

If you go into the Crop tool afterwards, do you see the entire image outside of the crop boundaries?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

In Transform, Constrain Crop is unchecked. I've included a png of the crop using the crop tool and it shows only what the image shows — none of the info that I see when using Transform.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines