• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

LR On New 14" MacBook Pro Not Using All Screen Real Estate

Community Beginner ,
Jan 01, 2022 Jan 01, 2022

Copy link to clipboard

Copied

Happy New Year all! Curious, anyone else running into an issue where Lightroom isn't using all the screen real estate on the new 14" M1Max MacBook Pro? It's super weird, I'll be in any other program and everythign is fine, but when I select Lightroom it shrinks the part of the screen it uses and the 'digital bezel' around it increases. Pic attached showing difference from desktop to Lightroom. I've tried all screen options from default to scaled. Think I checked all options in Lightroom. Anywho...figured I'd give it a shot here and see if anyone else had that cosmic weirdness and if so, how you fixed it. 

 

lightroom-cosmic-weirdness.jpg

 

TOPICS
macOS

Views

2.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jan 02, 2022 Jan 02, 2022

@wasimofnazareth wrote:

I've tried all screen options from default to scaled. Think I checked all options in Lightroom.


 

For the new MacBook Pros with a menu bar notch for the camera, there is probably not an option in Lightroom Classic that you will find that will change this.

 

What will probably change this is an option in macOS itself. For the notch Macs, macOS offers a new option called “Scale to fit below built-in camera.” You will find this by switching to the Mac Finder desktop, select

...

Likes

Translate

Translate
Community Expert ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

What you're seeing is normal for the 2021 14/16 inch MacBook Pros. The area either side of the notch can only be used by app or OS for menus.  However, Lightroom has an option that displays the app UI using all of the screen area below the menu/camera strip. This can be found under the Window > Screen Mode menu options as shown in below screenshot.

 

Untitled-1.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Oh cool! Thanks for that Ian! That worked (to an extent...). So when I first switched it using your recommendation, it looked great, I worked on some images, was excited, did the thing, but when I went to use the 'L' button (lights out mode) to dim the area around the image to check my progress, it reverted to just using the center part of the screen again, even on the left and right sides of the screen, and wouldn't go back to using the full screen again until I quit and relaunched LR. Here's screenshots of the progression from one mode to another and then back to filmstrip/develop mode. You'll see how the whole usable screen area shrunk from the top photo to the bottom photo with the lights out modes in between. I feel like there might be a bug or somethign with the lights out mode on the new screens. 

 

lr-lights-out-cosmic-weirdness.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Did you ever figure out this issue? I'm experiencing the same thing when I press 'L' to swich lights out modes. I have to full quit LrC and start it up again to regain the full screen real estate. 

 

If you didnt figure it out, did you report the bug? If so please share the link so i can upvote it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Yes, please see the post marked as "correct answer" in this thread. It has to do with MacOS's handling of apps that scale to fit below the notch. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

I'm not sure that we're on the same page.

 

LrC works perfectly fine with my MBP with notch.

 

The issue is that, while LrC is full screen and the LrC menu bar is correctly located next to the notch, if I press the letter "L" on my keyboard (which is supposed to simply "dim" the lights by making the LrC panels and background dim), then something happens to the entire UI.

I can only assume that it is a bug, becuase the second I press "L" then the LrC window changes sizes and the LrC menu bar relocates itself to be below notch instead of beside it.

 

Is this an issue with macOS or is it an issue with LrC?

 

How does pressing the letter "L" affect the way macOS handles apps that scale to fit below the notch? To be precise... i DONT wan't it to be scaled below the notch. I want it to behave just like it does before I press the letter "L". 

 

Do you own a MBP with notch? Could you test this for me to see if you see the same issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Yes, actually we are on the same page. For some reason Lightroom doesn't drop below the notch until you've manually put it in full screen mode, and then it stays below the notch until you quit and restart. If you uncheck the box in the Finder info window, it won't ever drop below the notch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Looks like i was wrong! Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 01, 2022 Jan 01, 2022

Copy link to clipboard

Copied

Happy New Year all! Curious, anyone else running into an issue where Lightroom isn't using all the screen real estate on the new 14" M1Max MacBook Pro? It's super weird, I'll be in any other program and everythign is fine, but when I select Lightroom it shrinks the part of the screen it uses and the 'digital bezel' around it increases. Pic attached showing difference from desktop to Lightroom. I've tried all screen options from default to scaled. Think I checked all options in Lightroom. Anywho...figured I'd give it a shot here and see if anyone else had that cosmic weirdness and if so, how you fixed it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied


@wasimofnazareth wrote:

I've tried all screen options from default to scaled. Think I checked all options in Lightroom.


 

For the new MacBook Pros with a menu bar notch for the camera, there is probably not an option in Lightroom Classic that you will find that will change this.

 

What will probably change this is an option in macOS itself. For the notch Macs, macOS offers a new option called “Scale to fit below built-in camera.” You will find this by switching to the Mac Finder desktop, selecting the Lightroom Classic application icon (not the folder), choosing File > Get Info, and changing the setting “Scale to fit below built-in camera.”

 

Lightroom-Classic-Scale-to-Fit-below-Built-in-Camera.jpg

 

When the option is on, a Mac application will act like it always has on older Mac laptops: It will stay below the camera (notch), so you will always see all of the menu bar. When the option is off, a Mac application will extend up to use all of the screen area available on the M1 Pro/Max MacBook Pro, but then the notch must be visible.

 

If the option is enabled for Lightroom Classic, you can get the effects you’ve seen: The area appears to change as you go in and out of full screen/Lights Out, and the available screen area seems to shrink or grow as you switch among applications that have that option set differently.

 

If the option is disabled for Lightroom Classic, it will use as much screen area as it can, but that means you will see a notch when Lightroom Classic is full screen.

 

Try it both ways and decide whether you like using Lightroom Classic better with the option enabled or disabled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Ahhhhh!! That's exactly what I was looking for. Thanks so much Conrad. It was already checked and once I unchecked it and relaunched LR, it now uses all the real estate. The notch really doesn't bother me, so this is perfect. I appreciate that. Didn't know that checkbox existed. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

Thank you so much for this thorough response! I had no idea that checkbox existed either, and I thought I was losing my mind because Lightroom kept shrinking down the entire UI. This is the solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

I don't understand the bit about going to mac finder desktop,selecting the Lightroom icon (not file). I pressed Finder icon on my toolbar, then went to applications and clicked on LR icon but all that does is open up LR again. What am I missing?

Thanks Gail

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

You need to right-mouse click on the 'Ligtroom Classic' application icon (i.e. the same one you double click to launch the application), then choose 'Get Info' from the context menu.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied


@GailBisson wrote:

and clicked on LR icon but all that does is open up LR again. What am I missing?


 

If Lightroom Classic opens, then it was not clicked, it was double-clicked. Try again, but this time, just click once to select (not open) the application icon, then follow the steps I wrote and showed in my earlier post above: Choose File > Get Info, and that Info window has the option in it.

 

(You can also open Get Info by right-clicking the application icon, if your Mac is set up that way. A lot of people don’t enable right-click on their Macs, so I send them to the menu command first.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2022 May 14, 2022

Copy link to clipboard

Copied

I also encountered such a problem but never solved it because the worst was memory loss due to a broken hard drive. The hard drive is where all the information basically contained in the laptop is stored. Breakdowns can happen for many reasons, from power surges to drops, as in my case. To get all my documents back, I spent a lot of time looking for a data recovery (link removed by moderator) specialist. By the way, your problem may be due to a small number of unreadable sectors in the user area of the hard drive. But this is my guess, were you able to solve this problem?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2022 Jun 03, 2022

Copy link to clipboard

Copied

Thank you for this! So initially I followed all your instructions and unchecked the box, but every time I opened lightroom and tried to full screen, it still sat beneath the bezel.  I thought I had to restart my M1 Macbook Pro and I did... but still nothing happened.

So as I was about to lose my mind, I found the additional solution: Step 2: After reopening lightroom, manually enter full screen by clicking CMD + SHIFT + F

 

After doing the full screen shortcut, the program will enter full screen mode and the notch won't be an issue anymore. Wooooo! So happy. haha. Thanks for your help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 03, 2022 Jun 03, 2022

Copy link to clipboard

Copied

LATEST

@Miraflor98 wrote:

So as I was about to lose my mind, I found the additional solution: After reopening lightroom, manually enter full screen by clicking CMD + SHIFT + F


 

Just a fun fact that might explain the difference sometimes:

Lightroom Classic supports two different full screen modes.

 

Lightroom Classic has its own full screen mode, which you go in and out of by choosing one of the Window > Screen Mode commands or pressing its F and Shift-F keyboard shortcuts. This is independent of the OS full screen modes in macOS or Windows.

 

Lightroom Classic also supports macOS full screen mode, which you go in and out of by choosing Window > Enter Full Screen, pressing the Command-Shift-F keyboard shortcut, or clicking the third button in the window title bar (the green one).

 

If something is not working as expected in full screen mode, it helps to know that these two different full screen modes coexist so that you make sure you’re in the one that will do what you expect.

 

(There are other Mac apps that have their own full screen modes instead of or in addition to the OS full screen mode, such as Adobe Photoshop, Illustrator, and InDesign, and VLC.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines