• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

LrC 13 crash when using preset in lrtemplate format

Community Beginner ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

It seems that newly installed LrC 13 crashing when I try to use preset for my old (by Adobe unsupported) lens Sigma 20-40mm/2.8. Preset is in lrtemplate format.

Here is content of the file opened in notepad++:

s = {
id = "1E1AE886-D25F-46D3-97A5-7F935B890AA5",
internalName = "LR_predvolba_Sigma_20mm_vinetace+CA",
title = "LR_predvolba_Sigma_20mm_vinetace+CA",
type = "Develop",
value = {
settings = {
AutoLateralCA = 1,
ChromaticAberrationB = 0,
ChromaticAberrationR = 0,
Defringe = 0,
DefringeGreenAmount = 0,
DefringeGreenHueHi = 60,
DefringeGreenHueLo = 40,
DefringePurpleAmount = 0,
DefringePurpleHueHi = 70,
DefringePurpleHueLo = 30,
EnableLensCorrections = true,
ProcessVersion = "6.7",
VignetteAmount = 54,
VignetteMidpoint = 100,
},
uuid = "B4C754DF-34F7-4C55-8B54-01F11DE3B277",
},
version = 0,
}

I was able to remove the preset, but LrC keep crashing, when I try to see the photo I used the preset on in Develop lupe view. Reinstalling LrC didn't help.

Here is my system info:

 

Lightroom Classic 13.0
Windows 11 Pro (22H2)
NVIDIA GeForce RTX 4080

TOPICS
Windows

Views

262

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 11, 2023 Oct 11, 2023

This preset format has been obsolete since Lightroom Classic 7.2! If has to be converted to .xmp before it can be used, so how did you manage to use it in the first place?

 

Votes

Translate

Translate
Community Expert ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

This preset format has been obsolete since Lightroom Classic 7.2! If has to be converted to .xmp before it can be used, so how did you manage to use it in the first place?

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Thank you for the answer.

I just used "Add new presets" dialog (+ icon).

It's not a big issue for me as I still have LrC 12 catalog (and I didn't do any serious work in LrC 13), so I will just update it into LrC 13 format again. But I guess using presets in .lrtemplate format should give error message and not allow them to be used.

I will try to find some info on converting presets.

Thanks again

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

They should indeed give an error message and not allow the import. No idea why you did not get that.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

"I just used "Add new presets" dialog (+ icon)."

 

That's the correct way to convert and import an old-format .lrtemplate preset to the new .xmp format. I put those settings into a .lrtemplate file and successfully converted/imported it into my LR.  That preset works fine in my LR 13.

 

Next steps:

 

1. When you applied the preset, did you see a crash report window appear and prompt you to submit it to Adobe? 

 

2. Did you enter the same email address you use for your Adobe account?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

Thank you for reply

quote

"I just used "Add new presets" dialog (+ icon)."

 

That's the correct way to convert and import an old-format .lrtemplate preset to the new .xmp format. I put those settings into a .lrtemplate file and successfully converted/imported it into my LR.  That preset works fine in my LR 13.

By @johnrellis

 

Is there way to know if .lrtemplate preset was converted into .xmp format? I guess Lr does it in background.

In case you want to try the original preset, I zipped it and uploaded to server. Here is the link:

http://fotonomad.cz/images/Lr_preset_delete_23-11/lrtemplate_preset.zip

 

1. When you applied the preset, did you see a crash report window appear and prompt you to submit it to Adobe? 

 

2. Did you enter the same email address you use for your Adobe account?


By @johnrellis

 

1. The LrC got unresponsive and in minute or so crash report appeared. I sent it to Adobe.

2. I think I did.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

"Is there way to know if .lrtemplate preset was converted into .xmp format?"

 

In the Presets panel, right-click the preset and do Show In Explorer / Finder. That will open Explorer or Finder on the imported preset, and it will have the ".xmp" extension.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

After updating to LR 13.0.1, which just came out yesterday, do you still get the crash?  

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

LATEST

It works as it should - no crash. Thanks again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

Thanks. I found the preset in the Explorer and it is in the .xmp format. I already use LrC 13.0.1.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines