• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

LrC not syncing with Lightroom Web App - Started after April 3rd, 2023 Lightroom Updated to v12.2.1

New Here ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard


My LrC auto-updated on April 3rd, 2023 and since then, the Lightroom Web App (lightroom.adobe.com) hasn't been able to sync back with LrC.


This is long, and descriptive, but all in an effort to provide context and detail to my sync issue, and to hopefully limit the amount of comments that would suggest I do things I have already done.


The History:
I have been using LrC for four years and have run into syncing issues in the past. I've run through the typical check "sync errors", delete images with sync errors, rebuild sync data, etc troubleshooting methods in the past which have worked at times, as well as this time, but this time it has been to to no avail.


Before April 3rd, 2023, I imported several new collections to my catalog in LrC, and it synced immediately to the Web App. This was within the last week or two. My assistant then opened the Web App on her computer and culled (flagged) the best photos in those collections so that I could later go back in to LrC and make the edits to the photos she had culled. This is our regular workflow and has been working since last year with no sync issues.


My original files are all stored on three separate external SSDs, and are of course always plugged in on import, and LrC has always continued to sync with the WebApp evenwhen these externals are not plugged in. I have found in my own research of LrC, that the Web App only syncs smart previews, and since original files are not needed to create smart previews in the first place, I have always believed that the originals don’t affect syncing with the Web App. *I think it should be noted that my assistant only flags photos, without making edits, so the syncing that goes on between my LrC and the Web App is only to sync the flags.


The Problem:
On April 3rd my LrC app auto-updated from its current version (either 12.1 or something recently before that version - not sure how to find out which version I had before at this point) to version 12.2.1. Since then, the new collections I had imported while LrC was in the previous version only a week or two ago - and which synced already and fully to the Web App - will not sync back with LrC from the WebApp. One collection in LrC, for example, shows the same number of total images (615 RAWs) as it shows in the Web App, but then only shows 42 flagged photos in LrC, while the Web App shows 113 photos have been flagged by my assistant.


Things to Know:

  1. I have one Lightroom catalog I use for all my collections (it has worked for me as long as I have used Lightroom)
  2. My catalog has 332,924 photos
  3. My cloud storage shows 63.4MB of 100GB used as of right now.
  4. The Web App shows only 327,725 photos there.
  5. LrC shows 328,607 in All Synced Photos
  6. No matter what I have done, the Sync Settings panel shows "No Sync Activity" and "0 Uploading/0 Downloading/0 Pending" - it even shows this when sync is turned on and shows that 328,384 photos are being synced.

What I Have Already Tried:
I researched the forums and sites for anyone else experiencing this issue to see what they have done. I have already:

  • Closed and reopened Lightroom
  • Rebooted my computer
  • Clicked "Rebuild Sync Data" in the Sync Settings panel
    • I get the warning that says "This will take a long time" and I click 'Continue'
    • The warning dialog closes
    • Lightroom restarts immediately
    • As far as I can see, nothing has been rebuilt or changed and literally takes 5 seconds from start to finish. So the dialog doesn’t make sense. Is this normally how Lightroom “Rebuild Sync Data” is supposed to work?
  • Paused & restarted sync in LrC
  • I have also done a number of combinations of the things listed directly above, as several forums said to do in certain orders.
  • I chatted with an Adobe tech support specialist yesterday for two hours.
    • He suggested doing all of the above, as well as deleting any sync error images in the Web App. I had 609 sync errors, and deleted all of them, even from the "Deleted" folder. Mind you, these error images have been there for some time and have not stopped LrC and the Web App from syncing in the past. But I did it because the tech guy told me to.
    • Nothing he told me to do while in the chat worked, so he then took control of my computer.
      • While in control, he:
        • looked through my collections
        • looked at the sync settings panel
        • went through the same “rebuild sync data” process as described above
        • saw that the sync window was frozen with 328,445 images syncing, but was not going anywhere.
        • pointed out that lightroom had 218,710 or so missing original images in my catalog, which I told him is likely due to the fact that over the past few months/years I have regularly deleted old enough client galleries to free up space on my external SSDs. And please remember, that syncing has always functioned for these collections in the past.
        • and finally reopened Lightroom with my last catalog, which he updated to work with the current 12.2.1 version of LrC.
          • this catalog began syncing 328,384 or so images immediately, which he noted.
          • we opened the sync settings panel and I pointed out to him that although it said it was syncing, and the numbers were going down, the sync activity still showed “no activity” and “0 syncing/0 pending/0 synced"
        • His two “solutions” for me were to
          • 1 - Use my old catalog - because it was showing that it was syncing, despite the sync activity issue, and re-import all collections to it and wait for it to resync.
            • This would mean re-importing every current collection, which is at least 50 collections, manually, reculling each of those collections that I have already been editing, and then wait for them all to resync. ALL WHILE CLIENTS ARE WAITING ON THEIR GALLERIES.
            • This also doesn’t make sense to me because as mentioned before, LrC had already synced all my galleries with the Web App, but at this point I cannot get the Web App to sync the flagged images back to LrC.
          • 2 - Use my most current catalog, where the syncing is frozen, and find where all 218,710 missing images are, and locate them in the external SSDs. He tried to explain that these missing images are likely causing the sync errors and that by locating them LrC should be able to finish syncing. Please let me remind you, as I reminded him, that many of those, if not all of those missing images are from RAW folders on my external SSDs that have been deleted because they are old enough and have already been delivered to my clients - and had already synced with the Web App when I was editing them.
            • This would also take an obscenely long amount of time, and still doesn’t make sense to me why it would cause a sync issue, when syncing to the Web App only requires Smart Previews, which don’t need to have originals around to be created.


Both of the final “solutions” the tech specialist gave me seem grossly short of any real solution. And I’m still hung up on a few things.

  1. LrC has been working and syncing fine up until literally the day it updated to v12.2.1.
  2. LrC had already synced the full galleries, as exampled above, of many collections, and after the update won’t fully sync from the Web App back to LrC. And mind you, it’s only trying to sync the flagged marks on the photos, not any edits.


After this tech support specialist tried his hand at correcting my problem, I also tried to revert LrC back to the version before this update. So I uninstalled LrC, while keeping all other folders related to my catalogs and collections, and reinstalled v12.1. This also did not fix the sync issue.


I have a most recent Sync Diagnostic Report, but it's a .html file which can't be uploaded here. I have at least attached some screenshots.


If you made it this far, thank you for reading. I wanted to be descriptive so I don’t have any pointless comments about things I have already tried. I appreciate any and all advice anyone can give about how to fix this issue.


All I need is for the Web App to be able to sync the flagged images back to LrC so that myself and my assistant don’t have to duplicate any work we have already done, and so that my assistant can continue culling images from the Web App in the future.


[Moved from ‘Bugs’ to ‘Discussions’ by moderator. For an explanation why, read this https://community.adobe.com/t5/lightroom-classic-bugs/p-do-i-post-in-discussions-or-bugs/idi-p/13691...]







Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2023 May 11, 2023

Copy link to clipboard



Maybe a bit late, but I have difficulties getting sync to start when the catalogue has not been backed up.





Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines