Lrc Version 11.x not compatible with MacOS

New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

I'm running MacOS High Sierra 10.13.6 (and can upgrade to Catalina) on a 2013 iMac.  I am being asked to upgrade to Lightroom 12.0 but this is not compatible with my OS/Mac.  Is there anything I can do, aside from accessing Lightroom online instead? 

TOPICS
macOS

Views

159

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

I am being asked to upgrade ...

 

There shouldn't be any problem staying with your current version of Lightroom Classic. There should be no problem upgrading to and using LrC 11.2 on Catalina. (There is no such thing as Lightroom 12.0, doesn't exist)

 

Who/what is asking you to do this upgrade? What is the exact word-for-word message?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

I am attaching the two screen shots.  I cannot load new images into Lightroom on my mac and get the first message.  When I go to upgrade I am then told the upgrade is not compatible.  If I can stay with the current version I will be very happy as it works fine for what I need it for, but from what I can see, I can't.  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

My web browser does not display attached screen captures. Please use the "Insert Photos" icon to include your screen captures in your reply.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

Screen Shot 2022-03-14 at 12.54.23.pngScreen Shot 2022-03-14 at 12.53.40.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

Screen Shot 2022-03-14 at 14.06.28.png

When I click on 'Not Compatible' this is what it shows, and doesn't go to anything. Just taking me round in circles.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

What an odd (and poorly written) message. Even Adobe makes the mistake of referring to Lightroom Classic as Lightroom.

 

So yes, if you upgrade your operating system to Catalina, all the upgrades will be available and should work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Thank you for your help. For the moment it worked by updating to Catalina and I can now access all Adobe apps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

LATEST

@Amy23576994g5f0 wrote:

Screen Shot 2022-03-14 at 12.54.23.pngScreen Shot 2022-03-14 at 12.53.40.png



This message is correct, but needs some explaining. The online database version has changed, and so you need a minimum version of Lightroom and Lightroom Classic if you want to continue to sync them. See also https://helpx.adobe.com/lightroom-classic/kb/upgrade-required-syncing-with-lightroom-mobile.html

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines