• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

(M1) Out of memory

New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Hi. Just upgarded to new Rls 12 and now Im getting messages about running out of application memory after about 5 mins of using LRC. No other applications being used. Anyone else having this issue.

 

I have a MavcBook Air(M1, 2020) with 16Gb Ram running 12.6 Monterey

 

Thanks in advance

TOPICS
macOS

Views

159

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Please advise specifics of, HDD internal and external, including free space on the drives.

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.7.1 BigSur,; LrC 12.0.1, Lr 6.0, Ps 24.0, ACR 15.0,; Camera OM-D E-M1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

D912B1BA-EE99-44F7-81C1-8EAF77B2C5AC.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

It was also be helpful if you would upload a screenshot of the Memory tab for Activity Monitor when memory message appears (see below for an example of what I'm requesting).

 

Untitled-1.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

3D108FB7-BEC7-4521-BBCA-6F3AC43BAECF.jpegD668E28D-3765-418F-8B36-6E1AC71E97F1.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Thanks for the screenshot, it certainly shows that LrC is using nearly six times the available physical memory available. Also, the Memory Pressure graph isn't what I would expect to see, even when memory is being pushed hard. Typically, the graph would show yellow before red. Yet, your graph goes from green to red without ever showing yellow first. Therefore, it would be important to explain exactly what it was that you doing prior to the Out of Memory message.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Thanks Ian

 

I was exporting a slideshow from LRC. I could do this no problem in LRC prior to upgrade.  I am unbale to supply a system info right now as I tried LRC again and it stopped responding. Will post after I restart

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Can you provide more specifics on the slideshow (i.e. number of images, output size, still or video > type, etc)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

I forgot to request that you copy / paste your 'System Info' to forum. This can be found in the LrC Help menu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Lightroom Classic version: 12.0 [ 202210031128-9cb7185d ]
License: Creative Cloud
Language setting: en-GB
Operating system: Mac OS 12
Version: 12.6.0 [21G115]
Application architecture: arm64
Logical processor count: 8
Processor speed: NA
SqLite Version: 3.36.0
Built-in memory: 16,384.0 MB
Real memory available to Lightroom: 16,384.0 MB
Real memory used by Lightroom: 1,819.0 MB (11.1%)
Virtual memory used by Lightroom: 403,689.7 MB
Memory cache size: 7.5MB
Internal Camera Raw version: 15.0 [ 1261 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2
Camera Raw virtual memory: 0MB / 8191MB (0%)
Camera Raw real memory: 1MB / 16384MB (0%)
Standard Preview Size: 2880 pixels
Displays: 1) 2880x1800

Graphics Processor Info:
Metal: Apple M1
Init State: GPU for Export supported by default
User Preference: Auto

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/LRC_Photos/Lightroom_Catalog/Mark_LR_Catalog-v12.lrcat
Settings Folder: /Users/marklaslett/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Flickr
4) HDR Efex Pro 2
5) Plugin Parameters
6) Teekesselchen

Config.lua flags: None

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

It also wont let me close LRC without the application hanging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Looking at your 'Activity Monitor' Graph again, I see that there is no indication of swap being used nor has the memory used exceeded the 16GB available on your system. I'm really not sure how this can be, and certainly isn't something I've come across before.

 

As a sanity check, I've just used my Mac mini M1 with 16 GB memory to export a 200 file sideshow with 90% 1920px jpegs and LrC 12 memory use never exceeded 2.4GB. I then exported the same 200 files as a 1080P video and LrC 12 memory use didn't 2.8GB.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Lightroom on the M1 has been plagued with memory leak bugs such as this ever since a M1 capable version was released. On the original operating system versions for M1, this memory leak would be triggered by setting your mouse cursor to be a different color than the default which was just maddeningly hard to figure out (it's in the accessibility control panel->Display->Pointer - anything but the default values here would lead to out of memory errors on M1). That said, it would be helpful if you could describe how you use Lightroom. Do you do a lot of AI masks, brushing, etc? Do you have any third party system/antivirus/etc/ tools installed? Just so the Adobe folks can take a look at whether there is a trigger.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Thanks

 

I mainy use LRC for cataloging. Mostly do Crop and auto adjust. Use Ai stuff a bit not a great deal. 

 I do have Nik Effects installed and Topaz De-Noise.

 

I have no 3rd party anti Virus software installed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Do you have a lot of custom presets installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Nope

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

LATEST

Have you tried resetting LrC preferences? If not not, then worth a try as doing so often resolves weird issues that typically arise after the application is updated. More details on how to reset the preferences can be found at https://helpx.adobe.com/lightroom-classic/help/setting-preferences-lightroom.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines