• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Mac High Sierra 10.13.6 not compatible with Lightroom C

New Here ,
Apr 06, 2023 Apr 06, 2023

Copy link to clipboard

Copied

Hi there,

Please help! I am unable to update my MAC OS further from 10.13.6, the adobe application like Photoshop and Lightroom classic need mac 10.14 or above to use last available version. What options do I have to download Lightroom and Photoshop for the older version of Apple Mac. I currently have the Photography Plan with Adobe. 

TOPICS
macOS

Views

102

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 06, 2023 Apr 06, 2023

Copy link to clipboard

Copied

see:

(ref 1): Lightroom Classic system requirements | earlier releases | Adobe

 

from (ref 1) you can look at the system requirements for previous LrC versions (pre v12)

 

I think that you will find that you are limited to LrC v9

 

(ref 2): Lightroom Classic 9.x system requirements | Adobe

 

while LrC v10, is a no go

 

(ref 3): Lightroom Classic system requirements (v10) | Adobe

 

Now, next issue is how to download v9. The Adobe Creative Cloud Desktop App, normally only shows the last two versions. But, I am not sure if it will note that neither version is available for your OS and be nice and show you v9.

 

Following from another posting, relates to how to install older version

 

"You have to contact the Adobe support and ask for an download link for the appropriate version of Lightroom.

Contact Customer Care (adobe.com)

Click on the Chat icon at the lower right. If asked, choose the “Download & Install” category, or type in "agent" to get a human and not the chat bot." credit: Axel Matt

 

from: https://community.adobe.com/t5/lightroom-classic-discussions/older-version-of-lightroom-10-x-for-osx...

 

 

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 06, 2023 Apr 06, 2023

Copy link to clipboard

Copied

LATEST

There are ways to get higher OS versions via patchers from Dosdude1. Disclaimer: Entirely unofficial, so the call to try it is yours and yours alone. I had Mojave on a 2008 Mac Pro. Catalina is the highest though. Just google 'dosdude1' and decide if it's worth a try. 


Sean McCormack. Author. Magazine Writer. Former Official Fuji X-Photographer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines