• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

MBP M1: Folders disappeared upon upgrading LRc

Community Beginner ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

I use LRc on a Macbook Pro M1. I recently upgraded to the newest version of LR classic (12.0 release camera raw 15.0). Since then most folders disappeared from the catalog. LRc says there are 32.068 photos in the current catalog, but 29.107 of them are missing...

I tried to use now the older copy of the catalog that I used before the latest software update on October 17th. Interestingly, LRc had to update the catalog into a new format, before I could use this catalog in the new LRc version (now I remember that the format of the catalog was changed upon this latest update). Now I can find more folders, but by far not all of them...

=> I think the problem arose from the reformatting of the catalog that is required for the new software version of LRc.

 

Thanks, Wolfgang

TOPICS
macOS

Views

68

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

=> I think the problem arose from the reformatting of the catalog that is required for the new software version of LRc.

 

Unlikely. The "missing folders" or "missing photos" problem is almost always that the photos are no longer on the same disk as previously, no longer in the same folder as previously, or the file name has changed. Please follow these instructions to fix the problem: https://www.computer-darkroom.com/lr2_find_folder/find-folder.htm

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Hi dj-page,

Unfortunately moving the folders/files is not the problem: when I move my directories, after postprocesing, to my NAS, the folders are still listed in the catalog, but are faded out and show a questionmark. I have to tell LRc then, where the folders can be found...

=> this time the folders disappeared completely.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

I have to tell LRc then, where the folders can be found...

=> this time the folders disappeared completely.

 

This is exactly what should happen, the folders seem to "disappear". They don't actually disappear, they are now seen in Lightroom Classic on a different drive, the NAS drive, with all links intact, no photos missing (assuming you did it properly)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Is the catalog by any chance stores on an external disk? There is a bug in LR C 12.0 when used on Mac OS X Ventura where catalogs on external disks get corrupted when upgraded to the new format. There is a fix fo this in the just released update to LR C. 12.0.1 so try updating your Classic install to 12.0.1 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Hi Jao VdL,

The catalog itself is on the SSD of the MBP M1. Just most folders are moved (after iage procesing) to an external NAS. So far, this never was a problem, it was always easy to tell LRc where to find the folders after moving...

 

LRc is as the newest version avaiable (v 12.0.1), so is the OS (Monterey, v 12.6)...

 

Thanks, Wolfgang

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

LATEST

I have a similar setup. Catalog on internal SSD on my i9 MBP. Most images (few 100k of them) on a NAS. Haven't had a problem with the upgrade and certainly no disappearing folders (knock on wood). I still wonder about the exact sequence of events that led to your issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines