• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Mojave/Lightroom Classic

Explorer ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

Ive just had a major crash and managed to restore all files. However I am running Mojave on my Mac Pro 5.1 and cannot install the older version of LR from the Creative Cloud desktop – I hope this is possible ?

TOPICS
macOS

Views

137

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 18, 2023 Nov 18, 2023

Thank you.

Votes

Translate

Translate
Community Expert ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

What older version of Lightroom.? Be very specific and include the numeric version number, e.g. Lightroom  version 6.14.

Regards, Denis: iMac 27” mid-2015, macOS 11.7.10 Big Sur; ( also laptop Win 11, ver 23H2; LrC 13.3.1,;) 2TB SSD, 24 GB Ram, GPU 2 GB; LrC 12.5,; Lr 6.5, PS 24.7,; ACR 15.5,; Camera OM-D E-M1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

I think it was version 7.5

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

If so you would be paying an annual or monthly subscription. 

Regards, Denis: iMac 27” mid-2015, macOS 11.7.10 Big Sur; ( also laptop Win 11, ver 23H2; LrC 13.3.1,;) 2TB SSD, 24 GB Ram, GPU 2 GB; LrC 12.5,; Lr 6.5, PS 24.7,; ACR 15.5,; Camera OM-D E-M1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

I am asking if I can install this older version from Adobe so I can run LR with Mojave.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

You should contact Adobe, and they can provide a link.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

LATEST

Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines