New mask toolbar "+" engages flyout menu, but menu immediately disappears.

Community Beginner ,
Dec 02, 2021 Dec 02, 2021

Copy link to clipboard

Copied

New mask toolbar "+" engages the adjustment tool flyout menu, but the menu immediatley disappears, requiring a second press of the "+" to access the tools (select subject/sky, brush, linear/raidial filter, etc.)

 

Doesn't sound like a big deal, but quite annoying to press a button, then have the action fail, resulting in repeated clicking and aimless cursor action.

 
Macbook Air M1
MacOS Monterey 12.0.1

Current Lr CC Version

 

It also happens on various iMac terminals in the studio, so it's not isolated to the M1. Due to the fact that it happens less when I'm careful not to move the cursor, after clicking the "+", I believe that the issue may be in the :hover function.

 

Thx for looking into it...

TOPICS
macOS

Views

148

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

I am unable replicate this on Mac M1 with 12.0.1 and Lightroom Classic 11.0.1.

Please go to Help>System Info… and get us the exact installed version number of your software.  There hasn't been any Lightroom version that used "CC" for several years. 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

I did a bit of trial and error and narrowed it down to my Logitech M720 Triathalon BT mouse, in combination with their Logitech Options software... it's their bug, not Adobe's.

 

When I run the mouse without the Options software, it works fine - when I install Options, it's ok for a while, but will revert back to glitching-out. The solution is to uninstall the buggy Logitech Options software.

 

Thank you for your reply.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Is LR in Window > Screen Mode > Full Screen or > Full Screen With Menu Bar?  Someone else reported that the mask layers panel disappeared in those modes, and that exiting to Window > Screen Mode > Normal caused it to reappear:

https://community.adobe.com/t5/lightroom-classic-discussions/mask-layers-box-disappeared/m-p/1255406...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

It's the Logitech Options software, in combination with my M720 BT mouse. The software is buggy with Lr and I solved it by removing the Options software, which is too bad because the functions that it offers are great.

 

Thank you for the repy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

Interesting -- there are other well-known problems with the Logioptions plugin, but this is the first I've heard of these symptoms.  Thanks for the update -- that could help others.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

It's a bothersome one and it happens on my Airbook M1 and on my iMac terminal, at the studio. It's something to do with the :hover property of the button itself, because I've learned to click while not moving the cursor at all, which seems to work... for the most part.

 

I've tried to report the issue to Logitech, but can't seem to find any type of bug report form.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

"I've tried to report the issue to Logitech, but can't seem to find any type of bug report form."

 

A number of years ago, when problems with the Logioptions plugin started appearing, I saw there were many threads in the Logitech forums about the problem, but there were no responses from Logitech employees.  I wonder if they've resolved the other problems with the plugin (slow startup of LR, error message when you delete photos) -- I don't recall seeing reports about them in the last year.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

By Logitech Options, are you referring to the plug-in, or the driver, or the control panel for the mouse? Three different bits of code.

The plug-in is a known piece of excrement.

.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

I'm referring to the Options package that I downloaded from the Logitech site - with the drivers and Options software. Options seems to be an issue for the M1 - as soon as I installed it, I also lost the ability to turn off the trackpad, which is an annoyance because a simple brush of the palm can take you from editing to nowheresville, in an instant.

 

One very important Options setting is the ability to turn off the thumb/gesture button, which I consider to be the most useless and improperly placed button in the history of mouse design - it's nearly impossible to avoid pressing it while attempting to grip and move the mouse, sending you into the "desktop quick view" screen, every time you hit it. 

 

For this function, alone, I need to run the Options software - otherwise, I'd remove it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Ok, but for thumb/gester button setting, do you need the plug-in, or is that outside of LrC, in the general Logitech Options controll panel?

 

A screenshot might help.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Ok... now you've sent me down the rabbit hole.

 

I was referring to the Options app settings to turn off the gesture button - what I didn't realize is that Logitech (apparently) installs it's own LR plugin, regardless of whether you install the Options app... and that plugin seems to be an issue for a lot of ppl.

 

Just starting a hunt for the plugin, now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

"Just starting a hunt for the plugin, now."

 

Do File > Plug-in Manager, scroll to Logioptions and select it, click Disable in the Status panel to the right. Restart LR.  No need to uninstall it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

LATEST

Thanks for that... no Logitech plugin present, but I got rid of FB, Flicker, etc. I don't run any other user added plugins.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

"the thumb/gesture button, which I consider to be the most useless and improperly placed button in the history of mouse design"

 

Maybe a strategically placed drop of superglue to stop the button from being accidentally pressed?  Talk about destructive editing... 😆

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2021 Dec 26, 2021

Copy link to clipboard

Copied

Superglue for the gesture button and a flap of carboard to cover the trackpad, which can't be shut off... it's the "Hillbilly Lightroom/Logitech Mod".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines