Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Norton Antivirus or iCloud causing problems on Windows 10?

New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Hello All,

I've been having periodic problems with Lightroom on Windows 10, main issue being horrible lagging in Library Module, sometimes it would stop responding, making it at times unusable.
At it's worse, I can select 10 or more images in Library, and it takes a good few seconds with nothing happening before they all select together. Sometimes just selecting one image takes a second or two.

Needless to say, the behaviour was driving me crazy.
I tried ALL the solutions that everyone suggests whenever you search LR problems, fixing LR itself, drivers, hardware, but no improvement...

Then I got a flicker where the desktop or window beneath LR would flicker into view. Searching on this got me thinking it was other software interfering, but which???
After more digging I found a suggestion it might be Norton Antivirus or iCloud.
I tried the Norton flicker fix mentioned in the article below and reinstalled iCloud and now all seems to be fine and LR feels slick and fast. Fingers crossed it was indeed the cause!
https://www.makeuseof.com/tag/fix-windows-10-screen-flashing-problem/
https://support.norton.com/sp/en/uk/home/current/solutions/v109267913

This may be common knowledge but despite a year or two of this problem to greater or lesser degrees, I hadn't seen this mentioned.
Just thought I'd pass this on in the hope it helps someone else.

All the best,

Al.

TOPICS
Crash or freeze, Performance, Problem or error, Windows

Views

109

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

LATEST

Thanks for posting this - hope it is helpful for others running into performance issues with Norton running in the background.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines